Turbocharge your Quanta LB6M - Flash To Brocade TurboIron - Big Update!

BabaMarta

New Member
Nov 27, 2019
1
0
1
Hello,
After flashing Quanta LB6M with the Brocade TurboIron version 07.4.00pT203, without any additional configuration on the switch, when you connect two devices via the switch and ARPING one with the other you receive double ARPING response( sending 1 packet receiving 2). That was not the case with the original firmware. Does anyone know how to fix this?
 

jezzy

New Member
Apr 18, 2020
7
0
1
Hi guys!
I just picked up a broadcom turboiron 24x used from Ebay, but the unit was sold without an operating system. Any way I can use this firmware and somehow flash my switch? without an OS, when loading putty, there's no command line. Ideas on how I can re-flash this with this technique?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,111
1,976
113
30
fohdeesha.com
Hi guys!
I just picked up a broadcom turboiron 24x used from Ebay, but the unit was sold without an operating system. Any way I can use this firmware and somehow flash my switch? without an OS, when loading putty, there's no command line. Ideas on how I can re-flash this with this technique?
Like, it doesn't even have a bootloader? there's no output at all over serial when it boots? If so, you bought a bricked switch
 
  • Like
Reactions: jezzy

jezzy

New Member
Apr 18, 2020
7
0
1
Like, it doesn't even have a bootloader? there's no output at all over serial when it boots? If so, you bought a bricked switch
ive just realized it doesn’t use a null modem cable so I’m on the hunt for a straight though serial cable. I’m missing an adaptor. I will try again once I get it.
 

jezzy

New Member
Apr 18, 2020
7
0
1
Hi guys!
I just picked up a broadcom turboiron 24x used from Ebay, but the unit was sold without an operating system. Any way I can use this firmware and somehow flash my switch? without an OS, when loading putty, there's no command line. Ideas on how I can re-flash this with this technique?

yes! the straight through cable works. I have working terminal access..!
 

Cabuzzi

New Member
May 7, 2020
2
0
1
Hey everyone. I have flashed a few of these switches without any hitches, but am kinda stuck on one I'm doing for a friend.

Basically, it's flashed and all is well, but when I went to log into the management interface via putty, it didn't like the password. I'm 110% sure of the password, so it doesn't make any sense to me. After what seemed like 100 tries, we finally decided to just reflash it... but it seems like the password is somehow persistent. I can interrupt the boot menu using a serial cable, but there doesn't seem to be a clear "reset" option.

How is the best way to reset the login/password after it's flashed over to the Brocade firmware?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,111
1,976
113
30
fohdeesha.com
Hey everyone. I have flashed a few of these switches without any hitches, but am kinda stuck on one I'm doing for a friend.

Basically, it's flashed and all is well, but when I went to log into the management interface via putty, it didn't like the password. I'm 110% sure of the password, so it doesn't make any sense to me. After what seemed like 100 tries, we finally decided to just reflash it... but it seems like the password is somehow persistent. I can interrupt the boot menu using a serial cable, but there doesn't seem to be a clear "reset" option.

How is the best way to reset the login/password after it's flashed over to the Brocade firmware?

so you must have set a password, because by default there is no password. you can try stopping it in the bootloader and running "no password" then "boot" and it should boot, temporarily not asking for your password. can you post your entire boot output? it sounds like it didn't get flashed all the way if it's asking for a default password (brocade doesn't have one)
 
  • Like
Reactions: Cabuzzi

Cabuzzi

New Member
May 7, 2020
2
0
1
so you must have set a password, because by default there is no password. you can try stopping it in the bootloader and running "no password" then "boot" and it should boot, temporarily not asking for your password. can you post your entire boot output? it sounds like it didn't get flashed all the way if it's asking for a default password (brocade doesn't have one)
I did set a password, because on boot, it asks me to log on (something neither the serial or management interface should do (right?).

I also tried the: no password
then: boot (just as shown on the RuckusWireless page)
but it argued that it did not provide enough args/params

So next, I googled some more and found this page, also on ruckus:

It's full boot command is: boot system flash primary
That seems to be booting now.

I don't think I'll be setting a password this time! :D
 

vpadro

New Member
Jul 16, 2015
10
1
3
45
So, I'm having an issue with the management port, the switch was off for a long time and now that I'm trying to use it, well it kinda works but the first thing I wanted to do is to revert the firmware to v7 since I flash it a couple years ago with the v8 beta firmware, but I can't, I've already tried this (Steps 3-4) but without any luck, the mngmt port does assign an IP/subnet:

Code:
enable / conf t / int man 1 / ip address 192.168.50.252/24 / wri mem
But I can't ping it or establish a connection thru it, here are some details from the switch:

Code:
TurboIron Boot Code Version 7.3.0
Enter 'a' to stop at memory test
Enter 'b' to stop at boot monitor
BOOT INFO: load monitor from boot flash, cksum = 7be5
BOOT INFO: verify flash files.......
BOOT INFO: load image from primary copy....

....................
....
Pre Parsing Config Data ...


Parsing Config Data ...

  SW: Version 08.0.01eT203 Copyright (c) 1996-2013 Brocade Communications Systems, Inc. All rights reserved.
      Compiled on Jul 15 2015 at 07:12:50 labeled as TIR08001e
      (6845067 bytes) from Primary brocadeimage.bin
      Compressed Boot-Monitor Image size = 369366, Version:07.3.00T205 (trz07300)
  HW: Stackable TurboIron-X24
==========================================================================
      Serial  #: ▒▒LB6M
      P-ASIC  0: type B820, rev 11  subrev 00
==========================================================================
  825 MHz Power PC processor MPC8541E (version 8020/0020) 330 MHz bus
  512 KB boot flash memory
31744 KB code flash memory
  512 MB DRAM
The system uptime is 20 seconds
The system : started=cold start

TX24 Router>
Power supply 1 (right slot when facing rear) detected and up.

TX24 Router>show run
Current configuration:
!
ver 08.0.01eT203
!
!
!
!
!
!
!
ip dns domain-name domain.net
ip dns server-address 192.168.50.1

!
!
interface management 1
 ip address 192.168.50.252 255.255.255.0
!
!
!
!
!
!
!
!
!
end

TX24 Router>show int man 1
GigEthernetmgmt1 is up, line protocol is up
  Hardware is GigEthernet, address is 748e.f8e2.d200 (bia 748e.f8e2.d21c)
  Configured speed auto, actual 10Mbit, configured duplex fdx, actual hdx
  Configured mdi mode AUTO, actual none
  Not a Member of any VLAN , port is untagged, port state is NONE
  No port name
  Internet address is 192.168.50.252/24, MTU 1500 bytes, encapsulation ethernet
  300 second input rate: 5184 bits/sec, 5 packets/sec, 0.05% utilization
  300 second output rate: 0 bits/sec, 0 packets/sec, 0.00% utilization
  1230 packets input, 149317 bytes, 0 no buffer
  Received 485 broadcasts, 745 multicasts, 0 unicasts
  0 input errors, 0 CRC, 0 frame, 0 ignored
  0 runts, 0 giants
  0 packets output, 0 bytes, 0 underruns
  Transmitted 0 broadcasts, 0 multicasts, 0 unicasts
  0 output errors, 0 collisions

If you need any other information please let me know, hope someone can point me out in some direction.

TIA.
 

vpadro

New Member
Jul 16, 2015
10
1
3
45
The mgmt port still doesn't respond to ping, telnet, anything, I just set the interface ve 1 as you stated on your guide and flash it, maybe the port is damaged really don't know, just wanted to set it up so I can sell it and get a ICX7250, thank you.
 

weseycorrea

New Member
Feb 22, 2019
5
0
1
hello I have this SW LB6M is compatible with brocade firmware?

(FASTPATH Routing) #show version

Switch: 1

System Description............................. Quanta LB6M, 1.2.0.18, Linux
2.6.21.7
Machine Type................................... Quanta LB6M
Machine Model.................................. LB6M
Serial Number.................................. QTFCRW2050080
FRU Number..................................... 1LB6BZZ0STL
Part Number.................................... BCM56820
Maintenance Level.............................. A
Manufacturer................................... 0xbc00
Burned In MAC Address.......................... 04:7D:7B:4A:6A:4C
Software Version............................... 1.2.0.18
Operating System............................... Linux 2.6.21.7
Network Processing Device...................... BCM56820_B0

Thank you, if it is compatible post a link how to do the process
 

mailinglists

New Member
Mar 3, 2017
15
0
1
41
Has anyone tested FastIron Multi-Chassis Trunking as described in manual page 885 on these switches?
Can anyone, who has two of these, test this?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,111
1,976
113
30
fohdeesha.com
hello I have this SW LB6M is compatible with brocade firmware?

(FASTPATH Routing) #show version

Switch: 1

System Description............................. Quanta LB6M, 1.2.0.18, Linux
2.6.21.7
Machine Type................................... Quanta LB6M
Machine Model.................................. LB6M
Serial Number.................................. QTFCRW2050080
FRU Number..................................... 1LB6BZZ0STL
Part Number.................................... BCM56820
Maintenance Level.............................. A
Manufacturer................................... 0xbc00
Burned In MAC Address.......................... 04:7D:7B:4A:6A:4C
Software Version............................... 1.2.0.18
Operating System............................... Linux 2.6.21.7
Network Processing Device...................... BCM56820_B0

Thank you, if it is compatible post a link how to do the process
the link on how to do this is literally in the first post of this thread in bold
 
  • Like
Reactions: name stolen