Turbocharge your Quanta LB6M - Flash To Brocade TurboIron - Big Update!

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

mTek

New Member
Nov 18, 2018
15
6
3
Well, that explains it very well. Is there another way to use LACP across multiple switches for redundancy?
 

pokemongo

New Member
Dec 11, 2018
1
0
1
hi guys, I'm kind of new here so be gentle on me :)
got question on Brokeaids document says

Quote"If the output on your switch does not match this exactly, STOP! Pastebin your switches output and get in touch with us on ServeTheHome."

I assume that is [if you wish to flash but the out put differs, stop and contact].
But it lacks instruction on how to [stop flashing and keep on using with original firm].
What should I do if the output differs and wishes to keep on using the original firm?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,790
3,168
113
33
fohdeesha.com
paste the output here, it's most likely just a different u-boot version and you're fine

if you don't wish to flash just reboot the switch, you haven't written anything to it yet. just pull power or type "reset"
 

vrod

Active Member
Jan 18, 2015
241
43
28
31
Hi @fohdeesha - I just did a show version on mine (crossflashed) and it showed me the version: SW: Version 08.0.01eT203

I guess this means I have the Version 8 which apparently was meant for internal use only/beta testing? Might explain why that switch has been acting strange lately, though I did this crossflashing over half a year ago :D
 

thisis789

New Member
May 6, 2016
4
0
1
27
my putty settings are default

Com line 3
Speed 9600
Data bits 8
stop bits 1
parity none
flow control XON/XOFF
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,790
3,168
113
33
fohdeesha.com
someone probably changed the u-boot serial speed environment variable so the bootloader is running at a different rate, try 19200, 38400, 57600 and 115200 until the bootloader output makes sense (changing them will make it not work in the OS which is running at 9600, so best to reboot it and do OS stuff from telnet or something during this)
 

thisis789

New Member
May 6, 2016
4
0
1
27
thanks for the help and fast replies! for some reason someone set it to 115200 but i got into the bootloader now, is there a command to set it back to the regular speed?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,790
3,168
113
33
fohdeesha.com
you can just follow the guide at that serial speed, youll just need to change your console back to 9600 once it boots the brocade bootloader
 

thisis789

New Member
May 6, 2016
4
0
1
27
Alright the flash went well, no problems and everything is going great except one thing, I turned out to be one of the unlucky ones that ended up with useless management ports. hopefully when I move it into the rack a different network cable will make it happy but I doubt it. So does anyone have a guide on how to set the ssh server an ip address and it could just listen on all the networks port kinda like modern smart switches? or just turn one of the other cooper NICs into the management port? The only networking CLI I know is very little and for a cisco router with 4g for some project. I tried setting up eth 28 to have an ip address and it kept throwing back an error about a conflict that didn't exist as far as I could tell.
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,790
3,168
113
33
fohdeesha.com
follow the "l3 quick guide" on the lefthand side of the guide website, it gets it set up with an in-band mgmt IP and ssh etc
 

d.ohlin

New Member
Dec 19, 2017
14
5
3
34
Does anyone know whether or not there's any way to connect 100Mbps copper ethernet devices to the SFP+ ports after doing this? The problem I have is that several of the cheap 'smart' home products I have insist on putting stupid 100Mb ports in their devices, and with the transceivers I have they do not work unless I put them in the 4 copper ports on the right side of the switch...which is becoming limited for space lol. I've seen autosensing transceivers like this from fs: Generic Compatible 10/100/1000BASE-T SFP Copper RJ-45 100m Transceiver Module but am not sure whether or not this would work. Anyone have any thoughts/experience/answers on this? Thanks!
 

JSchuricht

Active Member
Apr 4, 2011
199
74
28
Darn it. I was perfectly happy not having any knowledge if this Brocade switch. Now you have me thinking of combining several switches into one creating an empty space in a rack that will drain even more money. I would thank you but my wallet hates you right now.
 

Tommot

New Member
Feb 28, 2019
2
0
1
I seem to be in a broken but savable state. I was asked to restore "fartpath" and it seems that although tftpd64 does transfer the file, it doesn't actually boot to it. The bootloader revert worked, just reloading fartpath did not.

Code:
Select option (1-13 or Q): 2
Creating tmpfs filesystem on tmpfs for download...done.
Select Mode of Transfer (Press T/X/Y/Z for TFTP/XMODEM/YMODEM/ZMODEM) []:T
Enter Server IP []:192.168.186.49
Enter Host IP []:192.168.186.50
Enter Host Subnet Mask [255.255.255.0]:
Enter Gateway IP []:
Enter Filename []:lb6m.1.2.0.18.img
Do you want to continue? Press(Y/N):  y
Bringing up eth0 interface...done.
Bringing down eth0 interface...done.
Saving code file...
Code update instructions found!

Critical components modified -- system reboot recommended!

Reboot? (Y/N): y

Rebooting...
Starting pid 769, console /dev/ttyS0: '/etc/rc.d/rc.reboot'
syncing filesystems....This may take a few moments
umount: forced umount of /mnt/fastpath failed!
Rebooting system!
The system is going down NOW !!
Sending SIGTERM to all processes.
Please stand by while rebooting the system.


U-Boot 2009.06 (Apr 19 2011 - 15:57:06)

CPU:   8541, Version: 1.1, (0x80720011)
Core:  E500, Version: 2.0, (0x80200020)
Clock Configuration:
       CPU0:825  MHz,
       CCB:330  MHz,
       DDR:165  MHz (330 MT/s data rate), LBC:41.250 MHz
CPM:   330 MHz
L1:    D-cache 32 kB enabled
       I-cache 32 kB enabled
I2C:   ready
DRAM:  Initializing
Warning: some of the installed DIMMs can not operate this slowly.
    DDR: 512 MB
FLASH: 32 MB
L2:    256 KB enabled
*** WARNING: Could not read MAC address from EEPROM
VPD EEPROM CRC (0x4a982e8) invalid, should be 0xb2bc8ae1
In:    serial
Out:   serial
Err:   serial
Net:   TSEC0: PHY is Broadcom BCM5482 (143bcb1)
TSEC1: PHY is Broadcom BCM5482 (143bcb1)
TSEC0, TSEC1
Hit any key to stop autoboot:  0
### JFFS2 loading 'image1' to 0x8000000
Scanning JFFS2 FS:  done.
find_inode failed for name=image1
load: Failed to find inode
### JFFS2 LOAD ERROR<0> for image1!
## Booting kernel from Legacy Image at 08000074 ...
   Image Name:   FASTPATH System for lb4m
   Image Type:   PowerPC Linux Multi-File Image (gzip compressed)
   Data Size:    9025959 Bytes =  8.6 MB
   Load Address: 00000000
   Entry Point:  00000000
   Contents:
      Image 0: 1167342 Bytes =  1.1 MB
      Image 1: 1432683 Bytes =  1.4 MB
      Image 2: 474 Bytes =  0.5 kB
      Image 3: 6425435 Bytes =  6.1 MB
   Verifying Checksum ... OK
## Loading init Ramdisk from multi component Legacy Image at 08000074 ...
   Uncompressing Multi-File Image ... OK
   Loading Ramdisk to 1fa09000, end 1fb66c6b ... OK
   Loading Device Tree to 007fc000, end 007ffb63 ... OK
Model Name LB6M
Using Quanta LB Series machine description
Memory CAM mapping: CAM0=256Mb, CAM1=256Mb, CAM2=0Mb residual: 0Mb
Linux version 2.6.21.7 (gmirek@lc-rdub-26) (gcc version 4.1.2 (Wind River Linux Sourcery G++ 4.1-84)) #2 PREEMPT Thu Mar 31 09:38:27 EDT 2011
Found initrd at 0xdfa09000:0xdfb66c6b
Found MPC85xx PCI host bridge at 0x00000000e0008000. Firmware bus number: 0->0
Zone PFN ranges:
  DMA             0 ->   131072
  Normal     131072 ->   131072
early_node_map[1] active PFN ranges
    0:        0 ->   131072
Built 1 zonelists.  Total pages: 130048
Kernel command line: root=/dev/ram rw mtdparts=physmap-flash.0:32256k(jffs2),512k(u-boot),128k@32512k(u-boot-env)
mpic: Setting up MPIC " OpenPIC  " version 1.2 at e0040000, max 1 CPUs
mpic: ISU size: 4, shift: 2, mask: 3
mpic: Initializing for 60 sources
PID hash table entries: 2048 (order: 11, 8192 bytes)
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 515328k/524288k available (2336k kernel code, 8468k reserved, 76k data, 86k bss, 132k init)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
PCI: Probing PCI hardware
PCI: Cannot allocate resource region 0 of device 0000:00:12.0
Generic PHY: Registered new driver
NET: Registered protocol family 2
IP route cache hash table entries: 16384 (order: 4, 65536 bytes)
TCP established hash table entries: 65536 (order: 7, 524288 bytes)
TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
TCP: Hash tables configured (established 65536 bind 65536)
TCP reno registered
checking if image is initramfs... it is
Freeing initrd memory: 1399k freed
JFFS2 version 2.2. (NAND) (C) 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered (default)
Generic RTC Driver v1.07
Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing enabled
serial8250.0: ttyS0 at MMIO map 0xe0004500 mem 0xe1000500 (irq = 26) is a 16550A
serial8250.0: ttyS1 at MMIO map 0xe0004600 mem 0xe1002600 (irq = 26) is a 16550A
RAMDISK driver initialized: 2 RAM disks of 32768K size 1024 blocksize
Gianfar MII Bus: probed
eth0: Gianfar Ethernet Controller Version 1.2, 60:eb:69:3e:de:98
eth0: Running with NAPI enabled
eth0: 256/256 RX/TX BD ring size
eth1: Gianfar Ethernet Controller Version 1.2, 00:e0:0c:00:01:fd
eth1: Running with NAPI enabled
eth1: 256/256 RX/TX BD ring size
Broadcom BCM5411: Registered new driver
Broadcom BCM5421: Registered new driver
Broadcom BCM5461: Registered new driver
Broadcom BCM5464: Registered new driver
Broadcom BCM5481: Registered new driver
Broadcom BCM5482: Registered new driver
Broadcom BCM50610: Registered new driver
Broadcom BCM57780: Registered new driver
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
i2c /dev entries driver
physmap platform flash device: 02000000 at fe000000
physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank
 Amd/Fujitsu Extended Query Table at 0x0040
physmap-flash.0: CFI does not contain boot bank location. Assuming top.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
3 cmdlinepart partitions found on MTD device physmap-flash.0
Creating 3 MTD partitions on "physmap-flash.0":
0x00000000-0x01f80000 : "jffs2"
0x01f80000-0x02000000 : "u-boot"
0x01fc0000-0x01fe0000 : "u-boot-env"
nf_conntrack version 0.5.0 (4096 buckets, 32768 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
sit0: Disabled Privacy Extensions
NET: Registered protocol family 17
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Freeing unused kernel memory: 132k init
Starting pid 618, console /dev/ttyS0: '/etc/rc.d/rc.fastpath'
Mounting /dev/mtdblock0 at /mnt/fastpath.
*** Mount failed!
Mounting tmpfs at /mnt/application...done.

FASTPATH Startup Rev: 6.2

Select startup mode.  If no selection is made within 5 seconds,
the FASTPATH Application will start automatically...

FASTPATH Startup -- Main Menu

1 - Start FASTPATH Application
2 - Display Utility Menu
Select (1, 2):
code file image1 not present.
booting image2
Extracting application from .stk file...error: cannot open input file /mnt/fastpath/image2
Failed!
/mnt/application
FASTPATH not executed!
Press <ENTER> to continue...