smb

  1. L

    OmniOS r151036 and MacOS Word v16.30+ SMB

    Ran into a very weird issue. Running OmniOS r151036 with the native smb sharing, MacOS Word v16.something greater than 30 (still testing but 30 does not exhibit the behavior) in either the O365 or the 2019 line will only open .docx files as Read Only. .doc files work fine. Excel files of xls...
  2. AveryFreeman

    Linux accesses OmniOS share as appropriate domain user, Windows does not?!

    Hi [edit: I 'solved' this, it's not solved but it's working again - the secondary domain controller was turned off. However, that doesn't account for why the primary domain controller can't authenticate users properly by itself] I've got the weirdest issue that just cropped up and I have no...
  3. AveryFreeman

    OmniOS: New smbclient test package - how to run?

    Hey, was just reading over the release notes for OmniOS 151030: omniosorg/omnios-build and saw this package: system/test/smbclient New 0.5.11 I installed it, but I can't figure out how it's invoked, does anybody know? Thanks :)
  4. C

    napp-it snaps

    Hi all, Does anyone know how to set up snapshots ala Timeslider on Solaris 11.4 using napp-it? I set up several recurring snapshots on our main filesystem under Jobs/Snaps and enabled the Auto service. This filesystem has two nested filesystems, each are shared via the CIFS service. Several...
  5. C

    Windows SMB performance issues

    Hi all, We recently set up a Solaris 11.4 server based on the following hardware; SuperMicro SSG-6049P-E1CR45L 2x XEON Silver 4114 10 Core 2.2GHz (LSI 3008 IT mode) 512GB DDR4-2666 ECC RAM 2 x Intel S4600 240GB 2 x Intel Optane 905P 480GB U.2 24 x HGST 10TB SAS 2 x Intel X540T2 10Gbe NIC Our...
  6. L

    Slow SMB Read Speed, Fast Write | ZFS on Linux | Ubuntu 18.10

    Hello Guys, I got some strange problems with a new ZFS-Setup and SMB-Share: when copying files from a client machine to the server, I see around 400 - 500 MB/s transfer speeds. If I copy the same file from the server to the client, I only reach 150 MB/s. That seems way too low... On the...
  7. J

    Can't use emoji in file names on SMB

    OmniOS v11 r151026r napp-it 18.01c free When I try to copy a file with emoji in the name I get the error on Windows. I can copy the file using winscp and the file get copied with out a problem. In terminal I can view all the files but viewing the smb share on windows does not display the file...
  8. M

    Poor network speed on WS2016

    hello, my server has very poor networking speed when copieng files from a SMB share on the server to a client. The operating system is a freshly installed Windows Server 2016. The server uses a I350 T4 NIC and has two I210/I217 LM NICs onboard. The client runs on Windows 10 and has 2 I210 NICs...
  9. C

    Can the S3 disk be read/write?

    Hi I think it is great that there is an S3 target in FreeNAS. It's a Minio server as we know it. I configured the S3 service using /mnt/pool1/folder1 as disk. This is where I can create buckets and upload files from the Minio browser port 9000. Then I shared the /mnt/pool1/folder1 (which the...
  10. S

    OmniOS and SMBv1?

    Hi We are currently evaluating a storage appliance built on OmniOS v11 r151020 and can't join it to our Active Directory Domain with Windows Server 2016 Domain Controllers with SMBv1 disabled. We have done a lot of troubleshooting and always end up with the following errors: smbd[3792]: [ID...
  11. N

    Debug logs for SMB service?

    Hi, anyone knows where or how I can get debug logs for the built in SMB service in OmniOS? The share is set up via Napp-IT. I have issues with not being allowed to overwrite some files (from OS X). It just happens once in a while, and as far as I can see the files have the correct permissions...
  12. Z

    Software Basics of SMB Multichannel and Samba 4.6.x

    I am having a very difficult time finding examples and the Samba documentation seems to be out of date or I'm not finding what I need. I do not have any question related to hardware I am fully aware of the hardware requirements my focus is on software only please. My current setup is on RHEL...
  13. TheBloke

    Diskless Windows 10 workstation booted from NAS - possible? iSCSI? SMB?

    Hi all I'm in the process of a major upgrade to my home NAS. The server runs Solaris 11.3, with hardware of: 2 x 2.93GHz hex-core LGA1366 CPUs, 72GB RAM (considering upgrading to 120GB) and 32 ports of LSI 6GB SAS/SATA (2 x 2008, 2 x 2308). I currently have 27 x 2TB 7.2k SATA drives...
  14. K

    Need help with slow samba file copy speeds

    I have low windows-to-linux samba file copy speeds and I can't figure out why. I have 2 machines that I can dual boot windows and linux. Windows-to-Windows file copy has no problem maxing out gigabit ethernet at 110+ MB/s. But when I reboot one machine into linux, it can barely hit 60-65 MB/s...
  15. P

    Napp-it Issue with multiple Active Directory

    I have a setup where there are 4 remote sites and a primary site. Each have their own Windows 2012 server running DNS and AD. The networks are meshed so everybody can see everybody. Recently I have been replacing our old servers with new ones with similar setup. Everybody has the same hardware...
  16. N

    Always lowercase SMB sharename? [Napp-It – OmniOS v11 r151018]

    Hi all (and mostly @gea), I have a question regarding share names. How come the SMB share is lower case? Even if the directory is named "This Is A Directory" the share becomes "this is a directory". Is it possible to get it to respect the way it is named? Thanks! :)