Linux accesses OmniOS share as appropriate domain user, Windows does not?!

AveryFreeman

ESXi + ( ILLUMOS / ZFS ) = HAPPY
Mar 17, 2017
165
19
18
39
Near Seattle
averyfreeman.com
Hi

[edit: I 'solved' this, it's not solved but it's working again - the secondary domain controller was turned off. However, that doesn't account for why the primary domain controller can't authenticate users properly by itself]

I've got the weirdest issue that just cropped up and I have no idea why. It's really pissing me off because I need write access to my files on my Windows desktop

I have 2012r2 domain with IDMU. Usually my ID shows 10000/10001 across all my machines. Example:

1593125295757.png

Here's an example of a Linux computer connected to the same domain:

1593125344288.png

Now when my Windows desktop logs on to the domain it is showing a different ID. Example:

1593125374628.png

I can write to the share directly while in git bash:

1593125443644.png

That's fine, but I can't save any files in VS Code:

1593125482604.png

Can't set permissions to 777:

1593125541315.png

Settings permissions in OmniOS makes no difference:

1593125612625.png

Still looks like this:

1593125634965.png

It is so weird, but it's preventing me from doing my work (!) So frustrated...

Does anyone have any idea why my share is acting like this? It's never been a problem in the past.

Edit:

So thankfully it was easy to get it working again, I hadn't noticed my secondary domain controller was turned off. I had been trying to leave and re-join the domain in OmniOS and it wasn't working until I realized the secondary DC was off. Once I turned it on it started working again.

It doesn't really make any sense given the secondary DC replicates the primary. Has anyone ever seen this before? Totally bizarre.

Moreover, I have to fix it because the whole reason for running two DCs is so if one dies or needs to be taken down the AD infrastructure still works.
 
Last edited: