OmniOS r151036 and MacOS Word v16.30+ SMB

lymond01

New Member
Mar 19, 2021
3
0
1
Ran into a very weird issue. Running OmniOS r151036 with the native smb sharing, MacOS Word v16.something greater than 30 (still testing but 30 does not exhibit the behavior) in either the O365 or the 2019 line will only open .docx files as Read Only. .doc files work fine. Excel files of xls or xlsx also work fine. Word for Windows works fine. And other non-Solaris OSes that we run (FreeBSD for example) don't have this Read Only behavior.

We're eyeballing ways of tweaking the SMB settings on OmniOS but using the built-in smb we're a touch limited (versus running the full samba package). SMB 3.02 is the negotiated protocol on all tests. We've tested from MacOS Catalina to Big Sur with no improvements -- it seems to be Word related. The 64-bit universal installers began at 16.44 but 16.33 also exhibits the behavior.

I'm not looking for a fix on Omni's part. Just making a note. Another forum post suggested removing fruit locking fixed his issue but he must have been running the full samba package for that option. He had the exact same issue: OmniOS, Mac Word, .docx only affected..
 

gea

Well-Known Member
Dec 31, 2010
2,649
908
113
DE
You can try to disable the Apple extensions with the kernelbased SMB server

Put this on a new file inside /etc/system.d/ and reboot
set smbsrv:smb2_aapl_use_file_ids=1

If you ever want to disable completly the smb aapl mode, you can use:
set smbsrv:smb2_aapl_extensions=0



You can also try 151037 bloody (pre-release of next long term stable in may)
if behaviour is different as there are some SMB fixes.


If this does not help, write an email to illumos-dev, Mailing Lists - illumos
or add a bugreport to Issues - illumos


please report results
 
Last edited:

lymond01

New Member
Mar 19, 2021
3
0
1
You can try to disable the Apple extensions with the kernelbased SMB server

Put this on a new file inside /etc/system.d/ and reboot
set smbsrv:smb2_aapl_use_file_ids=1

If you ever want to disable completly the smb aapl mode, you can use:
set smbsrv:smb2_aapl_extensions=0



You can also try 151037 bloody (pre-release of next long term stable in may)
if behaviour is different as there are some SMB fixes.


If this does not help, write an email to illumos-dev, Mailing Lists - illumos
or add a bugreport to Issues - illumos


please report results
We can give this ago. I realize the setting is smb2_aapl_use_file -- will this only affect SMB 2 connections do you know? And we are considering spinning up a test of 151037 because of those SMB changes. I'll report back.
 

lymond01

New Member
Mar 19, 2021
3
0
1
Interestingly -- no luck at all. We already had the aapl_use_file_ids=1 set. Windows AD admins suggested our login is getting through but the password is showing as incorrect. We can kinit to the AD without issue -- just cannot join the box. Either with 151037 or, oddly, the current version even though we have another server joined (recently updated to the new version but joined with an earlier version).