omnios

  1. AveryFreeman

    FreeBSD/FreeNAS vs OmniOS/Napp-it write speeds when used as ESXi NFS VM datastore?

    Hey, so I've done a couple all-in-one ESXi boxes with either FreeNAS or FreeBSD with ZFS I pass to ESXi as NFS datastores. Tried to run VMs but benchmarks exposed gawd-awful write speeds, totally unusable. Just ended up using them for ISO storage and (slow) backups, content libraries, etc...
  2. M

    Worth migrating to Solaris?

    I'm currently using OmniOS 15022 (old) with Napp-it pro but would really like a storage system with SMB3 multichannel support. I really like how simply OmniOS/Napp-it integrate with my domain and allow the use of compmgmt.msc to control permissions and would like to continue using this. I'm...
  3. S

    OmniOS and SMBv1?

    Hi We are currently evaluating a storage appliance built on OmniOS v11 r151020 and can't join it to our Active Directory Domain with Windows Server 2016 Domain Controllers with SMBv1 disabled. We have done a lot of troubleshooting and always end up with the following errors: smbd[3792]: [ID...
  4. N

    Debug logs for SMB service?

    Hi, anyone knows where or how I can get debug logs for the built in SMB service in OmniOS? The share is set up via Napp-IT. I have issues with not being allowed to overwrite some files (from OS X). It just happens once in a while, and as far as I can see the files have the correct permissions...
  5. N

    "The installed package is not permissible." when trying to upgrade OmniOS

    I'm trying to update another install of OmniOS from 151020 to latest 151022 (i.e not the same install as my previous post), and this time I'm getting "The installed package XXX is not permissible." Any input on how to solve this? (see below for all info, and let me know if anything else is...
  6. M

    Napp-it error in auto.pl

    I just received a local mail upon login to my OmniOS server running Napp-it pro 17.04 dev: ld.so.1: perl: fatal: relocation error: file /var/web-gui/data/napp-it/CGI/auto/IO/Tty/Tty.so: symbol Perl_xs_apiversion_bootcheck: referenced symbol not found I have seen this thread : [SOLVED] OmniOS...
  7. G

    napp-it All-In-One ZFS storage server template for ESXi

    New ova templates available, ready to import in ESXi for a full featured NAS/SAN/VM ZFS storage with one e1000 vnic and one faster vmxnet3s - based on OmniOS 151022 lts, LX/Linux container, vmware tools, tls, current napp-it (Free/Dev) - based on OpenIndiana 2017.04 GUI, vmware tools, mate...
  8. G

    OmniOS 151022 long term stable

    Bad news for OmniOS users [OmniOS-discuss] The Future of OmniOS We will see what this means for the Future of OmniOS (continuation as an OpenSource project, or move/merge with another Illumos distribution like OI or SmartOS) The next OmniOS 151022 seem the last OmniOS release (expected Mai...
  9. TheBloke

    Moving from Solaris 11.3 to OmniOS (or OpenIndiana): anything important to know?

    Hi all I am currently running Solaris 11.3 on my home server. I went with Solaris 11 because I was a Solaris 10 + OpenSolaris admin for many years, so it is what I know. Plus I have a free license for Solaris 11, so licensing/patches are not a concern for me. But now I am thinking I made a...
  10. M

    napp it nfs subtree_check

    is it possible to allow subtree checking in omnios and if so how do i accomplish this?
  11. M

    What is the easiest way to move share to another pool?

    Hi, I tried this once before but it ended up more manual than I'd like and was hoping that someone could post an easy way to accomplish this via CLI (omnios) or Napp-iT. I have a pool "ssd1" and a zfs volume "Users" shared using cifs by the name "Users" I'd like to move this entire volume to...
  12. GCM

    OmniOS rebooting at setup

    So as some of you have saw, I received new storage hardware. I wanted to play around with Omni & Napp-it, but I'm having tremendous issues even getting Omni installed. I was lead to believe my reboot issue was caused by USB3.0 on the board, but I've made sure every single USB3.0 feature/BIOS...
  13. M

    ZFS SLOG. Can it be carved out of an SSD volume?

    I have a 960GB S3700 that I'm using as a datastore for VMs (iSCSI) but would like to add a SLOG. Can I recreate the volume on the SSD to use part of it for SLOG and part of it for data? Thanks!
  14. M

    OmniOS/Napp-it standalone to AIO ESXi

    Hi, I know this has been covered briefly before though I cannot find the appropriate thread: I have a standalone OmnisOS server but am trying to reduce my power bill as I have an R610 (2012 R2 Datacenter), R710 (2012 R2 Datacenter), and SQ836 X8F (OmniOS 48TB across two vdev) I've just recently...
  15. M

    Low 10GB speeds between direct attached servers

    Hi, I have a Windows server 2012 R2 installation on a Dell R710 with an Intel AF DA nic in an x8 slot. I also have an OmniOS installation on a Supermicro X8DTH with an Intel X520-DA2. These devices are directly connected on a 10.10.10.0/24 subnet using Twinax. Both are configured with large...
  16. N

    Always lowercase SMB sharename? [Napp-It – OmniOS v11 r151018]

    Hi all (and mostly @gea), I have a question regarding share names. How come the SMB share is lower case? Even if the directory is named "This Is A Directory" the share becomes "this is a directory". Is it possible to get it to respect the way it is named? Thanks! :)
  17. M

    ACL assistance for local unix user in a domain environment

    I'm running OmniOS with Gea's Napp-it but do not have an ACL gui license. My server is domain joined so the majority of my permissions are set from a Windows computer. I just installed the Owncloud 9 package on my OmniOS installation and it runs under Apache's www user. I'd like to change...
  18. M

    OmniOS Napp-it Replication Question

    This question is aimed mainly at Gea but others may be able to help. I'm running OmniOS with Gea's excellent Napp-It on top. I'm currently replicating several ZFS filesystems from one pool to another pool using Napp-it's replication feature once per week. I've noticed that on both the source...
  19. M

    OmniOS Kernel question

    I recently installed OmniOS blood (151017) on a Dell R710 and and installed Gea's excellent Napp-it gui. I was looking to see what the deduplication would be if enabled so ran "zdb -S mypoolname" and, after quite some time, the application crashed with OOM error (out of memory). Upon searching...
  20. M

    Napp-It OmniOS Active Directory ACL question

    Hi, I going to be migrating my Rockstor BTRFS data over to OmniOS/Napp-it and have a question regarding active directory integration and ACL. When OmniOS is joined to the domain, can I then use a Windows server with administrator credentials to configure share / file permissions? I'm a little...