R820 / H310 "Adapter at Baseport is not responding"

Quartzeye

New Member
Jul 29, 2013
12
0
1
I posted this on Dell's community as well but no responses as yet.

So I think I have a serious problem that I need any help I can get. I don't know if the H310, the SAS cables, the enclosure, or the drives are bad. I will explain.

I purchased a re-purposed R820 with an H310 and 10 1TB Seagate SAS drives. I had all the drives visible in the H310 and set up as JBOD, no raid config. I originally tried to install Ubuntu 18.04 and boot from the SAS drives and that failed. Debian/Ubuntu cannot boot from the SAS drives with the H310 on an R820. You can see them if they are in a non-raid config after the OS is up but not in a RAID config or bootable. Also, Ubuntu could not see any of the drives if I had them in a raid config. I tried many configs and flash attempts on the H310 back and forth from an H310 to an LSI HBA.

I also attempted to install Proxmox on the server, yes I know it is Debian based, and the installer saw the drives on in a non-raid config on H310 firmaware. I selected to install as a ZFS RAID2 with LZ4 compression and selected all the drives for the pool. It installed but before it was finished and attempting to reboot, it error'd and said it could not see the drives and the ZFS pool. Was using the UEFI boot option as Proxmox requires that. My hope was that Proxmox had worked out the H310 already and was supported.

So now I figured the install was toast and that Proxmox just couldn't passthrough the H310 to get to the ZFS pool. So I pulled the H310 out of the server and flashed it to be an LSI HBA thinking that it might solve that issue. The megarec utility would not run on the R820 which is why I had to continually pull the card and flash in non-dell workstation. I was able to successfully flash and put the h310 back into the R820 but it would not leave the initializing prompt any time I used flashed with the boot ROM and attached to the SAS drives backplane. I re-flashed and removed the boot bios from the H310 and retried in the R820. No boot initialization but it could not see the drives. Only one green LED was lit on each drive. At no time has a re-flashed H310 as a worked for me in this R820.

So I figured that since that didn't work and I don't believe you can get a HBA only for the R820. Also, the LSI firmware, while working on other servers and other Dell servers, doesn't work on the R820. I pulled the H310 and reflashed it back to a stock H310. I tested if I could get to the configuration utility on my other workstation and all was accessible before putting it back into the R820.

Same issue again, one led lit on each drive, but I also got the "adapter at baseport is not reponding" "no adapter" message. All the drives had one green led lit and I could not see the H310 in the bios or Lifecycle utility. I tried moving to different PCIE slots, no change. However, if I disconnected the SAS cables I can get the server to boot and I can see it in the bios and Lifecycle Controller, but can not get the dos configuration utility to open. I removed the H310 reflashed to an LSI HBA, then back to H310 again and retested everything with the same results.

I have not touched the backplane enclosure at all.

So first, the card seems to work in a different server and is visible in the bios config utilities when not connected, but I have not attached any drives to it in my workstation. The card may be bad but I do not know for sure. The cables confuse me as I don't know for sure that one or both are not bad but I suspect they are durable enough that none of this should be an issue, but I don't know that for sure either. I suspect that the backplane enclosure is fine but again, I don't know how to test that. Lastly, I think Proxmox stepped on the SAS hard drives in a way that they are not reporting to the controller properly and may be the ultimate culprit but I tried putting an HP hard drive into a single slot and got nothing as well, but it could just be that the drive was out of bounds. I don't know how to get the drives reformatted back to a default state as the H310 cannot see them or they cannot be seen, don't know which one it is and since they are SAS I cannot just plug them into my laptop via a usb adapter.

Any help would be greatly appreciated.

Lastly, I really need Proxmox on this server and I have found that Ubuntu and Proxmox/Debian cannot boot from the H310 in an R820. I had to put a dual SD Flash assembly in and boot from it as you cannot boot from the front panel SD card, just to get Ubuntu v18.04 to run. Other than the SAS drives, internal SD card, of flash dives, there is nothing you can put into the R820 that is bootable. Maybe if I can get a RAID card working in the R820 I can get Ubuntu or Proxmox to boot from the SAS drives or a single RAID 0 drive but I doubt that and I cannot get there from where I am at today.

To summarize the "truths" I have observed:
No HBA adapter that can pass-through is available for the R820
The R820 cannot see use a re-flashed H310 as an LSI HBA
Debian/Ubuntu is not supported on the R820
Debian/Ubuntu cannot boot from any SAS drive on an H310 in an R820 in an non-raid config
Debian/Ubuntu cannot see RAID'ed drives on the H310 in an R820
The only boot-able drives for Debian/Ubuntu in an R820 are internal SD Cards and Flash Drives.
ZFS cannot be used with an H310 in a non-raid config (don't believe in a raid config either as Debian cannot see the raided drives on the H310)


Selection_868.png
 

Attachments

Quartzeye

New Member
Jul 29, 2013
12
0
1
Update:

Still no joy but now I think I am zeroing in on at least part of the problem.

There is an issue the mpt3sas driver.

I reflashed the card back to an LSI 9211-8i HBA with out boot roms. I installed Proxmox on my internal SD cards and was able to get Proxmox running and get to a shell. Still no drives attached to my HBA are visible.

I can see the HBA:
Selection_869.png

Selection_870.png

So the Adapter is visible to the OS and is using the MPT3SAS driver. However, nothing is using that driver:
Selection_871.png

I checked the version of the driver:
Selection_872.png
It is newer than the firmware version which the latest is v20. Shouldn't be an issue but I read a post or two that said these had to be the same but others where saying that isn't true.

I checked to see if the driver was loaded and it isn't:
Selection_873.png

I then checked the messages:
Selection_874.png

The command to enable the ports is timing out, I don't know why. Maybe the drives are not reporting since I tried to format them as a RAIDZ2 pool with lz4 compression in a prior install. Maybe the drives are not reporting because of it but I would think that would not stop the ports from being enabled. I also don't know if the subsequent driver error is an issue or just a symptom of the ports not being enabled.

I thought that since this was an MPT2SAS device that I would add a driver parm to force it to legacy MPT2SAS and got the same results.
Selection_875.png

I see that there have been a lot of views on this post but no replies at all. Is there anyone that assist is fixing this?
 

nezach

Active Member
Oct 14, 2012
204
107
43
This might not be of much help, but look at the error code doc that I linked in this post: https://forums.servethehome.com/ind...oller-technical-discussion.24119/#post-224568

Maybe fault_state 0x7400 from your logs corresponds to the error code from that doc.

If heartbeat LED flashes, then that also tells you what the fault code is. Linked document describes how to decode that as well.

Also, try to access the card from BIOS/UEFI using sas2flash and especially LSIUtil tool.
 

Terry Kennedy

Well-Known Member
Jun 25, 2015
1,067
505
113
New York City
www.glaver.org
I see that there have been a lot of views on this post but no replies at all. Is there anyone that assist is fixing this?
This may or may not be relevant (I have an R730 with integrated H710 and FreeBSD) but I got random boot error messages until I reset the R730 BIOS to default values (obviously, write down all of your settings first). One of the "fancy option name that sounds like it improves performance" things (I don't remember which one) was the culprit.