1. L

    Minimal hardware for napp-it all-in-one?

    I posted in a different thread: I have been running SmartOS on a SuperMicro motherboard for 6+ years, with spinning disks. I have decided I want to re-architect my ZFS/NAS solution using OmniOS and napp-it, and preferably AiO so I can put all my VMs on the same server and get local disk speed...
  2. A

    napp-IT for dummies

    Does anyone have a simple. "watered down", easy to use, easy to digest setup guide? I find the docs to be a lil cumbersome & the UI isn't very intuitive.
  3. A

    napp-it AiO: NFS share - IP address change

    This box is getting setup at a temp location with a different IP scheme than it's final destination. How do you deal with a changed IP address for the NFS share (in napp-it AiO)?
  4. E

    OminosCe r151038d smb file lock issues

    Hello @gea and everybody, I have migrated my old samba3 file share server(CentOs) to OminosCe r151038d with napp-it. Everything working fine,only having smb file lock issues sometimes. I know smb on Omnios working in-kernel and it is not same bits with samba project. You know there is...
  5. M

    CIFS Logfile for Troubleshooting

    sorry but I cannot help myself. I don`t have any idea, why and when my successfuly AD joined Napp-IT lets me access his smb shares and when not. From my windows explorer on my AD joined PC all is working, but on other PCs or applications the same user gets for the same share an access denied...
  6. F

    Migrating napp-it to new hardware

    Hey there, So I've currently purchased some new hardware for my Esxi/napp-it aio as I couldn't fit any more drives in the current case. I'm currently planning the migration from old to new hardware. I'm going to do a fresh install of esxi and napp-it ovf on the new hardware. When it comes to...
  7. M

    Best way to upgrade from older OmniOS version?

    Hi, I'm currently running OmniOS v11 r151024ar and would like to upgrade to the current branch but am unsure if I can do this in one fell swoop or if I need to take a stepped approach to this by upgrading to intermediary versions first. If anyone can shed some light on with (along with the...
  8. S

    Is Napp-IT-all-in-one ready for use with ESXi 7?

    Was wondering if anyone has tried running Napp-IT-all-in-one under ESXi 7? (or any ZFS based VM for that matter) Been reading reports of people saying that popular LSI based cards are not longer working in ESXi. Since with Napp-it we run in passthrough mode to the VM and we don't need the...
  9. T

    Occasional OmniOS iSCSI disconnect from VMware

    I use a VM with OmniOS r151024ap and napp-it v. 18.01b as a storage server for a VMware 6.0u3 cluster. Around 30 VMs use 8 iSCSI LUNs for storage. It is mostly very stable, but about twice a year the storage VM stops responding to iSCSI requests from ESXi hosts. After an incident, vmkernel log...
  10. AveryFreeman

    Napp-It: Active Directory tab totally blank in 18.12 OmniOS 151030

    Hey, Just upgraded to 151030 and noticed this message: I also keep getting stuff like this: smbd: smb_domain_getinfo: no DC info My 'Active Directory' tab leads to a completely blank menu where I can't configure anything I also just upgraded to Napp-It 18.12 Not sure which upgrade to...
  11. C

    napp-it snaps

    Hi all, Does anyone know how to set up snapshots ala Timeslider on Solaris 11.4 using napp-it? I set up several recurring snapshots on our main filesystem under Jobs/Snaps and enabled the Auto service. This filesystem has two nested filesystems, each are shared via the CIFS service. Several...
  12. 2

    napp-it omnios active directory connection refresh

    Sometimes there is an issue with the DC not being online during a OmniOS reboot (after power outage) OmniOS is up before DC is ready. This leaves SMB active directory non-operational until either a AD rejoin, or a OmniOS reboot. [napp-it 18.12q1 / OmniOS v11 r151022cj / Server 2016]. Is...
  13. M

    Napp-IT ISCSI-Target with CHAP not working for Windows Initiators

    Hello, at lest I do not get it up and running ;-) Comstar configured within the good Napp-IT WebGUI without CHAP works instantly. But for security reasons one likes to have CHAP enabled... There is not any documention or hint how to do it and the obvious way within the gui: - edit iscsi...
  14. F

    Napp-IT / ESXi issues

    So I'm having a bit of a mare with my ESXi/Napp-IT AIO box atm... It's been running perfectly happily for 2 years+, however in the past week or so I've been experiencing random IO waits when streaming via Kodi or Plex, and they have now got bad enough to trigger an 'All Paths Down' event in...
  15. J

    Can't use emoji in file names on SMB

    OmniOS v11 r151026r napp-it 18.01c free When I try to copy a file with emoji in the name I get the error on Windows. I can copy the file using winscp and the file get copied with out a problem. In terminal I can view all the files but viewing the smb share on windows does not display the file...
  16. AveryFreeman

    NAPP-IT bug: zpool add disks to mirror, pool incorrectly reported non-existant

    Hi, So I am 100% new to Napp-It, I'm running it in a VM on ESXi 6.7 using Omni-OS uname -a SunOS napp-it01 5.11 omnios-r151026-51c7d6fd75 i86pc i386 i86pc (I started with the Jan 2018 Napp-in-One image and upgraded it after changing the publisher to Omni-OSCE since I got an error when...
  17. AveryFreeman

    FreeBSD/FreeNAS vs OmniOS/Napp-it write speeds when used as ESXi NFS VM datastore?

    Hey, so I've done a couple all-in-one ESXi boxes with either FreeNAS or FreeBSD with ZFS I pass to ESXi as NFS datastores. Tried to run VMs but benchmarks exposed gawd-awful write speeds, totally unusable. Just ended up using them for ISO storage and (slow) backups, content libraries, etc...
  18. M

    Worth migrating to Solaris?

    I'm currently using OmniOS 15022 (old) with Napp-it pro but would really like a storage system with SMB3 multichannel support. I really like how simply OmniOS/Napp-it integrate with my domain and allow the use of compmgmt.msc to control permissions and would like to continue using this. I'm...
  19. N

    Napp-it bug tracker?

    @gea Does Napp-IT have a bug tracker? Or a place to report bugs? (I tried googling, but did not find anything) Would you be open to let say have a repo on github with let say the HTML files? – or maybe just have a github just for the bug tracking. Anyhow, I found a typo: Under MTU on the...
  20. M

    Napp-it error in

    I just received a local mail upon login to my OmniOS server running Napp-it pro 17.04 dev: perl: fatal: relocation error: file /var/web-gui/data/napp-it/CGI/auto/IO/Tty/ symbol Perl_xs_apiversion_bootcheck: referenced symbol not found I have seen this thread : [SOLVED] OmniOS...