Is Napp-IT-all-in-one ready for use with ESXi 7?

socra

Member
Feb 4, 2011
81
2
8
Was wondering if anyone has tried running Napp-IT-all-in-one under ESXi 7? (or any ZFS based VM for that matter)

Been reading reports of people saying that popular LSI based cards are not longer working in ESXi.

Since with Napp-it we run in passthrough mode to the VM and we don't need the vmklinux based driver I was wondering if anyone has had time with a test-rig to check if Napp-it with a pass-through HBA is working under ESXi 7.

background:
What is the Impact of the VMKlinux Driver Stack Deprecation? - VMware vSphere Blog
 
  • Like
Reactions: lte

berchti

New Member
Jan 12, 2019
5
1
3
Im running napp-it 20.dev 28b.mar.2020 on the latest omnios without problems. PCI passthrough is configured for two Dell H310 (IT mode) and one NVME.

For now without it looks fine. (beside my slow 10gbe smb problem :p)
 
  • Like
Reactions: socra

gea

Well-Known Member
Dec 31, 2010
2,535
856
113
DE
I have heard that the older 6G LSI 2008 based cards are no longer supported in ESXi. Maybe you no longer want them as for SSD pools you need a newer 12G LSI 3008 based one anyway.

If you use pass-through this does not matter at all as you only need driver support with the OmniOS or Solaris VM and support for LSI 2008 is there mandatory as they are still in use on many storage boxes.
 
  • Like
Reactions: lte and socra

daisho

New Member
Apr 25, 2019
25
3
3
I upgraded my server this week and everything is running fine (omnios *34 already).
My LSI 2308 based controller was ditched anyway as it was onboard previously, now having a 3008 which works just fine.

btw, if someone tries to deploy the latest stable OVA template from napp-it in ESXi 7.x you might get an error about a missing resource ...file2 for nvram ... that features seems to be removed from vsphere now?

Anyway, you can just open the OVA template as archive with e.g. 7zip, edit the included zfs_vsan_omni032_esxi6v1.ovf by right-click > edit
In the text editor go to the bottom and remove this line:
<vmw:ExtraConfig ovf:required="false" vmw:key="nvram" vmw:value="ovf:/file/file2"/>
Save > update the archive when 7zip asks for it because it notices it changed
> Now you can deploy the OVA without errors in vsphere 7.
 
  • Like
Reactions: lte

daisho

New Member
Apr 25, 2019
25
3
3
Deployed the 034 as a test and that worked fine out of the box with 7.0.0, vcenter 16189207 / vsphere 5843807.