Update custom (Cisco) ESXi 6.5 image [Exception]

Harry P. Nyce

Harry P. Nyce
Sep 27, 2017
58
3
8
42
Please help a neophyte attempting to learn a thing or two about a thing or two, by enabling me to update my ESXi 6.5 custom Cisco image with the latest two (2) patches. Current custom Cisco version: ESXi 6.5.0d (2017-04-18) 5310538

Need these two updates: ESXi 6.5 U1 Express Patch 4 (2017-10-05) 6765664 & ESXi 6.5 U1 (2017-07-27) 5969303

This works fine to see my options:
[root@localhost:~] esxcli software sources profile list -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
However, this fails with the following error (see below):
[root@localhost:~] esxcli software profile install -p ESXi-6.5.0-20171004001-standard -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml

[Exception]
You attempted to install an image profile which would have resulted in the removal of VIBs ['Avago_bootbank_lsi-msgpt35_04.00.00.00-1OEM.650.0.0.4598673', 'Intel_bootbank_net-i40e_1.4.28-1OEM.550.0.0.1331820', 'Cisco_Systems_Inc._bootbank_ucs-tool-esxi_1.0.0-1OEM']. If this is not what you intended, you may use the esxcli software profile update command to preserve the VIBs above. If this is what you intended, please use the --ok-to-remove option to explicitly allow the removal.
Please refer to the log file for more details.


Which log file am i supposed to refer to? This same/similar update process worked fine for the stock VMware image, but i had other issues with missing drivers because i neglected to use the special Cisco prebuilt image from VMware. Things are going much better, however i'm not able to apply the two latest patches, ESXi 6.5 U1 Express Patch 4 (2017-10-05) 6765664 & ESXi 6.5 U1 (2017-07-27) 5969303 -- i just created a new USB flash device that's currently running this version: ESXi 6.5.0d (2017-04-18) 5310538

What's the best approach to resolve or workaround this? Do i use the stock VMware image and try to add the custom Cisco VIBs? I had hoped i could use the custom Cisco prebuilt image from VMware's site and simply update it. Please advise. Thanks ya kindly!

EDIT:

-


My initial research lead me to this resource: How to easily update your VMware Hypervisor from 6.5.x to 6.5 Update 1 Express Patch 04 (ESXi 6.5 U1 EP04) | TinkerTry IT @ Home (Thanks, Paul! TinkerTry is a fantastic site, i've learned a bunch there, as well.)
 
Last edited:

Harry P. Nyce

Harry P. Nyce
Sep 27, 2017
58
3
8
42
Apparently this is not possible (at least using the ISO) due to Cisco's custom image. Anyone have suggestions and/or workarounds for the two missing updates i'm trying to apply?