Ubiquiti EdgeSwitch ES-16-XG SFP+ Compatibility Thread

Aestr

Well-Known Member
Oct 22, 2014
898
296
63
Los Angeles
  • Like
Reactions: Patrick

Marsh

Moderator
May 12, 2013
2,257
1,069
113
The same seller has 2m version of cable, BO $45 for 10 cables .
I have 20 x 1m and 20 x 2m cables. I was really happy that the $5 cable just works.
 
  • Like
Reactions: tby

cloud

New Member
Dec 28, 2016
1
0
1
23
Joining in this thread as we've recently invested in upgrading network to 10g through this switch and have run into compatibility issues as well..

We have 6x Cisco SFP-H10GB-CU3M
The switch running the latest firmware (as of date of post 1.7xxx)
6x Mellanox Connect x2 (MNPA19-XTR)
as well as a machine with 10g through a dual port Intel X550T (rev 1.0), connected via CAT7 with 0 issues.

We've extensively tested the equipment using iperf and have come to some conclusions.
Our 2 main issues are:
a. inconsistent bandwidth depending on the cable (even though they're identical model).
b. some ports are completely dead, most notably 1, 11, 12. with 2, 3, 4, 7, 9 running on average at ~4Gb/s, and 5, 6, 8, 10 at ~9 Gb/s

We tested by using our X550T machine as the iperf server and transmitting from the SFP+ based Mellanox machines.
When we tested X550T transmitting to Mellanox, speeds were typically decent on all ports (minus 'dead' ports).

Any recommendations on better cables to look into for the mlx nics?
 

Christopher

New Member
Apr 17, 2016
3
2
3
45
Brand:Fiberstore
Model:Customized 1000BASE-T SFP Copper RJ-45 ID#37762 / FS part# SFP-GB-GE-T
Type (SFP+, DAC): SFP RJ45
DAC length if applicable: Cat 5e & 7 cables connect at 1G
Notes: Compatible Brands Dell 2824

Brand:Fiberstore
Model: .5m 10G SFP+ Passive Direct attach copper twinax cable ID#64250 / FS part# SFP-10G-DAC
Type (SFP+, DAC): DAC
DAC length if applicable: .5m (1.6ft)
Notes: Compatible with Ubiquiti / AWG 30AWG

Using DACs as uplinks on Dell Powerconnect 2824 to 2x US-XG-16s. Currently have Supermicro X10SDV-12C-TLN4F and X10SDV-8C-TLN4F 10G NICs connected to each switch, unable to get consistent 10G connections as per UBNT forum ports.
 
  • Like
Reactions: Patrick

tby

Active Member
Aug 22, 2013
206
91
28
Snellville, GA
set-inform.com
I have 20 x 1m and 20 x 2m cables. I was really happy that the $5 cable just works.
My 2M cables arrived today. Tried 3 so far, two worked going LB6M -> US-16-XG but only in ports 5-8. The third will not link with the XG at all but if I plug it into two ports on the LB6M I get lights. None are working with QLE8152 NICs connected to anything I have.

So maybe not a sure thing.

Some output from a working cable:
Code:
(UBNT) #show fiber-ports optics all

                                    Output    Input
Port      Temp  Voltage  Current     Power    Power   TX     LOS
           [C]   [Volt]     [mA]     [dBm]    [dBm]   Fault
--------  ----  -------  -------   -------  -------   -----  ---
0/1        N/A      N/A      N/A       N/A      N/A   N/A    N/A
0/2        N/A      N/A      N/A       N/A      N/A   N/A    N/A
0/7
0/12      23.9    3.302      7.6    -1.787   -2.510   No     No

 Temp - Internally measured transceiver temperatures.
 Voltage - Internally measured supply voltage.
 Current - Measured TX bias current.
 Output Power - Measured optical output power relative to 1mW.
 Input Power - Measured optical power received relative to 1mW.
 TX Fault - Transmitter fault.
 LOS - Loss of signal.

(UBNT) #show fiber-ports optics-info all

                         Link Link                                 Nominal
                       Length Length                                   Bit
                         50um 62.5um                                  Rate
Port     Vendor Name      [m] [m]  Serial Number    Part Number     [Mbps] Rev  Compliance
-------- ---------------- --- ---- ---------------- ---------------- ----- ---- ----------------
0/1      Arista Networks  0   0    XHC104910050     CAB-SFP-SFP-1M   10300 0002 DAC
0/2      Arista Networks  0   0    XPV104632498     CAB-SFP-SFP-1M   10300 0002 DAC
0/12     FINISAR CORP.    8   3    AL80LUD          FTLX8571D3BCL    10300 A    10GBase-SR

Don't know how to get comparable output from the Quanta side but it is passing traffic.
 
  • Like
Reactions: Chrisbrns

Chrisbrns

chrisbrns.com
Nov 13, 2011
29
5
3
Central Florida
www.chrisbrns.com
My 2M cables arrived today. Tried 3 so far, two worked going LB6M -> US-16-XG but only in ports 5-8. The third will not link with the XG at all but if I plug it into two ports on the LB6M I get lights. None are working with QLE8152 NICs connected to anything I have.

So maybe not a sure thing.

Some output from a working cable:
Code:
(UBNT) #show fiber-ports optics all

                                    Output    Input
Port      Temp  Voltage  Current     Power    Power   TX     LOS
           [C]   [Volt]     [mA]     [dBm]    [dBm]   Fault
--------  ----  -------  -------   -------  -------   -----  ---
0/1        N/A      N/A      N/A       N/A      N/A   N/A    N/A
0/2        N/A      N/A      N/A       N/A      N/A   N/A    N/A
0/7
0/12      23.9    3.302      7.6    -1.787   -2.510   No     No

 Temp - Internally measured transceiver temperatures.
 Voltage - Internally measured supply voltage.
 Current - Measured TX bias current.
 Output Power - Measured optical output power relative to 1mW.
 Input Power - Measured optical power received relative to 1mW.
 TX Fault - Transmitter fault.
 LOS - Loss of signal.

(UBNT) #show fiber-ports optics-info all

                         Link Link                                 Nominal
                       Length Length                                   Bit
                         50um 62.5um                                  Rate
Port     Vendor Name      [m] [m]  Serial Number    Part Number     [Mbps] Rev  Compliance
-------- ---------------- --- ---- ---------------- ---------------- ----- ---- ----------------
0/1      Arista Networks  0   0    XHC104910050     CAB-SFP-SFP-1M   10300 0002 DAC
0/2      Arista Networks  0   0    XPV104632498     CAB-SFP-SFP-1M   10300 0002 DAC
0/12     FINISAR CORP.    8   3    AL80LUD          FTLX8571D3BCL    10300 A    10GBase-SR

Don't know how to get comparable output from the Quanta side but it is passing traffic.
Ports 5-8 seem to be the only working ports for me too. And not even reliably. Super bummed on this unit.


Sent from my iPhone using Tapatalk
 
Mar 7, 2015
56
6
8
I purchased 3 x Cisco SFP-H10GB-CU5M based on earlier reports that 1M and 3M worked. It negotiated at full speed between my US-16-XG and Netgear S3300. However, a Cat 7 cable connected to a S3300 10GbE port negotiated at only 1Gbps until I restarted the US-16-XG, at which point it negotiated full speed.
 
Last edited:

pyro_

Active Member
Oct 4, 2013
726
161
43
Was just able to test a few between my US-16-XG and Netgear XS708T switches

Working SFP+ optics
ACP J9150A-AO
Mellanox MFM1T02A-SR A1 / FTLX8571D3BCL-ME

Working SFP 1gb optics
Finisar FTRJ-8519-7D-2.5 (must manually set at 1gb negotiation not auto)

Working DAC
Force10 CBL-10GSFP-DAC-0,5M

Kinda sorta working DAC
Dell CBL-10GSFP-DAC-2M
Have tried two of these cables with the same results, also tried different ports to make sure. It will not connect between this switch and my Netgear XS708T however it will connect to a server running a Mellanox Connect X 2 card. Cables also work between the server and the netgear switch so it is something between the two switches that is the issue

No issues with getting 10gb link using CAT7 cables between the two switches
 
Last edited:

zeynel

Active Member
Nov 4, 2015
483
101
43
44
@XmiX , thanks for the message, i ordered a 20 package. for 319,97€ without VAT , incl. paypal and delivery.
 
  • Like
Reactions: XmiX
Sep 7, 2016
111
24
18
31
Was thinking about picking up one of these switches. Seems like a lot of the problems stem from DAC instead of fiber connections. I was planning on picking up some SFP+ modules (The arista ones) and using fiber. Are there any isses with NICs, specificially the Intel X520-DA1/2 or the 10Gbase rj45 ports found on most supermicro boards and this switch?

Thanks in advance!
 

pyro_

Active Member
Oct 4, 2013
726
161
43
The x550 rj45 ports which a lot of the Xeon-d boards have do have issues with this switch


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: CookiesLikeWhoa
Sep 7, 2016
111
24
18
31
The x550 rj45 ports which a lot of the Xeon-d boards have do have issues with this switch


Sent from my iPhone using Tapatalk
Alright the board I was looking at uses an Intel x540 chipset. Hopefully that will work out.


Sent from my iPhone using Tapatalk
 

wildchild

Active Member
Feb 4, 2014
394
57
28
Yes, they are the same hardware, and underlying software
This are slowly improving, but everyone is waiting for a chipset update from broadcom ( the underlying chipset)
 

Kybber

Active Member
May 27, 2016
132
33
28
44
Did you actually mean "chipset update" or did you mean "firmware update for the chipset"? I hope it's the latter...?