Ubiquiti EdgeSwitch ES-16-XG SFP+ Compatibility Thread

Discussion in 'Networking' started by Patrick, Aug 31, 2016.

  1. Aestr

    Aestr Well-Known Member

    Joined:
    Oct 22, 2014
    Messages:
    861
    Likes Received:
    263
    #81
    Patrick likes this.
  2. Marsh

    Marsh Moderator

    Joined:
    May 12, 2013
    Messages:
    2,113
    Likes Received:
    964
    The same seller has 2m version of cable, BO $45 for 10 cables .
    I have 20 x 1m and 20 x 2m cables. I was really happy that the $5 cable just works.
     
    #82
    tby likes this.
  3. cloud

    cloud New Member

    Joined:
    Dec 28, 2016
    Messages:
    1
    Likes Received:
    0
    Joining in this thread as we've recently invested in upgrading network to 10g through this switch and have run into compatibility issues as well..

    We have 6x Cisco SFP-H10GB-CU3M
    The switch running the latest firmware (as of date of post 1.7xxx)
    6x Mellanox Connect x2 (MNPA19-XTR)
    as well as a machine with 10g through a dual port Intel X550T (rev 1.0), connected via CAT7 with 0 issues.

    We've extensively tested the equipment using iperf and have come to some conclusions.
    Our 2 main issues are:
    a. inconsistent bandwidth depending on the cable (even though they're identical model).
    b. some ports are completely dead, most notably 1, 11, 12. with 2, 3, 4, 7, 9 running on average at ~4Gb/s, and 5, 6, 8, 10 at ~9 Gb/s

    We tested by using our X550T machine as the iperf server and transmitting from the SFP+ based Mellanox machines.
    When we tested X550T transmitting to Mellanox, speeds were typically decent on all ports (minus 'dead' ports).

    Any recommendations on better cables to look into for the mlx nics?
     
    #83
  4. tby

    tby Active Member

    Joined:
    Aug 22, 2013
    Messages:
    206
    Likes Received:
    90
    I got them to take $35 on a 10x2M listing. And for some reason eBay was defaulting to UPS ground for $25 but would let me choose USPS Priority for $16.
     
    #84
    StevenDTX likes this.
  5. StevenDTX

    StevenDTX Active Member

    Joined:
    Aug 17, 2016
    Messages:
    306
    Likes Received:
    113
    Thanks! I, too, got them for $47 shipped.
     
    #85
  6. Christopher

    Christopher New Member

    Joined:
    Apr 17, 2016
    Messages:
    3
    Likes Received:
    2
    Brand:Fiberstore
    Model:Customized 1000BASE-T SFP Copper RJ-45 ID#37762 / FS part# SFP-GB-GE-T
    Type (SFP+, DAC): SFP RJ45
    DAC length if applicable: Cat 5e & 7 cables connect at 1G
    Notes: Compatible Brands Dell 2824

    Brand:Fiberstore
    Model: .5m 10G SFP+ Passive Direct attach copper twinax cable ID#64250 / FS part# SFP-10G-DAC
    Type (SFP+, DAC): DAC
    DAC length if applicable: .5m (1.6ft)
    Notes: Compatible with Ubiquiti / AWG 30AWG

    Using DACs as uplinks on Dell Powerconnect 2824 to 2x US-XG-16s. Currently have Supermicro X10SDV-12C-TLN4F and X10SDV-8C-TLN4F 10G NICs connected to each switch, unable to get consistent 10G connections as per UBNT forum ports.
     
    #86
    Patrick likes this.
  7. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,564
    Likes Received:
    4,498
    @Christopher where should those go? Working? Not working?
     
    #87
  8. Christopher

    Christopher New Member

    Joined:
    Apr 17, 2016
    Messages:
    3
    Likes Received:
    2
    Sorry, should have listed both as working.
     
    #88
    Patrick likes this.
  9. tby

    tby Active Member

    Joined:
    Aug 22, 2013
    Messages:
    206
    Likes Received:
    90
    My 2M cables arrived today. Tried 3 so far, two worked going LB6M -> US-16-XG but only in ports 5-8. The third will not link with the XG at all but if I plug it into two ports on the LB6M I get lights. None are working with QLE8152 NICs connected to anything I have.

    So maybe not a sure thing.

    Some output from a working cable:
    Code:
    (UBNT) #show fiber-ports optics all
    
                                        Output    Input
    Port      Temp  Voltage  Current     Power    Power   TX     LOS
               [C]   [Volt]     [mA]     [dBm]    [dBm]   Fault
    --------  ----  -------  -------   -------  -------   -----  ---
    0/1        N/A      N/A      N/A       N/A      N/A   N/A    N/A
    0/2        N/A      N/A      N/A       N/A      N/A   N/A    N/A
    0/7
    0/12      23.9    3.302      7.6    -1.787   -2.510   No     No
    
     Temp - Internally measured transceiver temperatures.
     Voltage - Internally measured supply voltage.
     Current - Measured TX bias current.
     Output Power - Measured optical output power relative to 1mW.
     Input Power - Measured optical power received relative to 1mW.
     TX Fault - Transmitter fault.
     LOS - Loss of signal.
    
    (UBNT) #show fiber-ports optics-info all
    
                             Link Link                                 Nominal
                           Length Length                                   Bit
                             50um 62.5um                                  Rate
    Port     Vendor Name      [m] [m]  Serial Number    Part Number     [Mbps] Rev  Compliance
    -------- ---------------- --- ---- ---------------- ---------------- ----- ---- ----------------
    0/1      Arista Networks  0   0    XHC104910050     CAB-SFP-SFP-1M   10300 0002 DAC
    0/2      Arista Networks  0   0    XPV104632498     CAB-SFP-SFP-1M   10300 0002 DAC
    0/12     FINISAR CORP.    8   3    AL80LUD          FTLX8571D3BCL    10300 A    10GBase-SR
    

    Don't know how to get comparable output from the Quanta side but it is passing traffic.
     
    #89
    Chrisbrns likes this.
  10. Chrisbrns

    Chrisbrns chrisbrns.com

    Joined:
    Nov 13, 2011
    Messages:
    29
    Likes Received:
    5
    Ports 5-8 seem to be the only working ports for me too. And not even reliably. Super bummed on this unit.


    Sent from my iPhone using Tapatalk
     
    #90
  11. timothy.lazarus

    Joined:
    Mar 7, 2015
    Messages:
    51
    Likes Received:
    5
    I purchased 3 x Cisco SFP-H10GB-CU5M based on earlier reports that 1M and 3M worked. It negotiated at full speed between my US-16-XG and Netgear S3300. However, a Cat 7 cable connected to a S3300 10GbE port negotiated at only 1Gbps until I restarted the US-16-XG, at which point it negotiated full speed.
     
    #91
    Last edited: Jan 10, 2017
  12. XmiX

    XmiX New Member

    Joined:
    Oct 7, 2016
    Messages:
    10
    Likes Received:
    1
    #92
  13. pyro_

    pyro_ Active Member

    Joined:
    Oct 4, 2013
    Messages:
    726
    Likes Received:
    161
    Was just able to test a few between my US-16-XG and Netgear XS708T switches

    Working SFP+ optics
    ACP J9150A-AO
    Mellanox MFM1T02A-SR A1 / FTLX8571D3BCL-ME

    Working SFP 1gb optics
    Finisar FTRJ-8519-7D-2.5 (must manually set at 1gb negotiation not auto)

    Working DAC
    Force10 CBL-10GSFP-DAC-0,5M

    Kinda sorta working DAC
    Dell CBL-10GSFP-DAC-2M
    Have tried two of these cables with the same results, also tried different ports to make sure. It will not connect between this switch and my Netgear XS708T however it will connect to a server running a Mellanox Connect X 2 card. Cables also work between the server and the netgear switch so it is something between the two switches that is the issue

    No issues with getting 10gb link using CAT7 cables between the two switches
     
    #93
    Last edited: Jan 14, 2017
  14. zeynel

    zeynel Active Member

    Joined:
    Nov 4, 2015
    Messages:
    462
    Likes Received:
    93
    @XmiX , thanks for the message, i ordered a 20 package. for 319,97€ without VAT , incl. paypal and delivery.
     
    #94
    XmiX likes this.
  15. CookiesLikeWhoa

    Joined:
    Sep 7, 2016
    Messages:
    111
    Likes Received:
    24
    Was thinking about picking up one of these switches. Seems like a lot of the problems stem from DAC instead of fiber connections. I was planning on picking up some SFP+ modules (The arista ones) and using fiber. Are there any isses with NICs, specificially the Intel X520-DA1/2 or the 10Gbase rj45 ports found on most supermicro boards and this switch?

    Thanks in advance!
     
    #95
  16. pyro_

    pyro_ Active Member

    Joined:
    Oct 4, 2013
    Messages:
    726
    Likes Received:
    161
    The x550 rj45 ports which a lot of the Xeon-d boards have do have issues with this switch


    Sent from my iPhone using Tapatalk
     
    #96
    CookiesLikeWhoa likes this.
  17. CookiesLikeWhoa

    Joined:
    Sep 7, 2016
    Messages:
    111
    Likes Received:
    24
    Alright the board I was looking at uses an Intel x540 chipset. Hopefully that will work out.


    Sent from my iPhone using Tapatalk
     
    #97
  18. CookiesLikeWhoa

    Joined:
    Sep 7, 2016
    Messages:
    111
    Likes Received:
    24
    You'll have to forgive me on the double post but do the SFP+ modules also apply to the US-16-XG switch as well?
     
    #98
  19. wildchild

    wildchild Active Member

    Joined:
    Feb 4, 2014
    Messages:
    394
    Likes Received:
    57
    Yes, they are the same hardware, and underlying software
    This are slowly improving, but everyone is waiting for a chipset update from broadcom ( the underlying chipset)
     
    #99
  20. Kybber

    Kybber Active Member

    Joined:
    May 27, 2016
    Messages:
    130
    Likes Received:
    33
    Did you actually mean "chipset update" or did you mean "firmware update for the chipset"? I hope it's the latter...?
     
    #100
Similar Threads: Ubiquiti EdgeSwitch
Forum Title Date
Networking 12 sfp+ + 4 10gbe rj45 - Ubiquiti Edgeswitch 16xg Aug 3, 2016
Networking Ubiquiti EdgeSwitch lite 24/48 ports (no PoE) Jul 1, 2015
Networking HPE 1920 8G PoE+ (180W) Switch -vs- Ubiquiti ES-8-150W Mar 7, 2019
Networking Ubiquiti WAPs any good? / Buying them on Amazon? Dec 15, 2018
Networking DAC compatible with Cisco P81E VIC and Ubiquiti US-16-XG Sep 11, 2018

Share This Page