Ubiquiti EdgeSwitch ES-16-XG SFP+ Compatibility Thread

Discussion in 'Networking' started by Patrick, Aug 31, 2016.

  1. Chrisbrns

    Chrisbrns chrisbrns.com

    Joined:
    Nov 13, 2011
    Messages:
    29
    Likes Received:
    5
    Hey, that is my post. I got nothing back from ubnt. Will keep you posted if anything turns up.


    Sent from my iPhone using Tapatalk
     
    #41
    Patrick likes this.
  2. Hank C

    Hank C Active Member

    Joined:
    Jun 16, 2014
    Messages:
    642
    Likes Received:
    66
    does any of the working DAC work on Intel X520 cards?
     
    #42
  3. slurpeesurprise

    slurpeesurprise New Member

    Joined:
    Oct 24, 2016
    Messages:
    2
    Likes Received:
    2
    Brand: Intel
    Model: AFBR-703SDZ-IN2
    Type (SFP+, DAC): SFP+
    DAC length if applicable: n/a
    Status: Working

    Brand: HP
    Model: X242 (J9281B)
    Type (SFP+, DAC): DAC
    DAC length if applicable: 1m
    Status: Working
     
    #43
    Patrick likes this.
  4. slurpeesurprise

    slurpeesurprise New Member

    Joined:
    Oct 24, 2016
    Messages:
    2
    Likes Received:
    2
    I used an HP X242 (J9281B) with an X520 to the ES-16-XG without a problem.
     
    #44
    Patrick likes this.
  5. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,524
    Likes Received:
    4,450
    #45
  6. Hank C

    Hank C Active Member

    Joined:
    Jun 16, 2014
    Messages:
    642
    Likes Received:
    66
    what about Chelsio T420 compatibility to this switch? Which DAC will work?
     
    #46
  7. MiniKnight

    MiniKnight Well-Known Member

    Joined:
    Mar 30, 2012
    Messages:
    2,936
    Likes Received:
    857
    Which T420?
     
    #47
  8. Hank C

    Hank C Active Member

    Joined:
    Jun 16, 2014
    Messages:
    642
    Likes Received:
    66
    T420-CR
     
    #48
  9. Chrisbrns

    Chrisbrns chrisbrns.com

    Joined:
    Nov 13, 2011
    Messages:
    29
    Likes Received:
    5
    I wouldn't consider that working then... if it's working by connecting the switches, there is a great chance it will stop working under load, configuration changes, etc. I had a few non working cables connect like this, but then stop out of nowhere. Frustrating....


    Sent from my iPhone using Tapatalk
     
    #49
  10. Chrisbrns

    Chrisbrns chrisbrns.com

    Joined:
    Nov 13, 2011
    Messages:
    29
    Likes Received:
    5
    I won't sell this switch until it works with DAC cables. It's completely useless in the real world and no production can stand on "maybe it will work in the future".


    Sent from my iPhone using Tapatalk
     
    #50
    nev_neo and wsuff like this.
  11. nev_neo

    nev_neo Member

    Joined:
    Jul 31, 2013
    Messages:
    129
    Likes Received:
    19
    Do the 10gig on the Xeon-D (X10SDV-4C) motherboards work with this switch ?
    Do any of the RJ-45's link up at 10G ?
     
    #51
  12. Waldek

    Waldek New Member

    Joined:
    Apr 3, 2016
    Messages:
    17
    Likes Received:
    2
    In my case yes. There is some randomness though (this switch is one big mistery - I am very dissapointed that I have bought it). I have had to force the network ports on the X10SDV-4C-TLN4F to 10G, because when using the auto-negotiation it always links at 1G. Still, sometimes just rebooting the X10SDV causes one of the 10G ports of the ES-16-XG to not to link. Same problems regardless if it is firmware version 1.6 or the newer 1.7 beta 1.

    All in all, do not buy - too much frustration... Sorry...
     
    #52
  13. trumee

    trumee Member

    Joined:
    Jan 31, 2016
    Messages:
    180
    Likes Received:
    9
    Do the following work:

    SFP+
    Cisco GLC-SX-MM, 30-1301-02, Class 1 21CFR1040.10

    Copper/RJ-45
    Chelsio T420-BT Copper
     
    #53
  14. Waldek

    Waldek New Member

    Joined:
    Apr 3, 2016
    Messages:
    17
    Likes Received:
    2
    Just to add: I have just received the Cisco SFP-H10GB-CU1M (1 meter long) cable and can confirm it works OK when connected to the Dell Intel X520 (-DA2 in my case) network card. I.e. SFP+ recognized, 10G speed (even with the auto-negotiation), links ever after the switch or the server reboot ;-)

    So, apparently the problem is with SFP+ cables longer than 1 meter (my Cisco SFP-H10GB-CU3M, which a 3 meter cable, does not work). Ubiquity support says it might work with 1.8 firmware, which provided that 1.7 beta1 is the current one, might mean somewhere in 2017...

    It might not be just the length, but also if the DAC is passive or active. I do not have any active cable to verify, unfortunately (even the short 1-3 active DAC cables cost way above 100 USD currently, so might be quite expensive in a home lab environment).
    Anyway, for a home lab (where the 1m cable might be sufficient), there is some hope for a cheap solution to the problem with ES-6-XG and Intel X520 NICs. Just use 1m ones ;-)
     
    #54
  15. Scott Laird

    Scott Laird Active Member

    Joined:
    Aug 30, 2014
    Messages:
    218
    Likes Received:
    84
    #55
  16. chilipepperz

    chilipepperz Active Member

    Joined:
    Mar 17, 2016
    Messages:
    204
    Likes Received:
    61
    @Scott Laird that's a funny vendor locking. "Our PHY's are so poor we only recommend using our optics."
     
    #56
    StevenDTX likes this.
  17. trumee

    trumee Member

    Joined:
    Jan 31, 2016
    Messages:
    180
    Likes Received:
    9
    Following works:

    Brand: Finisar
    Model: Force10 FTLX8571D3BCL-FC, GP-10GSFP-1S
    Type (SFP+, DAC): SFP+

    Brand: CISCO-FINISAR
    Model: GLC-SX-MM 30-1301-02 1000Base-sx transceiver, FTLF8519P2BCL-CS
    Type (SFP+, DAC): SFP
    Notes: Need to manually set 1G mode in ES-16-XG

    Chelsio T420-BT ethernet card
    Intel Corporation Ethernet Controller 10-Gigabit X540-AT2
    Mellanox ConnectX-2 Single port
     
    #57
    Last edited: Nov 3, 2016
    Patrick likes this.
  18. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,524
    Likes Received:
    4,450
    Thanks @trumee post #1 updated.
     
    #58
  19. StevenDTX

    StevenDTX Active Member

    Joined:
    Aug 17, 2016
    Messages:
    303
    Likes Received:
    109
    My switch arrived today. I was all excited because I thought I had all the cables I needed. Needless to day, I have been disappointed. I read all the warnings, but I could not overcome the "in-stock" email I received earlier in the week.

    Here is what works:
    F5 OPT-0016-00 - Works in all ports! Connected it to a Dell X1052 and a Mellanox ConnectX-2.

    Here is what PARTIALLY works:
    Cisco SFP-H10GB-CU1M - Works only in ports 5-8.
    Cisco SFP-H10GB-CU3M - Works only in ports 5-8.
    HP 684517-001/Amphenol 0.5M - Works in ports 1-10. Connected it to a Dell X1052 and a HP 570SFP+/Solarflare SFC9020.


    I did update the firmware to 1.70. I did not test any of these prior to the update.

    And as you can see, all of the ports recognize that a cable is inserted.

    Code:
    (UBNT EdgeSwitch) #show version
    
    Switch: 1
    
    System Description............................. EdgeSwitch 16-Port 10G, 1.7.0.4922892, Linux 3.6.5, 1.0.0.4872137
    Machine Type................................... EdgeSwitch 16-Port 10G
    Machine Model.................................. ES-16-XG
    Serial Number.................................. 802AA89EEBB2
    Burned In MAC Address.......................... 80:2A:A8:9E:EB:B2
    Software Version............................... 1.7.0.4922892
    
    (UBNT EdgeSwitch) #show fiber-ports optics-info all
    
                             Link Link                                 Nominal
                           Length Length                                   Bit
                             50um 62.5um                                  Rate
    Port     Vendor Name      [m] [m]  Serial Number    Part Number     [Mbps] Rev  Compliance
    -------- ---------------- --- ---- ---------------- ---------------- ----- ---- ----------------
    0/1      CISCO-TYCO       0   0    TED1542A6HE      1-2053783-1      10300 P    DAC
    0/2      CISCO-TYCO       0   0    TED1542A6HE      1-2053783-1      10300 P    DAC
    0/3      CISCO-TYCO       0   0    TED1542A6EC      1-2053783-1      10300 P    DAC
    0/4      CISCO-TYCO       0   0    TED1542A6EC      1-2053783-1      10300 P    DAC
    0/5      CISCO-TYCO       0   0    TED1542A6CG      1-2053783-1      10300 P    DAC
    0/6      CISCO-TYCO       0   0    TED1542A6CG      1-2053783-1      10300 P    DAC
    0/7      CISCO-TYCO       0   0    TED1541A0Q6      1-2053783-1      10300 P    DAC
    0/8      CISCO-TYCO       0   0    TED1541A0Q6      1-2053783-1      10300 P    DAC
    0/9      CISCO-TYCO       0   0    TED1541A03M      1-2053783-1      10300 P    DAC
    0/10     Amphenol         0   0    APF12240015REJ   611980001        10300 A    DAC
    0/11     Amphenol         0   0    APF12240015REJ   611980001        10300 A    DAC
    0/12     CISCO-TYCO       0   0    TED1541A03M      1-2053783-1      10300 P    DAC
    
    
     
    #59
  20. Jeff Robertson

    Jeff Robertson Active Member

    Joined:
    Oct 18, 2016
    Messages:
    349
    Likes Received:
    70
    Thanks for the info, just ordered a batch of F5 OPT-0016-00 off of ebay! No switch yet but I'll order one some day.
     
    #60
Similar Threads: Ubiquiti EdgeSwitch
Forum Title Date
Networking 12 sfp+ + 4 10gbe rj45 - Ubiquiti Edgeswitch 16xg Aug 3, 2016
Networking Ubiquiti EdgeSwitch lite 24/48 ports (no PoE) Jul 1, 2015
Networking HPE 1920 8G PoE+ (180W) Switch -vs- Ubiquiti ES-8-150W Mar 7, 2019
Networking Ubiquiti WAPs any good? / Buying them on Amazon? Dec 15, 2018
Networking DAC compatible with Cisco P81E VIC and Ubiquiti US-16-XG Sep 11, 2018

Share This Page