Ubiquiti EdgeSwitch ES-16-XG SFP+ Compatibility Thread

Discussion in 'Networking' started by Patrick, Aug 31, 2016.

  1. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    Still in search of some sub $30 2m DAC's that work with this switch since I need to buy at least 8 of them to replace my Nebula's.
     
    #21
  2. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    So good news...

    My Nebula CBL-10GSFP-DAC-2M 2M SFP+ DAC do in fact work but only when connected to both my Ubiquiti switches (ES-48-LITE & ES-16-XG) on both ends. Before I was testing between my Dell X1052 and the ES-16-XG in which case I was getting no link or inventory recognition. Now I need to test connectivity between the Ubiquiti switch and my SuperMicro Xeon D servers.

    Will report back once I can test that @Patrick so you can possible move the Nebula DAC's to the "Working" section.
     
    #22
  3. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,524
    Likes Received:
    4,450
    Very strange indeed! Maybe working with an asterisk?
     
    #23
  4. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    So it appears the issue is indeed the ES-16-XG compatibility. The Nebula DACs work fine connecting my ES-48-LITE to either my Dell X1052 or my SuperMicro SFP+ ports. However the ES-16-XG will ONLY work if connected to the ES-48-LITE. It will not link up to either my Dell X1052 OR my SuperMicro SFP+ ports. I've yet to upgrade the firmware on the switch so maybe I'll give that a shot but if that's a no go it's really disappointing.
     
    #24
  5. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    Well you can add that * @Patrick. Even after a firmware upgrade the Nebula DAC's do not work between the ES-16-XG and any of my other non-Ubiquiti devices include the onboard SFP+ ports on my SM servers.
     
    #25
  6. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    I purchased generic DACs from FS.com that arrived today. I advised I'd need these DAC's to work between a Ubiquiti ES-16-XG and SFP+ ports on SuperMicro X10SDV boards. I will test tonight and report back.
     
    #26
    Patrick likes this.
  7. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    Well that's a NO GO on the FS.com generic DAC's. Looks like I'm going to have to return them. I'll be honest I'm getting pretty tired of this trial and error and may just foot the bill for official Cisco DAC's.
     
    #27
  8. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,524
    Likes Received:
    4,450
    @IamSpartacus mind sharing the FS model number(s) so we can add to the list?
     
    #28
  9. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    The P/N is SFP-10G-DAC but that's just the generic model #. When you order customized here it asks you choose the switch brand and enter the switch model number. I even spoke to the head salesman there personally who said they would test connectivity for my exact scenario which was obviously BS.

    P.S. Same situation as my Nebula DAC's, the FS DAC's work fine connecting Ubiquiti to Ubiquiti switch but not to any other device (Intel SFP+, Dell Switch).
     
    #29
    Last edited: Sep 16, 2016
  10. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,524
    Likes Received:
    4,450
    Thanks! List updated.
     
    #30
  11. lkmhaqer

    lkmhaqer New Member

    Joined:
    Sep 16, 2016
    Messages:
    1
    Likes Received:
    0
    Have you attempted to get a DAC that is coded for two different vendor eprom on each end? For instance UBNT on one SFP+ and Cisco/Intel on the other SFP+? This is needed in some situations when a NIC only supports their own "vendors" DAC.
     
    #31
  12. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    Well when I spoke to the salesman at FS.com I specifically asked for exactly that but it doesn't appear to have happened. Where else can I have that done for a reasonable price?

    BTW, my Cisco DACs work fine between the UBNT switch and my Intel NICs.
     
    #32
    Last edited: Sep 16, 2016
  13. GCM

    GCM Active Member

    Joined:
    Aug 24, 2015
    Messages:
    137
    Likes Received:
    43
  14. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    Ok I'm officially at a loss...

    My Cisco SFP-H10GB-CU2-5M cables showed up today and they DO NOT WORK! I figured since my CU1M cables work fine these had a to be a sure thing, I mean...they're just an extra 1.5M in length. Well, I was wrong. They will not link up any device to the ES-16-XG, not even to the ES-48-LITE. This switch is officially a royal pain in the ass. I've never had such difficulty getting DACs to work.

    I don't even know where to go from here. I've confirmed the 1M work for me but those are two short to reach my servers, while others have said the 3M work based on the OP but those are way too long. Even these 2.5M were too long but they don't even work.

    Very frustrated.


    P.S. Just found this nugget over on the Ubiquiti forums. Not happy about this. Looks like it's transceivers or bust.
     
    #34
    Last edited: Sep 23, 2016
  15. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,524
    Likes Received:
    4,450
    @IamSpartacus that trend is becoming apparent given the list we have compiled.
     
    #35
  16. IamSpartacus

    IamSpartacus Well-Known Member

    Joined:
    Mar 14, 2016
    Messages:
    1,896
    Likes Received:
    400
    Yea, I think I should have been more patient and waited for version 2 of this switch. It seems Ubiquiti is known for v1 issues according to many.

    I'm giving serious consideration to returning this switch and saving up for a SG350XG-24.
     
    #36
  17. himynameisdaniel

    Joined:
    Aug 17, 2016
    Messages:
    32
    Likes Received:
    1
    Got an interesting update whilst playing with my Edgeswitch.
    upgraded to latest 1.6 firmware

    can confirm transceiver Finisar FTLX8571D3BNL-E5 is working (shows as revision B in webUI) operates as 10GBase-SR no issues on all ports.
    the problem is my intel X520 DA2 cards do not like those.
    I get the feeling we need a global SFP\DAC\NIC\Switch\ compatibility vs known working page...

    managed to get my 2m intel coded FiberStore DAC 10GSFP-PC-30-2 IN* which work for my intel DA2 nics. HOWEVER i could not get them to work in all ports...
    IE; 0/9, 0/10 work however some others do not.
    on closer inspection there seems to be no physical issue with either the SFP+ slot or DAC and the DAC is even picked up in the webUI however no link can be established.
    So I'm guessing there will be a major firmware update sometime to fix this.
     
    #37
  18. Zeronic

    Zeronic New Member

    Joined:
    Sep 29, 2016
    Messages:
    2
    Likes Received:
    1
    Can also confirm they work with the Intel X552 on the Supermicro X10SDV.
     
    #38
    ultradense likes this.
  19. XmiX

    XmiX New Member

    Joined:
    Oct 7, 2016
    Messages:
    10
    Likes Received:
    1
    My experience with ES-16-XG and different DACs:

    ES-16-XG firmware version is 1.6.0

    Scenario 1:

    MikroTik CRS226-24G-2S+ connected to ES-16-XG

    Port activity light on CRS226-24G-2S+ is active with every DAC I tested, but on ES-16-XG side is different story:

    DAC – MikroTik S+DA0001 – Working with all ports on ES-16-XG
    DAC – MikroTik S+DA0003 – Working only with ports: 05,06,07,08,10
    DAC – Cisco SFP-H10GB-CU3M – Working only with ports: 05,06,07,08,10

    Scenario 2:

    ES-16-XG connected to Mellanox MNPA19-XTR

    Port activity light on MNPA19-XTR is active with every DAC I tested, but only DAC that works on ES-16-XG side is DAC – MikroTik S+DA0001 on all ports. All other DAC are failing to establish connection.

    This is very strange situation, why only some port are working and other not? I am starting to think that maybe this is more hardware problem then software one. Or my switch is defected?!

    SFP+ modules confirmed working:
    SOURCEPHOTONICS - FTLX8571D3BCL-HC
    SOURCEPHOTONICS - SPP10ESRCDFB

    All comments and suggestions are most welcome.
     
    #39
    Last edited: Oct 7, 2016
  20. himynameisdaniel

    Joined:
    Aug 17, 2016
    Messages:
    32
    Likes Received:
    1
    XmiX. i have the same CRS switch also connected. had the same issues. except different ports worked for my DAC cables.
    Also had issues that on switch reboot some additional ports were picked up (but not all) providing there was a DAC already plugged in.
    UBNT support even admitted that DA cables do not work very well at this stage and to use transceivers. So we can only hope that they are working to resolve this issue.
     
    #40
    Chrisbrns likes this.
Similar Threads: Ubiquiti EdgeSwitch
Forum Title Date
Networking 12 sfp+ + 4 10gbe rj45 - Ubiquiti Edgeswitch 16xg Aug 3, 2016
Networking Ubiquiti EdgeSwitch lite 24/48 ports (no PoE) Jul 1, 2015
Networking HPE 1920 8G PoE+ (180W) Switch -vs- Ubiquiti ES-8-150W Mar 7, 2019
Networking Ubiquiti WAPs any good? / Buying them on Amazon? Dec 15, 2018
Networking DAC compatible with Cisco P81E VIC and Ubiquiti US-16-XG Sep 11, 2018

Share This Page