Quanta LB6M (10GbE) -- Discussion

WeekendWarrior

Active Member
Apr 2, 2015
335
129
43
55
I've followed this thread closely and others re 10G and seem ready to take the 10G plunge. I wonder if the LB6M is a reasonable way to do so.

The used price for these is very attractive but I can't tell if I'm jumping into deep water re complexity. I would want a 10G switch that was relatively easy to configure, worked reliably, and didn't draw too much idle power (what everyone wants, right?). I will have help getting it configured but don't want a huge project doing that. For idle power 100W is OK but 300W would seem unreasonable. I don't need exotic functionality or maximizing performance - I will only do fairly basic things like VLANs and possibly LACP.

After reading this thread and numerous others I'm leaning toward the LB6M but wonder if another switch may be better in the sub-$1k price point. If compatible used optics were available that would certainly influence the decision.

Is the LB6M a reasonable choice for these goals and is there a better choice?

Thanks in advance --
Dave
 

PigLover

Moderator
Jan 26, 2011
3,049
1,350
113
The LB6M appears reliable and stable once configured.

If your use case is simple then it is indeed simple to configure. Vanilla layer 2 switching is 'out of the box' easy.

There is, however, limited documentation. Your a bit on your own.

VLAN works OK but config takes a bit to figure out. Not too complex.

Gets trickier if you want to do LAG or other trunking. Layer 3 features are a bit wild-west. Mixing multiple features into a complex config will be a tear your hair out experience (VLAN with LAG and layer 3 routing all mixed together).


Sent from my SM-G925V using Tapatalk
 
  • Like
Reactions: WeekendWarrior

frogtech

Well-Known Member
Jan 4, 2016
1,422
237
63
34
Well I couldn't even get LAG/LACP to work. I could get things put into LAG groups but Windows Server wouldn't pick up LACP at the switch level, so I just skipped that.
 

sthsep

Member
Mar 7, 2016
72
10
8
I also dont get LACP working. I can't even create the lacp group on the switch. Frogtech which commands did you use and how have you created a lacp port-group?
@dave my LB6M takes here in EU (230V) idle arround 100 Watts. With 7 ports active and normal traffic its about 30-40 Watt more.
 

Sorin

New Member
Apr 29, 2016
10
20
3
40
if anywone is looking for the root user password: "lvl7dbg" (without the quotes), which is also the "drop to shell" diagnostics password

From what I can see it might only work via telnet (not ssh). so I think you would need telnet enabled for this to work.

Extra 1: LB6M seems to share the same CPU board as LB4M (at least in the firmware that's what's written) LVL7 DNI8541 CPU Card ( or LVL7 LB4M CPU Card in later versions)
Extra 2: web interface files seem to be in the firmware. just need to know how to start the web app
(maybe "ip http server 80", "ip http java", "ip http session maxsessions <int>", "ip http authentication local" )
Extra 3: seems the switch can do some BGP ( at lease it is compiled in the firmware ), but it seems that it's an option ( FASTPATH BGP-4 ), more options:FASTPATH QOS,FASTPATH Multicast,FASTPATH IPv6,FASTPATH IPv6 Management,FASTPATH Wireless,FASTPATH Stacking,FASTPATH Metro
so maybe Stacking can be also done. will need my switch to find out how

In 2 weeks I'll get my lb6m and think will have more by than
 
Last edited:
  • Like
Reactions: Fritz

sthsep

Member
Mar 7, 2016
72
10
8
upload_2016-5-4_15-48-2.png

@Sorin ip http is not available on the lb6m (left). Left (lb4m) have this option. Both have latest routing firmware here available.
 

Sorin

New Member
Apr 29, 2016
10
20
3
40
@sthsep
license advanced <key>
where key is the license key. We would need to crack that. that's what you need to get them working. or just patch the 'switchdrvr' executable to think you have all the options
 

Sorin

New Member
Apr 29, 2016
10
20
3
40
In order to access the actual linux and play with the switch, boot the switch in debug mode (option 2 at boot options) and you will be presented with the following options:
Code:
FASTPATH Startup -- Utility Menu

1  - Start FASTPATH Application
2  - Load Code Update Package
3  - Load Configuration
4  - Select Serial Speed
5  - Retrieve Error Log
6  - Erase Current Configuration
7  - Erase Permanent Storage
8  - Select Boot Method
9  - Activate Backup Image
10  - Start Diagnostic Application
11  - Run Manufacturing Diagnostics
12  - Delete Manufacturing Diagnostics
13  - Reboot
choose D or d ( I know it's not on the menu ).

Now you can enable the linux telnet daemon ( 1 - Enable/Disable Telnet daemon ). If at any step you are presented with a password just enter the "lvl7dbg" password. The default telnet port is 2323 and I suggest you keep it.

You can now reboot the switch. It should boot into normal operation but you should be able to telnet on port 2323 and use root/lvl7dbg
 
Last edited:
  • Like
Reactions: epers and TheBloke

aalexson

New Member
May 7, 2016
2
0
1
49
Great thread. I have my LB6M up and running with a Mikrotik router. VLANs so I can separate different networks for my VMWare hosts.

Quick question as I am unable to find it in a manual or this thread, how do I upgrade the firmware from 1.2.0.14 to 1.2.0.18. I have the 1.2.0.18.bin file. I have pushed my config to my TFTP server. I'm just not quite sure how to grab a bin and apply it. Also, I have seen comments about u-boot.bin, do I require installing both or simply 1.2.0.18?

Thanks!
 

redwing31

New Member
Feb 12, 2016
16
0
1
38
Great thread. I have my LB6M up and running with a Mikrotik router. VLANs so I can separate different networks for my VMWare hosts.

Quick question as I am unable to find it in a manual or this thread, how do I upgrade the firmware from 1.2.0.14 to 1.2.0.18. I have the 1.2.0.18.bin file. I have pushed my config to my TFTP server. I'm just not quite sure how to grab a bin and apply it. Also, I have seen comments about u-boot.bin, do I require installing both or simply 1.2.0.18?

Thanks!
Check here: Quanta LB4M 48-Port Gigabit Switch Discussion

post 338 ish should get you going, I believe that is the same thing I did when I upgraded mine (also I am using mine to a CCR1036, UBNT EdgeSwitch, both with LAG & VLANs, great little setup. Also picked up a dual SFP+ PCIe card for the home server.
 

aalexson

New Member
May 7, 2016
2
0
1
49
redwing31, perfect! Thank you very much!

Quanta LB6M Firmeware upgrade process (image on TFTP server, switch has static IP address with working configuration):
show bootvar {to confirm the firmware you have)
I copied my most recent working version from active to backup
copy active backup
Transfer to image from TFTP server to backup
copy tftp://[IP address of TFTP server]/[file name]
confirm images are where they should be:
show bootvar
Boot system up with new firmware:
boot system backup
restart switch:
reload
Switch will go off line for roughly 100 seconds. After boot, confirm you booted the correct image:
show bootvar ("show run" also shows the firmware at the top of the confiration)
 

Drewy

Active Member
Apr 23, 2016
200
53
28
52
Does anyone know of differences between the 1.2.0.14 & 1.2.0.18 firmware versions?
 

redwing31

New Member
Feb 12, 2016
16
0
1
38
Does anyone know of differences between the 1.2.0.14 & 1.2.0.18 firmware versions?
0.0.0.04 :). I have seen no difference, I believe 1.2.0.18 is simply the last firmware release before the hardware became EOL. Probably just some obscure bugfix of a feature 99% of us will never use. Pure speculation.
 

Toby

New Member
May 6, 2016
17
4
3
47
Got my switch earlier this week. So far I'm really enjoying it. Got LAG/LACP setup with 4 1GB connections to my Extreme Networks switch (don't laugh - it's not a bad switch!)
Got my IPv4 VLAN's all setup with routing, the only thing I haven't moved to it from my Extreme switch is IPv6. - Edit: Just realized this thing doesn't have the IPv6 routing module it appears, as there are no commands for setting IPv6 addresses, routing, etc. Darn!

I'm looking for some good (and cheap) SFP+ Fiber adapters. Has anyone tried these, from Solarflare?
NEW! Solarflare SFM10G-SR 10Gb SFP+ Optical Transceiver - IBM 90Y7324

Those are about the cheapest I can find on eBay.

Right now I'm just using some Cisco 3M DAC cables and they work, but I would prefer fiber and need fiber for some longer distances.
 
Last edited:

thisisnotdave

New Member
May 9, 2016
5
0
1
38
Got my switch earlier this week. So far I'm really enjoying it. Got LAG/LACP setup with 4 1GB connections to my Extreme Networks switch (don't laugh - it's not a bad switch!)
Got my IPv4 VLAN's all setup with routing, the only thing I haven't moved to it from my Extreme switch is IPv6. - Edit: Just realized this thing doesn't have the IPv6 routing module it appears, as there are no commands for setting IPv6 addresses, routing, etc. Darn!

I'm looking for some good (and cheap) SFP+ Fiber adapters. Has anyone tried these, from Solarflare?
NEW! Solarflare SFM10G-SR 10Gb SFP+ Optical Transceiver - IBM 90Y7324

Those are about the cheapest I can find on eBay.

Right now I'm just using some Cisco 3M DAC cables and they work, but I would prefer fiber and need fiber for some longer distances.
Can you go over the steps you took to get LACP working?
 

Toby

New Member
May 6, 2016
17
4
3
47
Can you go over the steps you took to get LACP working?
On my LB6M I did this:
Code:
interface 0/25
addport 1/1
exit
interface 0/26
addport 1/1
exit
interface 0/27
addport 1/1
exit
interface 0/28
addport 1/1
exit
interface 0/25
description 'LAG to Extreme Switch'
exit
interface 0/26
description 'LAG to Extreme Switch'
exit
interface 0/27
description 'LAG to Extreme Switch'
exit
interface 0/28
description 'LAG to Extreme Switch'
exit
interface 1/1
description 'LAG to Extreme Switch'
no port-channel static
vlan acceptframe vlanonly
vlan participation include 50,150,198-200,255,400,500,600
vlan tagging 50,150,198-200,255,400,500,600
exit
The "key" here was the "no port-channel static". Without that it's a LAG but doesn't do LACP.

On my Extreme Networks switch, I just ran this:
Code:
enable sharing 1:41 grouping 1:41-44 algorithm address-based L2 lacp
I also had to add port 1:41 to every VLAN.

On my LB6M it looks like this:
Code:
(LB6M 10GB) #show port-channel 1/1


Local Interface................................ 1/1
Channel Name................................... ch1
Link State..................................... Up
Admin Mode..................................... Enabled
Type........................................... Dynamic
Port-channel Min-links......................... 1
Load Balance Option............................ 3
(Src/Dest MAC, VLAN, EType, incoming port)

Mbr    Device/       Port      Port
Ports  Timeout       Speed     Active
------ ------------- --------- -------
0/25   actor/long    Auto      True
       partner/long
0/26   actor/long    Auto      True
       partner/long
0/27   actor/long    Auto      True
       partner/long
0/28   actor/long    Auto      True
       partner/long
Note the "Type... Dynamic"


On my Extreme Networks switch, it looks like this:
Code:
Slot-1 Stack.9 # show lacp lag 1:41

Lag   Actor    Actor  Partner           Partner  Partner Agg   Actor
      Sys-Pri  Key    MAC               Sys-Pri  Key     Count MAC
--------------------------------------------------------------------------------
1:41        0  0x0411 e8:9a:8f:92:13:79   32768  0x001e      4 02:04:96:37:3e:56

Port list:

Member     Port      Rx           Sel          Mux            Actor     Partner
Port       Priority  State        Logic        State          Flags     Port
--------------------------------------------------------------------------------
1:41       0         Current      Selected     Collect-Dist   A-GSCD--  25
1:42       0         Current      Selected     Collect-Dist   A-GSCD--  26
1:43       0         Current      Selected     Collect-Dist   A-GSCD--  27
1:44       0         Current      Selected     Collect-Dist   A-GSCD--  28
================================================================================
Actor Flags: A-Activity, T-Timeout, G-Aggregation, S-Synchronization
             C-Collecting, D-Distributing, F-Defaulted, E-Expired

I also had it all working as a static LAG, just change the LB6M back to static and on the Extreme just take off the 'lacp' part.
 
  • Like
Reactions: YueLuo and tjk

Toby

New Member
May 6, 2016
17
4
3
47
It also looks like this switch somewhat works with Cisco CDP. It gives me the port it's plugged into, that's the main thing I always like to have.

LB6M CDP.PNG