LSI Megaraid 9260-4i - card disappears when computer sleeps

Discussion in 'RAID Controllers and Host Bus Adapters' started by haydentech, Nov 6, 2019.

  1. haydentech

    haydentech New Member

    Joined:
    Nov 6, 2019
    Messages:
    2
    Likes Received:
    1
    I've been using the 9260-4i happily in a Windows 7 Dell Precision box for about a year. I just upgraded to Windows 10 on a nearly identical Dell Precision, moved the card and drives over, and everything appeared to work fine at first glance. However, when the machine goes to sleep, the card and the drives silently disappear from Device Manager. Scanning for new devices in Device Manager does not find them. The only solution to get the drives back is a reboot.

    What I've tried:
    Tried 5 different BIOS's on the Dell Precision 3620 that it's in
    Updating the BIOS to the latest available for the 9260-4i
    Updating the drivers to the latest available for the 9260-41
    Motherboard replacement in the Precision 3620
    Tried sleep with no drives physically connected to the card (the card still disappears)

    This card has Windows 10 64-bit drivers, so I assumed it's qualified to run on Win 10/64. So what's going on here, and how can I fix it?

    If this card is known to be not compatible with sleep on Windows 10, can anyone recommend a compatible, newer RAID card that is?
     
    #1
    Last edited: Nov 6, 2019
    Sleyk likes this.
  2. Sleyk

    Sleyk Active Member

    Joined:
    Mar 25, 2016
    Messages:
    790
    Likes Received:
    218
    Welcome to STH my friend! Glad to have you.

    Question for ya, must you use a raid card? What are ya doing with the drives? Win 10 has software raid that works just a well.

    What Im trying to get at is better to use a HBA without raid capability. You can use a 9212-4i or something like that if you only need 4 ports. There are many hba's to choose from though.

    However, to answer your question my brother, I'm thinking for your case, there is some sort of incompatibility between your system as it is, and the drivers for the card.

    Im thinking a fresh install of Windows 10 might be in order.

    But, but... if you cant do that, you can try to clear out ALL the lsi drivers from your system and reinstall them. Right where you go to update the drivers in device management, you can delete the drivers for the card, then reboot the system, then reinstall the latest drivers.

    This could help. Let us know how it works out!

    Oh also, first like for you :cool:
     
    #2
    haydentech likes this.
  3. haydentech

    haydentech New Member

    Joined:
    Nov 6, 2019
    Messages:
    2
    Likes Received:
    1
    Thanks for suggestions! I moved from Intel software RAID to this card because it offered almost 50% speed improvement. That said, I think I am going to dump the RAID card for now. I've tried a full clear and reload of the drivers, which did not change the behavior. And this machine *was* a fresh install, so I don't see a use in doing it all over again. My plan now is to simply buy a much larger NVMe drive to house what used to be on the RAID, which will definitely solve my speed issue -- those suckers as unbelievably fast. My old RAID drives will become non-RAID'ed backup.
     
    #3
Similar Threads: Megaraid 9260-4i
Forum Title Date
RAID Controllers and Host Bus Adapters Avago LSI MegaRaid 9260-8i cannot import foreign config Nov 11, 2019
RAID Controllers and Host Bus Adapters Avago MegaRaid 9361-16i recognized but stops working Nov 1, 2019
RAID Controllers and Host Bus Adapters Help - LSI MegaRAID 2208 in Supermicro 2027TR-H72RF Oct 21, 2019
RAID Controllers and Host Bus Adapters "Safe ID decryption failed" MegaRAID 9280-8e Dec 2, 2018
RAID Controllers and Host Bus Adapters MEGARAID SAS 9271-4I with cachevault Oct 26, 2018

Share This Page