[Solved] IPMI of Supermicro A1SAM-2750F unreachable

Discussion in 'Processors and Motherboards' started by Kristian, Aug 4, 2015.

  1. Kristian

    Kristian Active Member

    Joined:
    Jun 1, 2013
    Messages:
    344
    Likes Received:
    82
    I received Supermicro A1SAM-2750F (Avoton SOC) yesterday for a build I am doing.

    I spend nearly 3 hours trying to bring up the IPMI Interface. No luck.

    The BMC/IPMI Heartbeat LED is blinking green (So the board thinks status is normal)
    The link LED of the dedicated IPMI Network Port is constantly lit amber (as I would expect).
    The activity LED is blinking amber occasionally (as I would expect without substantial) traffic.

    BIOS output:
    IPMI Firmware Revision is 1.88
    Status of BMC is "working"

    But the IPMI interface wont get a IP assigned by the DHCP.

    In addition to that it does not seem to be possible to set a static IP.
    The BIOS accepts the input and continues, but I wasn't even able to ping the interface.

    Can anybody help?
    Would this be the expected behaviour if the previous owner had configured the "IP Access control" feature?
    Looking forward to your suggestions.
     
    #1
  2. RTM

    RTM Active Member

    Joined:
    Jan 26, 2014
    Messages:
    444
    Likes Received:
    143
    I suggest looking into resetting the IPMI, I believe you can do it from the CLI using some tool (forgot which though).
     
    #2
    Kristian likes this.
  3. EffrafaxOfWug

    EffrafaxOfWug Radioactive Member

    Joined:
    Feb 12, 2015
    Messages:
    1,097
    Likes Received:
    364
    Have you tried using different NICs on the back? On my ASRock boards at least it was a toss-up which interface the BMC started listening on thanks to different defaults for the BIOS or BMC, drove me bonkers; would have hoped SuperMicro would have had saner defaults but you never know...
     
    #3
    Kristian likes this.
  4. Kristian

    Kristian Active Member

    Joined:
    Jun 1, 2013
    Messages:
    344
    Likes Received:
    82
    I think I found the correct tool:

    Integrated IPMI Firewall of Supermicro Motherboards - Thomas-Krenn-Wiki
    Factory reset via ipmitool or ipmicfg:
    <code>ipmitool raw 0x3c 0x40 or
    ipmicfg -fd

    lets see how that works out tonight

    Good suggestion, but as I understood the manual it is a dedicated IPMI Port.
     
    #4
  5. RTM

    RTM Active Member

    Joined:
    Jan 26, 2014
    Messages:
    444
    Likes Received:
    143
    Some Supermicro boards are in their default configuration, configured to "piggyback" on a secondary NIC if the IPMI port is not connected, this is something that can be configured in the webinterface.

    I suppose it is possible, although i reckon it is fairly unlikely, that the IPMI is configured to only use a secondary NIC. All the more reason to reset the IPMI and be done with whatever weird configuration it has.
     
    #5
    Kristian likes this.
  6. EffrafaxOfWug

    EffrafaxOfWug Radioactive Member

    Joined:
    Feb 12, 2015
    Messages:
    1,097
    Likes Received:
    364
    I've seen it where even though the IPMI was configured to use either the dedicated or the onboard NIC(s) that it took a full power cycle for it to detect the change and thus was listening on the wrong interface. Reckon it's worth a stab at any rate if resetting the IPMI config doesn't work.
     
    #6
    Kristian likes this.
  7. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,627
    Likes Received:
    4,584
    I would do exactly as outlined above:
    1. Ensure the dedicated gigabit NIC is indeed dedicated and dedicated to IPMI
    2. Use ipmitool in linux to set the IP address or reset
     
    #7
    Kristian likes this.
  8. Chuckleb

    Chuckleb Moderator

    Joined:
    Mar 5, 2013
    Messages:
    1,017
    Likes Received:
    330
    Also make sure the cable is plugged in before you plug in the power. We have had instances where that seemed to help. It initializes the IPMI on first boot.
     
    #8
    T_Minus and Kristian like this.
  9. Kristian

    Kristian Active Member

    Joined:
    Jun 1, 2013
    Messages:
    344
    Likes Received:
    82
    Solved!

    1.) Downloaded ipmicfg from supermicros site
    2.) tried a factory reset via ipmicfg. Reset was done - no change -
    3.) tried factory reset via firmware update with option -r no (no preserve, reset to factory default) - no change -
    4.) out of a mood tried ipmicfg -vlan off

    Problem solved!
     
    #9
    T_Minus and Patrick like this.
Similar Threads: [Solved] IPMI
Forum Title Date
Processors and Motherboards [solved] Supermicro X9SRi-F does not boot, but has IPMI May 12, 2018
Processors and Motherboards [SOLVED] Wonky IPMI on SM X9SCM-iiF Feb 6, 2017
Processors and Motherboards [SOLVED] How to read PPIN directly (linux) Jul 9, 2019
Processors and Motherboards [SOLVED] AXP-200 and narrow ILM Jun 21, 2019
Processors and Motherboards [Solved] Does the AMD EPYC 3000 Support Non-ECC UDIMM DDR4? Feb 22, 2019

Share This Page