Quanta LB4M 48-Port Gigabit Switch Discussion

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Beenie069

New Member
Dec 20, 2015
2
0
1
41
Was anyone able to get the updated flash or image for the LB4M? I been looking all over the internet and I'm unable to find it anywhere. I have read the previous posts and it seems that it was a complete failure trying to contact the vendors. So does anyone have the routing version, since my system only shows up as switching, and I'm just trying to ip VLANs and I have been unsuccessful so far.

-Ham
 

Beenie069

New Member
Dec 20, 2015
2
0
1
41
How about I pay you just for the image, and you can still try to sell the LB4M to someone else who needs it and you end up making a profit. I already have the device, If I didn't I would have purchased it. It just doesn't make sense for me to have 2 48 port devices in my house with only 8 rooms. Even the 48 ports is too much to have but it was at a good price, and I wanted to learn some switching and routing stuff, but this only does switching and not what I need it for. Let me know my email is beenie069@hotmail.com.
 

microram

New Member
Dec 21, 2015
5
1
3
124
...if you CAN access the CLI and you need a base IP address to get the web gui working the commands to set a STATIC IP is:

network protocol none
network parms 192.168.1.XXX 255.255.255.0 192.168.1.1
write memory
network javamode

This seems to enable http access to the web gui on 1.0.2.12 - 1.0.2.17 firmwares. I don't believe there is a web gui on the newer 1.1.0.8 firmware as others have said. Once in the gui you will see both Web Mode and Java Mode enabled. I disable java mode as it is only used for the top banner showing port status. I would love to have the 5.13.12.14 firmware if possible.
 

Attachments

Last edited:
  • Like
Reactions: rEd2k

aj84

Member
Oct 28, 2015
60
27
18
Germany
Was anyone able to get the updated flash or image for the LB4M? I been looking all over the internet and I'm unable to find it anywhere.
I searched around, too. Found a few different versions and tried all of them:
v1.0.2.14 / VxWorks5.5.1 - switching, WebUI - Operational Code Date: Tue Oct 20 14:03:02 2009
v1.0.2.16 / VxWorks5.5.1 - switching, WebUI - Operational Code Date: Fri Jan 29 14:55:13 2010
v1.0.2.17 / VxWorks5.5.1 - switching, WebUI - Operational Code Date: Wed Jul 28 20:44:43 2010
v1.1.0.8 / VxWorks 6.6 - switching, NO WebUI - Operational Code Date: Mon Sep 3 19:00:46 2012
v1.1.1.8 / VxWorks 6.6 - switching, NO WebUI - Operational Code Date: Mon Sep 3 19:01:44 2012
v5.13.12.14 / VxWorks5.5.1 - routing, WebUI - Operational Code Date: Wed May 13 12:16:52 2009

For me it looks like the newest versions (VxWorks 6.6) don't have a WebUI...and the routing firmware is the oldest one. Did I miss any image/are there others out?

So does anyone have the routing version, since my system only shows up as switching, and I'm just trying to ip VLANs and I have been unsuccessful so far.
Yes, I got it. But I did not yet use any of the routing functions...
(Sorry - should have posted earlier...would share the image, but now I won't steal Fritz's show as he already ordered one of the routing LB4M... ;))
 
  • Like
Reactions: BackupProphet

aj84

Member
Oct 28, 2015
60
27
18
Germany
Lets see what Fritz says...if he wants to cancel his order I'm happy to share the image. Otherwise he could check if we got different routing images; SHA1 of my image: e35f28f7a9ff6df0509ff78e488051a54278d37c
 

Fritz

Well-Known Member
Apr 6, 2015
3,419
1,435
113
70
It's already shipped so too late to cancel the order. But I don't mind a bit if you share. I could then go ahead and update the two I have and get them ready for eBay. :)
 

aj84

Member
Oct 28, 2015
60
27
18
Germany
On CLI (SSH/Telnet/SerialConsole) "show bootvar" (not sure if "enable" beforehand is needed to enter privilege mode)
 

aj84

Member
Oct 28, 2015
60
27
18
Germany
If you've got a serial cable (Cisco-like RJ45 Connector) and you only flash one image slot at one time: I don't think you can really brick it in any way. (My assumption after some flashing-fun: Bootloader never gets flashed/changed by an image-flash procedure -> thats the most important part. -> In case an image-flash procedure gets interrupted/fails there is still another image-slot which can be activated easily using SerialConsole + BootMenu of the Bootloader.)
 

rEd2k

New Member
Oct 16, 2015
22
5
3
46
Thank you aj84, I will try to update the firmware. But first I need to dig up all the flashing details spread around in several threads and posts on this forum. I don't want to brick it.
Hi there, I posted earlier about how to do it in the webui and it DOES WORK as I have tested it myself with the routing firmware :) FINALLY that routing firmware is available! I have been looking everywhere for it! Anyways here's a copy and paste from my earlier post on how to do it through http access:

I use the web ui to do this and it always works for me :) Under the "Navigation" panel on the left side in the gui you will see a folder called "system" click/expand that then look for "System Utilities" and click/expand that. You will then see "HTTP File Download" and click on that option. You will then see on the right hand pane the various options and you wanna make sure "File Type" is "Code" and "Image File Name" is either "Image1" or Image2" <-depending on which image slot you want to upload the firmware file to.

Then obviously click on the "Browse" button beside the "Select File" line and find the firmware you want to upload to the switch from your hard drive. After you select it click on the "Start File Transfer" Button and it will start to upload the firmware to your selected slot WITHOUT ANY INDICATION THAT ITS DOING SO EXCEPT FOR A POP UP WINDOW WARNING YOU NOT TO INTERRUPT THE PROCESS. You can close that pop up but LEAVE THE BROWSER WINDOW OPEN AND RUNNING AND DON'T TOUCH IT!! All you will see is the little loading circle (Firefox & IE anyways) and it will keep going for a long time, when it finally stops it means that the firmware has finished uploading. You can verify this by navigating to "Dual Image Status" under the original "System" folder you expanded earlier and you will see the firmware versions for both slots in there.

I have firefox for my web browser and my little "circle for loading" I mentioned is located on the top left of the tab that's currently open when using the web ui.

Sorry its so long, I was trying to support another user :p Hope that helps!
 

Fritz

Well-Known Member
Apr 6, 2015
3,419
1,435
113
70
So I flashed the routing image and now it's dead. :(

First question is, when you flash the image do the settings come along with the image or do they all revert to defaults?

Second question is, is there a utility available that does out of band IP scanning?

Third question is, how do I get into the switch to attempt to sort this out?

Thanks

Also, all the ports are off.