Quanta LB4M 48-Port Gigabit Switch Discussion

Mattia

New Member
Nov 7, 2019
1
0
1
Hi guys,
i need your help here. I need to setup this switch for a friend of mine in this particular scenario :
Firewall with 2 LAN (LAN1 192.168.10.x 255.255.255.0 and LAN2 192.168.20.x 255.255.255.0) and DHCP is enable on both LAN.
The 2 LAN are separated and devices in LAN 1 cannot see devices in LAN2 and vice versa.

I "just" need, if possible, to dedicate port switch from 1 to 24 for the LAN1 and from port 25 to 48 for the LAN2.
I think this switch can do more than that but i just need this so i don't have to use 2 switches.
Is this possible? and if yes could someone please tell me how ? I'm starting from a fresh setup using consolle cable to setup the switch.

Thanks
Mattia
 

Kirill Harkin

New Member
Mar 25, 2018
9
1
3
Hi guys,
i need your help here. I need to setup this switch for a friend of mine in this particular scenario :
Firewall with 2 LAN (LAN1 192.168.10.x 255.255.255.0 and LAN2 192.168.20.x 255.255.255.0) and DHCP is enable on both LAN.
The 2 LAN are separated and devices in LAN 1 cannot see devices in LAN2 and vice versa.

I "just" need, if possible, to dedicate port switch from 1 to 24 for the LAN1 and from port 25 to 48 for the LAN2.
I think this switch can do more than that but i just need this so i don't have to use 2 switches.
Is this possible? and if yes could someone please tell me how ? I'm starting from a fresh setup using consolle cable to setup the switch.

Thanks
Mattia

So... You want this Quanta to be a router? Or do you have a firewall and just need to seperate the VLANs?

First of all, for routing functionality you'll need routing firmware (5.13.12.14).
Also, in your scenario there's no uplink to internet...
I have my LB4M set up as a switch, so you'll have to refer to the manual for DHCP configuration. But the rest should be something like this:

vlan database
vlan 10,20
vlan name 10 "LAN1_192.168.10.0_24"
vlan name 20 "LAN2_192.168.20.0_24"
exit
configure
ip access-list LAN1-ISOLATE
permit ip 192.168.10.0 0.0.0.255 192.168.10.1 0.0.0.0
deny ip any any
exit
ip access-list LAN2-ISOLATE
permit ip 192.168.20.0 0.0.0.255 192.168.20.1 0.0.0.0
deny ip any any
exit
interface 0/1-0/48
storm-control broadcast level 0.5
storm-control multicast level 0.5
load-interval 30
spanning-tree bpdufilter
mtu 9216
no shutdown
exit
interface 0/1-0/24
description "LAN1_192.168.10.0_24"
vlan pvid 10
vlan participation include 10
exit
interface 0/25-0/48
description "LAN2_192.168.20.0_24"
vlan pvid 20
vlan participation include 20
exit
interface vlan 10
ip address 192.168.10.1 255.255.255.0
ip access-group LAN1-ISOLATE in
no shutdown
exit
interface vlan 20
ip address 192.168.20.1 255.255.255.0
ip access-group LAN2-ISOLATE in
no shutdown
exit
ip dhcp pool "LAN1"
lease 0 4 0
dns-server 1.1.1.1
default-router 192.168.10.1
network 192.168.10.0 255.255.255.0
domain-name 1.local.net
exit
ip dhcp pool "LAN2"
lease 0 4 0
dns-server 1.1.1.1
default-router 192.168.20.1
network 192.168.20.0 255.255.255.0
domain-name 2.local.net
exit
service dhcp
exit

Manual can be found here: https://acm.cs.uic.edu/wiki/_media/lb4m.pdf
Firmware can be found here: Index of /~jared/lb4m

Good luck!
 
  • Like
Reactions: Fritz

NYCone

Member
Jun 23, 2017
36
8
8
60
I have an issue on my LB4M. I'm trying to set up VLANs for my Unifi APs to give each SSID a different VLAN. I warn you, I'm new to vlans, so assume nothing.

My network configuration is: ESXi server (via 2x mellanox cards to 10GB dac cables) to LB4M on a port-channel with ports 0/49 and 0/50 (to form 3/1). My ESXi is running ClearOS and serving data via the vmx0 10gb virtual port.

My issue is I've configured vlans 10,20,30,40 on the ClearOS server and set up port 3/1 on the Quanta with tagging vlans 10,20,30,40. I have tagging out to the ports with the unifi APs, and the APs set with tagging each SSID. The issue is, I can't get anything to work, not even a little.

It's possible I've done this completely wrong, or it's possible I'm one step away from a sound set up. I'd be happy for advice.
 

spyrule

Active Member
I have an issue on my LB4M. I'm trying to set up VLANs for my Unifi APs to give each SSID a different VLAN. I warn you, I'm new to vlans, so assume nothing.

My network configuration is: ESXi server (via 2x mellanox cards to 10GB dac cables) to LB4M on a port-channel with ports 0/49 and 0/50 (to form 3/1). My ESXi is running ClearOS and serving data via the vmx0 10gb virtual port.

My issue is I've configured vlans 10,20,30,40 on the ClearOS server and set up port 3/1 on the Quanta with tagging vlans 10,20,30,40. I have tagging out to the ports with the unifi APs, and the APs set with tagging each SSID. The issue is, I can't get anything to work, not even a little.

It's possible I've done this completely wrong, or it's possible I'm one step away from a sound set up. I'd be happy for advice.

My first thought is, how is your esxi vlan setup configured?
 
  • Like
Reactions: itronin

NYCone

Member
Jun 23, 2017
36
8
8
60
My first thought is, how is your esxi vlan setup configured?
Wow. Yes, I have nothing for ESXi. Can you point me to setting up a trunk on ESXi? I've googled and am having trouble finding something that fits. I'm on ESXi 6.0 if that matters.

EDIT:

I set the ESXi trunk and all is well. Thanks
 
Last edited:

Takrbark3

New Member
Dec 17, 2017
26
0
1
41
Hi!

After 3years of service - today suddenly the LB4M stopped processing the VLANS - you cannot connect to another switch using TRUNK link - the only working thing is using only one vlan on the ports ~ access ports - nothing more. The first sympthon was loosing the "mgmt_vlan" address - cannot ping or access via ssh.

Does anybody seen this?
 

quanta

New Member
Feb 22, 2022
1
0
1
Hi,

Does anyone know how can I configure LB4M to not ask password when I type "enable"?

Thanks
 

Antoine

New Member
Oct 25, 2014
3
3
3
27
I bought this LB4M and it was working fine until few days ago. I was trying some of the features such as vlan or port channel, and uppon a casual reboot, I locked myself out of the switch.. The switch isn't pulling any DHCP address from the server (which is working 100% fine) and I can't connect to console port via a (USB to Serial -> Serial Cable -> Serial to RJ45 Adapter with the pin layout modified for NULL-Modem at rate 11520, 8bit, parity none, flow control none (as written in the manual). Any idea what I should try next? I even removed the "cmos"(?) battery on the mainboard and it changed nothing.

Here's the pin layout if anyone here is familiar with theses kind of adapter :


I'm more used to cisco 2960 where if you lock yourself out, you bush the button and it's reset to default. How about theses? Any way to hard-reset without telnet/console?.

Even locked out, it is working as an unmanaged switch for the moment, but it looks like it is blocking DHCP request (It can't take an IP for itself, and blocking the client from receiving one). However, if the client enters a static IP, it can succesfully connect to the rest of the network.

----

For the interrested, I modified my LB4M for a more "Home Friendly" usage. I removed the loud fan at the back and added two 120mm slim fan. Here's the picture! PS: I didn't intented to ever rack-mount the switch, so the outside fan didn't really borthered me.





The one in the back of the switch had place to go inside once the 3 small stock fan were removed. This one is pulling air out of the switch as the little one were doing.

The one in the front is entirely outside pulling air in the switch.It couldn't be put inside safely because of the "screws" I used who were too close to the daughter board.

Thank you for any help provided for the hard-reset.!

Edit : What is the default baud rate? Is it 9600 or 115200? They are completely losing me in the manual.

Just a heads up after all theses years, my LB4M is still running strong 24/7 with this mod on the same original PSU that came with it when I got in in 2013-2014 on ebay.
I forgot to answer the post, but I used a null modem cable (looks like a RJ45 plug to Serial. It's a pale blue one if it help but I don't know the specific wiring that it used) and a usb serial adapter to connect to the console

I use IGMP Snooping, Vlans, SFP+ GBIC (Both DAC and Fiber Gbic work). I've not yet seen a Gbic that this switch wont accept and I have 3 pairs of different brands around.

I've also changed the fans of the PSU with some Noctua 40mm version with the ohmibod adapter to make it less noisy. The switch is almost silent, to the point that i'm running it in my open-spaced living room 24/7 without hearing it :)

For thoses who were having issues with the web interface, in case it wasn't found, it was wiped out if you upgrade it passed a certain version of the firmware.

And remember to save the switch before rebooting if you use the web interface, because it's gone if you didn't!
 
  • Like
Reactions: oneplane