Need some help with a 9362-8i (NEC N8103-178)

JLL

New Member
Apr 25, 2020
1
0
1
Hello and please forgive the noobness :)

I have a NEC N8103-178 card (3108 chip) that is giving me some headaches.
I am trying to flash it so I can either get IT or JBOD mode out of it.

My setup:
- asrock x370 itx motherboard
- 3400ge pro cpu
- 32gb ddr4 ecc ram
- integrated graphics
- ADATA SX8200 pro ssd
- 8 HDDs
- esxi 6.7u3 (with megaraid card passthrough)
- truenas 12.0

It initially came with a fairly old firmware (2014 I believe ?) and I have somehow managed to update it either to the latest NEC official firmware (dated 2016) or the Broadcom 9361-8i latest firmware.

However when I enter the config utility with Ctrl+R upon boot, the bios loads up and then sits there, totally frozen. I cannot even ctrl+alt+del to reboot, I need to manually reset the machine (with the initial bios dated 2014 this used to work just fine). Now I don't have the initial firmware so I cannot test it/revert it back.

Also if I set the CSM in the bios to UEFI only, I can access the card from the UEFI bios and fiddle with settings. With the 9361-8i firmware I managed to switch the card to JBOD mode but then during TrueNAS bootup (card passthrough from esxi), I'm seeing scsi command timeouts and resets (see screenshot). Ultimately truenas cannot boot properly.

timeout.png

A bunch of other stuff and details:
- flashing is mostly done with megarec3.exe (freedos) : megarec3.exe -m0flash 0 fw.rom (but I've also managed to successfully flash with storcli.efi)
- sas3flash.efi cannot access the card at all, except when the sbr has been cleared (megarec3.exe -writesbr 0 sbrempty.bin)
- I also cannot use sas3flsh.exe because of the PAL issue thingy
- any kind of flashing I've tried with sas3flash.efi gave me the error: NVDATA image does not match controller device id (0x97 vs 0x91 values being different)
- I have tried the hacked sbr as well without success

In a nutshell:
- the official NEC firmware found here seems to work but entering utility with ctrl+r makes the whole machine freeze
- the latest 9361-8i also seems to work (still freezes upon entering utility with ctrl+r) and I can enable JBOD through the csm UEFI bios but Truenas times out on startup

There's probably a lot of missing details so I apologize for the incomplete summary but feel free to ask should you have questions.
If anyone can provide some hints I'd be very grateful :)


Links and tutorials I've followed to try to make some sense of everything
 
Last edited: