How to make the most of a 1.15Gbps (Gig1) Virgin Media ISP

ChuckMountain

New Member
Nov 6, 2019
26
2
3
As a long time lurker I've often visited this thread in the past. I finally got my act together yesterday and replaced my Asus RT-AX5300 router with a Mikrotik CCR1009-7G-1C-1S+ and 10GBE SFP+ transceiver. After a couple of minor teething issues I successfully got the new router to connect to my Superhub 4 in modem mode using the balance-rr config information supplied here. It's been giving me connections in excess of 1000Mbps reliably since I set it up last night.

So, thanks for posting this (but don't tell my wife! ;) )
Glad you got sorted, and don't worry just added another 10GB switch with more ports ...

Just wondering when the 2.2Gbps trial is going to roll out as I really want a better upload speed :)
 

Blueyonderer

New Member
Oct 13, 2020
7
2
3
Yeah - the upload/download speeds we get are pretty imbalanced. Hyperoptic are installing in our area (symmetric Gbit connection) but they seem to be concentrating on blocks of flats where they can recoup their costs quickly. I registered interest with them a couple of years ago but have heard nothing back.

With regard to the original subject of this thread: after reading more about using link aggregation with a SuperHub 4 elsewhere, I've tweaked my original config to bond the router using four lanes rather than two (ether1..4 in my case) since this is meant to be more reliable and gives more headroom if download speeds do increase in future. I can confirm that this method works well and I'm getting download speeds of 1000Mbps+ at all times of day now, which is great given the current working from home situation. I've still got the superhub running in 'modem' mode so there's no double-NATting, etc.
 
Last edited:
  • Like
Reactions: ChuckMountain

carbon60

New Member
Dec 17, 2018
4
5
3
Glad you got sorted, and don't worry just added another 10GB switch with more ports ...

Just wondering when the 2.2Gbps trial is going to roll out as I really want a better upload speed :)
They're supposed to be going to 100Mbit upload speed on the Gig1 service 'at some point' but who knows when that might be.
 

a5ian300zx

New Member
Aug 26, 2012
18
8
3
My friend just got the Virgin 1gig service and got a Dream Machine Pro which has 10gig WAN port (SFP+) + 1gig WAN RJ45 and 8x1 gig ports he gets 950Mbps on his connection.

Pfsense, untangle it will depend on what you have enabled and the hardware spec eg if you have IDS IPS protection it will affect the performance.
 
Last edited:

Blueyonderer

New Member
Oct 13, 2020
7
2
3
950Mbps is the maximum speed achievable via a single cable to a VM Superhub since its 4 LAN ports are gigabit only. Your friend would need to bond two or more ports (as above) to achieve speeds higher than this, assuming its possible on his Dream Machine. The next iteration of the hub will surely need to have at least one multigig output on it, which would negate the need for this, since VM are actively testing 2.2Gbit downloads in some areas just now and very few will have the hardware/knowledge necessary to take advantage of the extra bandwith.
 
  • Like
Reactions: a5ian300zx

Bradliam1

New Member
Jul 7, 2021
5
3
3
@ChuckMountain Is this still working for anyone? I've got it all set up with balance-rr but it it seems to be balancing upload, download just seems to go through one ethernet port
 

Blueyonderer

New Member
Oct 13, 2020
7
2
3
I'm pretty sure balance-rr is still working OK for me. I'm seeing traffic up and down across all four ports I've bonded. I'll run a speed test later once working from home traffic has died down here.

Edit: still measuring over 1000Mbps here so all good.
 
Last edited:

Bradliam1

New Member
Jul 7, 2021
5
3
3
Not sure what's going on with mine then, I've got a mikrotik rb4011 with 2 bonds in a bridge, balance-rr to the modem and 802.11ad to my Netgear rax120. Pretty much the same setup to @chris6273. The 802.11ad link to the router is splitting traffic equally but the balance-rr is preferring one ethernet link for download, but splitting for upload.
Not sure what's going on, afaik it should be working fine
 

Blueyonderer

New Member
Oct 13, 2020
7
2
3
The ports that chris6237 used to set up the balance-rr trunks seemed to make a difference due to the design of the switch:

"After setting up two "balance-rr" trunks as before (One across ether1 & ether6 and the other across ether2 & ether7) and making a more-or-less identical firewall config to the hEX (Taking the opportunity to clear it up), I performed a speedtest and voila!"

So, it might be worth duplicating this exact setup if yours is different.
 

Bradliam1

New Member
Jul 7, 2021
5
3
3
Figured it out, was a Windows issue causing the slow speed, reset my pc and got 1125mbps down.
For anyone interested, to make this work you don't need to mess around with firewalls or anything, just need to bond the ethernet ports from the modem using balance-rr, and bridge them with the output to your router, be that through the Sfp port or another bonded group like I did. I used 802.3ad bond to my Netgear nighthawk. Just make sure you turn off arp on the bridge and it should all work fine.
 
  • Like
Reactions: Blueyonderer

ragingwhisky

New Member
Jul 15, 2021
4
0
1
This will be a numpty query so forgive, but I've recently just had a Virgin Media install with 1Gig, and to date all my kit has only ever had to deal with 'up to 300mpbs' so facing the perilous situation of forcing myself to do some upgrades.

I'm not a network guru but happy to get stuck in - is there a specific hardware combo and approach that would best enable the nic bonding implementation to enable the 1.2Gbs 'ceiling'?

Never had to delve too deeply into this realm so I'll be wearing the noob hat for the interim.

Interested in the capabilities of the microtik/pfsense routers mentioned in this thread to support the round robin teaming, but am also open to unifi hardware (though unknown if it at present supports this approach?).

Currently using a Netgear RAX120 standalone with a BT Home Hub, so keen to upgrade the interim capabilities to take advantage of the speeds on offer with the VM Hub4.

Any help/direction welcome!
 

Bradliam1

New Member
Jul 7, 2021
5
3
3
@ragingwhisky You have the same setup as me, I got the mikrotik RB4011iGS+RM, almost certain that's the cheapest way to do it, around £160 on amazon. Just set it up like I have and it will work, I cant get more than 600mbps over Wi-Fi with that router so you will need a pc with a 2.5gbps ethernet port/adapter or higher and connect it the the rax120 5gbit port.
You need to go to the Internet section in the router page and change it to wan aggregation 1gbps+1gbps on the netgear router side.
If you get that mikrotik router, or if you get another you can modify this, connect to the router, reset it with no default configuration and paste this whole config into the console and connect ports 1+2 to the modem and ports 6+7 to the wan and lan 1 on the netgear router. You might need to restart the modem but it should work straight away. Don't use the netgear inbuilt speedtest because it only tests with a gigabit connection.

/interface bridge
add arp=disabled name=MAIN_Bridge protocol-mode=none

/interface bonding
add link-monitoring=none mode=802.3ad name=LAN_Bond slaves=ether6,ether7 \
transmit-hash-policy=layer-2-and-3
add link-monitoring=none name=WAN_Bond slaves=ether1,ether2

/interface bridge port
add bridge=MAIN_Bridge interface=LAN_Bond
add bridge=MAIN_Bridge interface=WAN_Bond
 
Last edited:
  • Like
Reactions: ragingwhisky

ragingwhisky

New Member
Jul 15, 2021
4
0
1
@ragingwhisky You have the same setup as me, I got the mikrotik RB4011iGS+RM, almost certain that's the cheapest way to do it, around £160 on amazon. Just set it up like I have and it will work, I cant get more than 600mbps over Wi-Fi with that router so you will need a pc with a 2.5gbps ethernet port/adapter or higher and connect it the the rax120 5gbit port.
You need to go to the Internet section in the router page and change it to wan aggregation 1gbps+1gbps on the netgear router side.
If you get that mikrotik router, or if you get another you can modify this, connect to the router, reset it with no default configuration and paste this whole config into the console and connect ports 1+2 to the modem and ports 6+7 to the wan and lan 1 on the netgear router. You might need to restart the modem but it should work straight away. Don't use the netgear inbuilt speedtest because it only tests with a gigabit connection.
Thanks for the steer - Amazon quote delivery of the RB4011iGS+RM (and an EU>UK plug adaptor just in case) for tomorrow, so will get that ordered.

May come back with questions :)
 

ragingwhisky

New Member
Jul 15, 2021
4
0
1
@ragingwhisky You have the same setup as me, I got the mikrotik RB4011iGS+RM, almost certain that's the cheapest way to do it, around £160 on amazon. Just set it up like I have and it will work, I cant get more than 600mbps over Wi-Fi with that router so you will need a pc with a 2.5gbps ethernet port/adapter or higher and connect it the the rax120 5gbit port.
You need to go to the Internet section in the router page and change it to wan aggregation 1gbps+1gbps on the netgear router side.
If you get that mikrotik router, or if you get another you can modify this, connect to the router, reset it with no default configuration and paste this whole config into the console and connect ports 1+2 to the modem and ports 6+7 to the wan and lan 1 on the netgear router. You might need to restart the modem but it should work straight away. Don't use the netgear inbuilt speedtest because it only tests with a gigabit connection.
I believe the MikroTik is setup as specified - within Winbox it shows up the WAN and LAN bonding as expected from your console command examples, however oddly enough there appears an issue on the AX120 when attempting to establish the WAN link.

Obviously i've misconfigured something but I can't seem to avoid getting the following error when trying to apply the WAN aggregation 1gbps+1gbps setting " Error: Unable to establish WAN aggregation "

Any immediate thoughts?
 

Bradliam1

New Member
Jul 7, 2021
5
3
3
@ragingwhisky The router should detect it automatically, make sure you've connected port 6 and 7 on the mikrotik to the wan port and Lan port 1 on the Netgear.
Did you make sure to reset with no default config on the mikrotik and paste the whole config in the mikrotik terminal? Might be worth resetting and retrying if you've got everything in the right ports.

Make sure you've connected to these ports
002IGjIrutRy4IVLGFbC5jR-2.fit_lim.size_1050x~2.jpg
 
  • Like
Reactions: ragingwhisky

ragingwhisky

New Member
Jul 15, 2021
4
0
1
Just did that very check - looking at the error on the netgear side, it seems the netgear can be a bit "protective" of you having both ports hooked up whilst attempting to aggregate + gave both it a boot and its come up with the blue text showing success.

Given the virgin hub a boot also and all "seems" to be working - across WiFi (obviously not going to max it out) it's now 814mbps/51mpbs.

Not attempted yet with the server on anything higher than 1Gbps ports though (USB<->network adaptor i've been using seems to max out at 920mbps) on the nighthawks 5G port.

Assuming i've done everything else correctly - think its back and working now.

Thanks for your pointers and help.
 

matchett808

New Member
May 12, 2021
5
0
1
Checking in september 2021 - installed a CRS305 today, followed previous posts here to get it configured and only have traffic flowing down sfp-sfpplus-2 (into VM port 1) - any of the OG folx here able to validate this still works?


Do I maybe need to do a firmware update on the VM side?