How to make the most of a 1.15Gbps (Gig1) Virgin Media ISP

carlpea

New Member
Oct 18, 2021
19
0
1
Hi,
As you're the first post on here I can see with a RB5009 would you kindly share your config with me.

I've gone through a few different setup posted on here and they don't seem to work properly on my RB5009, perhaps because of the different number and internally configured ethernet ports.

My current router has my Synology DS918+ connected link aggregation 802.3ad so I need to set that up on the Mikrotik too.

Any help would be greatly appreciated!

Richard
It may be worth mentioning the actual issue you are having?

Unsure what sequence you plugged cables in, however you must ensure you reboot the HUB if any cable configuration has changed i.e. added an extra ethernet cable.
 

rickyb90

New Member
Dec 11, 2021
9
0
1
So I think I'm almost there, its just not getting an IP allocated from the HUB4 and consequently (or not) no DNS either. Literally no connection to the internet.

I think I've configured the bond correctly with ARP disabled and link monitoring on None.

I've got 4 ethernet cables in the bond if that makes any difference (figured it can't hurt as the MikroTik RB5009 is 3ft away from the HUB4)

I've attached the screen grabs from my configuration as I'm kinda hoping there's something really simple I've missed.....

InterfaceListInt.jpg

WanBondGeneral.jpg

WanBondBonding.jpg

DHCPClient.jpg

DHCPClientAdv.jpg

DHCPServer.jpg

DHCPServerNetworks.jpg

DNS.jpg

FirewallFilterRules.jpg

FirewallNAT.jpg
 

carlpea

New Member
Oct 18, 2021
19
0
1
Only Ether7 is showing as R (Running) so something is amiss.

I had to enable ARP on the WAN_Bond and set a forced static MAC, as well as enable ARP on the salves of the bond.

Has the HUB been rebooted following all four ethernet cables being plugged in?
 

ChuckMountain

New Member
Nov 6, 2019
27
2
3
Yes something is definitely up with the 4 connections.

Your firewall rules are also missing quite a bit including passthrough and fastrack (offload once rule has been established for traffic)

Also have ARP enabled.

On a separate note I have found the Cloudflare DNS and Virgin don't play well together and you end up all sorts of weird unoptimised paths. Netflix used to drop quality for me for example and I found it was getting an IP somewhere in France, rather than the local "VM copy". Same for Spotify so I have gone back to using Google DNS which works better with VM.
 

rickyb90

New Member
Dec 11, 2021
9
0
1
Hi, I probably should have said the posted images were for checking if I had the right configuration setup :p

It was Ether7 I was plugged into just to do the screen grabs and nothing else was connected.

Thanks for the replies I'll change a couple of bits to what's suggested including Google DNS.

Is there guide on here to show how to setup the firewall as I've read up a couple of bits and it's a different language I don't get:D:D
 

rickyb90

New Member
Dec 11, 2021
9
0
1
Ok so I've changed a few settings as suggested and it kind of works. There's internet connectivity on the router and I can use the built in tools to ping external addresses etc but there's no internet connectivity to any LAN connected devices...

I'm sure its simple to fix but I can't see in my settings what's up with it.

Updated.jpg
 

carlpea

New Member
Oct 18, 2021
19
0
1
Ok so I've changed a few settings as suggested and it kind of works. There's internet connectivity on the router and I can use the built in tools to ping external addresses etc but there's no internet connectivity to any LAN connected devices...

I'm sure its simple to fix but I can't see in my settings what's up with it.

View attachment 21501
What's your setup?

Are you using the MikroTik as a passthrough to another router or is it being used as a router?

Are the ethernet ports you are using to gain internet access on the Bridge, as welll as the WAN Bonded ports?

My example below is showing only the WAN Bond and SFP port only as I use my device as a passthrough to an ASUS router.

1644089832600.png
 
Last edited:

Vertigo1

New Member
Nov 13, 2021
5
1
3
I seem to be having an issue whereby the aggregation is 'flaky'.

Sometimes it works fine and I get full speed, other times, during big downloads, I'll see the speed fluctuate between the 'full' 1100+ and about 950Mb, which is too coincidental for me and suggests the aggregation has failed and it's using one port.

This morning I'm getting 950 on all speed tests and downloads (not tried rebooting anything yet).

I know there used to be a bug with the hub4 where the aggregation failed after a while but I thought that had been fixed?
 

carlpea

New Member
Oct 18, 2021
19
0
1
I seem to be having an issue whereby the aggregation is 'flaky'.

Sometimes it works fine and I get full speed, other times, during big downloads, I'll see the speed fluctuate between the 'full' 1100+ and about 950Mb, which is too coincidental for me and suggests the aggregation has failed and it's using one port.

This morning I'm getting 950 on all speed tests and downloads (not tried rebooting anything yet).

I know there used to be a bug with the hub4 where the aggregation failed after a while but I thought that had been fixed?
Like my image above, add column 'Link Downs' to your 'Interface List' and note if the value increases.

Also check for data throughput on all slaves in the bond, as well as checking all slaves show as 'RS' (Running Slave).

There was a bug in the HUB 4 which was fixed in firmware 01.02.065.21.EURO.PC20.

Although the below link seems to suggest it's not stable, I find after a an hour of occasional 'Link Downs' it settles and works fine for months.


EDIT: Ah, it looks like you aren't using MikroTik kit! Look for an alternative column in your setup that can show when links go down, for monitoring purposes.
 
Last edited:

Vertigo1

New Member
Nov 13, 2021
5
1
3
Thanks, yeah I'm using pfSense. Had to reboot everything earlier for another reason and it's back to full strength so I'll keep an eye on it.
 

rickyb90

New Member
Dec 11, 2021
9
0
1
What's your setup?

Are you using the MikroTik as a passthrough to another router or is it being used as a router?

Are the ethernet ports you are using to gain internet access on the Bridge, as welll as the WAN Bonded ports?

My example below is showing only the WAN Bond and SFP port only as I use my device as a passthrough to an ASUS router.

View attachment 21502
Hi,
Yes I'm using the MikroTik as a router and the HUB 4 in modem mode. I thought the HUB 4 needed to be in modem mode to avoid double NAT?
Ideally I want to replace my existing router with the MikroTik and tidy up some of the multiple cable runs I have.

I'm not sure about the WAN bond being on the bridge so I'll check.
 

figarospares

New Member
Nov 13, 2021
6
0
1
Hi I have had this up and running for few months was bonding but speeds was not great I had power outage now it as gone back to 1 connection it is driving me mad. it is bridged to udm pro
# feb/26/2022 18:22:53 by RouterOS 7.1.1
# software id = EADM-A60K
#
# model = RB4011iGS+
# serial number =
/interface bridge
add admin-mac= auto-mac=no comment=defconf name=bridge
add arp=disabled name=vmbridge protocol-mode=none
/interface ethernet
set [ find default-name=ether4 ] auto-negotiation=no
set [ find default-name=ether5 ] auto-negotiation=no loop-protect=off
set [ find default-name=ether6 ] auto-negotiation=no loop-protect=off
set [ find default-name=ether7 ] auto-negotiation=no loop-protect=off
set [ find default-name=sfp-sfpplus1 ] advertise=10000M-full auto-negotiation=\
no
/interface bonding
add arp=disabled link-monitoring=none name=vmbond slaves=\
ether4,ether5,ether6,ether7
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/port
set 0 name=serial0
set 1 name=serial1
/routing bgp template
set default as=65530 disabled=no name=default output.network=bgp-networks
/routing ospf instance
add name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/interface bridge port
add bridge=bridge comment=defconf hw=no ingress-filtering=no interface=ether2
add bridge=bridge comment=defconf hw=no ingress-filtering=no interface=ether3
add bridge=bridge comment=defconf hw=no ingress-filtering=no interface=ether8
add bridge=bridge hw=no ingress-filtering=no interface=ether1
add bridge=vmbridge ingress-filtering=no interface=vmbond
add bridge=vmbridge ingress-filtering=no interface=sfp-sfpplus1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface list member
add comment=defconf interface=bridge list=LAN
/ip dhcp-client
add disabled=yes interface=bridge
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=192.168.88.1 gateway=\
192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=\
invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" \
connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=\
out,none out-interface-list=WAN
/system clock
set time-zone-name=Europe/London
/system resource irq rps
set sfp-sfpplus1 disabled=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 

Vertigo1

New Member
Nov 13, 2021
5
1
3
I gave up on it myself. Found that, whilst it worked fine, it only lasted a short time and, after a few hours the speeds would drop back to around 950Mbps max, obviously only utilising a single link.

More trouble than it's worth for the marginal increased speed. I was only getting 1100Mbps max when it worked anyway which doesn't really make that much difference over 950. Even on a 100GB download, it would save you all of two minutes :)
 

penrhos

New Member
Nov 23, 2020
28
10
3
My Gig1 is due to be installed tomorrow - currently I have the Hub3 running in router mode (but with Wi-Fi, DHCP etc disabled as I couldn't get it stable in Modem mode) this is feeding into a Cisco 2960X and a TP-Link M3 mesh. I have a CRS305 hanging off the 10Gb SFP+ port on the 2960X which services my NAS, BACKUP server and media server at 10Gbe.

The primary TP-Link M3 (plugged into the hub3) is hosting my 2 Wi-Fi zones and manages the DHCP on the network.

So when the Hub4 arrives do I take 2 x cables to the 2960X and then use a third cable to the TP-Link as currently wired up?

I've seen loads of posts stating the hub4 only works with one port if in Modem mode, is this the case, will I have to bodge the Router mode so it's not doing anything? -

How do i setup the ports on the Cisco to do balance-rr? I've only ever used it as a hub with 10Gbe uplinks..



.
 
Last edited:

carlpea

New Member
Oct 18, 2021
19
0
1
My Gig1 is due to be installed tomorrow - currently I have the Hub3 running in router mode (but with Wi-Fi, DHCP etc disabled as I couldn't get it stable in Modem mode) this is feeding into a Cisco 2960X and a TP-Link M3 mesh. I have a CRS305 hanging off the 10Gb SFP+ port on the 2960X which services my NAS, BACKUP server and media server at 10Gbe.

The primary TP-Link M3 (plugged into the hub3) is hosting my 2 Wi-Fi zones and manages the DHCP on the network.

So when the Hub4 arrives do I take 2 x cables to the 2960X and then use a third cable to the TP-Link as currently wired up?

I've seen loads of posts stating the hub4 only works with one port if in Modem mode, is this the case, will I have to bodge the Router mode so it's not doing anything? -

How do i setup the ports on the Cisco to do balance-rr? I've only ever used it as a hub with 10Gbe uplinks..



.
The M3 only has 1Gbps ethernet ports so I assume you have other connections off the Cisco to make use of the additonal bandwidth available?

The HUB 4 does support multiple ports when in modem mode.
 

penrhos

New Member
Nov 23, 2020
28
10
3
Currently port 1 on the hub feeds the tp-link which all my WiFi kit connects to. Port 2 uplinks to the 2960X so all my hard wired kit (homelab & office) connect to the 2906X at 1Gbe. The 10gbe port means I can backup my nas and media centre at 10Gbe (although the disks max out at 550).

With 200M this setup works fine but if hub4 can go at 1100 then I want to squeeze 1100 out of it....

Out of interest as virgin are putting their prices up this month I said I was thinking of leaving as bt are rolling out fttp on our estate and got my package upgraded to 1Gbe for just £5 more than my 200M was due to increase to (but tied in for 18 months).
 

figarospares

New Member
Nov 13, 2021
6
0
1
Ok I have been messing around with this and I have got it working again. What I done was unplugged the link to switch left it 12 hours and plugged it back in to gain access to winbox and it is still using all 4 again been up 24 hours now.
 

penrhos

New Member
Nov 23, 2020
28
10
3
I seem to be having the same issue with the Hub4 as I did with the Hub3 - If I run it in Modem mode the TP-Link M3's have a fit and can't access the internet if the Cisco 2960X is also plugged in. so at the moment I'm running the hub4 in Router mode with WiFi switched off and the TP-Link M3's in Access-point mode instead.

So if I run 2 cables from the hub4 in router mode to the Cisco can I still balance-rr them to get more the 975Mb I'm topping out at with a single connection?