CWWK/Topton/... Nxxx quad NIC router

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

bobbeh

New Member
Nov 7, 2023
2
0
1
I've done some searching but haven't found a conclusive answer, so if anyone with the "Topton 13th gen 10g router" could do a validation check, it would be greatly appreciated.

From the attached image, it shows the PCIex8 slot as "signaling at x4" however from what i understand, the 82599ES is a PCIe2x8 card. Does this mean the card is only getting PCIe2x4 worth of bandwidth, or is there some other magic going on to make it get the full 32 GT/s of bandwidth the PCIe3x4 lanes can provide?

Edit: For added context, i'm concerned that the PCIe2x4 lanes would restrict the 2x sfp+ ports to a combined 16 gigabit.

 

Attachments

Last edited:

moonman

New Member
Aug 12, 2023
21
1
3
I've done some searching but haven't found a conclusive answer, so if anyone with the "Topton 13th gen 10g router" could do a validation check, it would be greatly appreciated.

From the attached image, it shows the PCIex8 slot as "signaling at x4" however from what i understand, the 82599ES is a PCIe2x8 card. Does this mean the card is only getting PCIe2x4 worth of bandwidth, or is there some other magic going on to make it get the full 32 GT/s of bandwidth the PCIe3x4 lanes can provide?

Edit: For added context, i'm concerned that the PCIe2x4 lanes would restrict the 2x sfp+ ports to a combined 16 gigabit.

I believe you are correct. I guess the assumption is that you will never max out 2 ports at the same time, but the assumption doesn't hold well as time goes on. They do the same with single lane PCIe 2nd gen cards with 2x 2.5Gbit/s ports (2 chips). It needs 600MB/s but single lane only provides 500. It would work well for 5Gbit/s but 82599ES doesn't support 5Gbit/s, just 10Gbit/s and Gigabit.
 

bobbeh

New Member
Nov 7, 2023
2
0
1
I believe you are correct. I guess the assumption is that you will never max out 2 ports at the same time, but the assumption doesn't hold well as time goes on. ...
I've done some more reading into the PCIe spec, and think i have a better understanding of it now; so correct me if i'm wrong.

I see that PCIe is full-duplex, so in theory the PCIe2x4 connection would be capable of 16gbit send, AND 16gbit receive simultaneously. Meaning, theoretically you can push 8g through the router in both upload and download (assuming the cpu can keep up) or 10g down and 6g up.

This is sufficient for my small network router use case, as then chances of both uploading and downloading at 10g at the same time are vanishingly small.
 

Cellgalvano

New Member
Nov 7, 2023
6
6
3
I got a N305 V2 with the 4x M.2 expansion board from Topton. After asking how to enable PCIe bifurcation they send me three different BIOS files (named 5M.2+WIFI, 4M.2+SATA, PXE=CSM) and said that one needs to flash a different BIOS depending on the wanted configuration. None of them seems to be flashable on the V2. Has anyone been able to enable the 4x M.2 expansion? I would like to use all 5 M.2 slots.
 

alexw1982

Member
May 20, 2015
56
25
18
42
Germany
does anybody know if the 4x m.2 expansion board can be used in 2x PCIe3 x2 configuration. I hate that my zfs mirror consists of a x4 and a x1 connected ssd ...
 

rinat_sabirov

New Member
Aug 8, 2021
3
1
3
Got it working using this BIOS from CWWK
Hi! I have N100 v2 and using BIOS built around 10th october 2023, and asked for a new BIOS from CWWK because my single SSD didn't work while put solely in slots 2, 3 or 4. While they were making a new BIOS I discovered, that one need to put ssd first in the first slot, otherwise expansion board seems to not get initialized at all. Is this new BIOS from 4th november solves that issue? And how settings look like, would be frateful to see what's new there (the manufacturer don't do any sort of release notes, but considering that it's making new versions at least, while many other chinese manufacturers do not, I'm happy with CWWK:)
 

TvdH

New Member
Jul 17, 2013
18
8
3
The Netherlands
Allegedly there is new N305 V2 production starting next week, probably just BOM optimisation. Shipping of V1 stopped and sgipping of V2 should resume shortly
Are you talking about CWWK? I'm currently looking at their N305 model with the additional nvme expansion card. Not seeing a V2 (yet).
 

therobin

New Member
Aug 9, 2023
3
1
3
I have questions about the fan cable for these motherboards. I am looking for a fan cable for my N100 unit. I only need the mini 4-pin PWM to standard 4-pim PWN cable. Where can I get the cable?

I have my own fans I would like to use and would prefer not having to order a fan from Topton just to get the cable.
 

Cellgalvano

New Member
Nov 7, 2023
6
6
3
Hi! I have N100 v2 and using BIOS built around 10th october 2023, and asked for a new BIOS from CWWK because my single SSD didn't work while put solely in slots 2, 3 or 4. While they were making a new BIOS I discovered, that one need to put ssd first in the first slot, otherwise expansion board seems to not get initialized at all. Is this new BIOS from 4th november solves that issue? And how settings look like, would be frateful to see what's new there (the manufacturer don't do any sort of release notes, but considering that it's making new versions at least, while many other chinese manufacturers do not, I'm happy with CWWK:)
Unfortunately it does not seem to fix it. You need to "load" the slots one after another starting from the first one (the one directly over the 4x M.2 slot).
 

buz

New Member
Nov 5, 2023
20
11
3
So the CWWK store is the best Ali seller (and topton to be avoided), did I infer this correctly?
 

AdamAu

New Member
Oct 15, 2023
15
8
3
So the CWWK store is the best Ali seller (and topton to be avoided), did I infer this correctly?
seems to be the general consensus.
I ordered two units from CWWK in the last month no issues. came with sata & fan cables

some parts you need to order as extra items, such as the M2 to 4x M.2 adapter, just be aware to message the store if you want it.
 

Mercantides

New Member
Nov 8, 2023
1
6
3
I ordered the C version N100 direct from the CWWK store on Nov. 2 and it arrived at my house in Ottawa on Nov. 8; it was so quick that I didn't even have the RAM or SSD picked out! The pictures on the store page are still showing the older version (only 2 USB on the front face) but I received the version with 6 USB on the front face (CW-AL-4L-V2.0 N100). It has 1 DDR5 SODIMM slot and came with a SATA cable, fan cable, screwdriver, and a DAJING ADP-60E2 12V/5A power supply. I bought a Corsair Vengeance 16GB 4800 SODIMM (CMSX16GX5M1A4800C40) and a SOLIDIGM P44 Pro SSD.

So far I've only ran memtest86+ and am now installing Proxmox so I don't have much to report. I did encounter a weird issue where BIOS settings wouldn't save. I could save/load user defaults and the clock was correct so it wasn't a battery issue. I finally gave up and ran memtest86+ to accomplish something. Next time I tried saving the BIOS it worked fine. I still don't know what the issue was. The BIOS version is 2.22.1288 9/27/2023 21:59:27.

The other issue I had is some graphical glitches when connecting via HDMI to my 1440p monitor. The DisplayPort worked fine and the HDMI is fine when connected to a 1080p monitor. It might be the cable and I'm going to be running headless so I'm not concerned about it.

IMG_0958 (Large).JPG

IMG_0959.JPG

IMG_0961 (Large).JPG

_1040192 (Large).JPG
 

splifingate

Member
Oct 7, 2023
41
26
18
I ordered the C version N100 direct from the CWWK store on Nov. 2 and it arrived at my house in Ottawa on Nov. 8; it was so quick that I didn't even have the RAM or SSD picked out! The pictures on the store page are still showing the older version (only 2 USB on the front face) but I received the version with 6 USB on the front face (CW-AL-4L-V2.0 N100). It has 1 DDR5 SODIMM slot and came with a SATA cable, fan cable, screwdriver, and a DAJING ADP-60E2 12V/5A power supply. I bought a Corsair Vengeance 16GB 4800 SODIMM (CMSX16GX5M1A4800C40) and a SOLIDIGM P44 Pro SSD.

So far I've only ran memtest86+ and am now installing Proxmox so I don't have much to report. I did encounter a weird issue where BIOS settings wouldn't save. I could save/load user defaults and the clock was correct so it wasn't a battery issue. I finally gave up and ran memtest86+ to accomplish something. Next time I tried saving the BIOS it worked fine. I still don't know what the issue was. The BIOS version is 2.22.1288 9/27/2023 21:59:27.

The other issue I had is some graphical glitches when connecting via HDMI to my 1440p monitor. The DisplayPort worked fine and the HDMI is fine when connected to a 1080p monitor. It might be the cable and I'm going to be running headless so I'm not concerned about it.

View attachment 32688

View attachment 32689

View attachment 32690

View attachment 32691
Rather miffed (though--ultimately--not really that upset) that I didn't get the SATA data/power cable in my previous shipment :rolleyes:

Blue USB is definitely 3.2 (10Gb) on my 305 v.2 unit.
 

slidermike

Active Member
May 7, 2023
116
45
28
I am fairly certain toptop just resells cwwk appliances. Which is why you can flash the firmware without an issue. Doubt there is a "general concensus" one is better.
I have the 6 port 2.5gbe i5 gen12 topton, 32gb ram with the cwwk unlocked bios. Proxmox, pfsense, openwrt and a couple of lxc's. No issues.
 
  • Like
Reactions: Pinuccio

lued

New Member
Nov 10, 2023
2
1
3
So here's a strange one, my Proxmox crashes HARD after 3 minutes when putting hard IO on 3 NVMes in zfs RAIDZ1 on pve.

This happens every time running fio, a stress test using dd, or zfs send | recv. No dmesg, journalctl, or /var/log/{message,...etc.} signifying what happened to the kernel. Server just hard resets and uptime shows reboot occurred. Connecting a monitor to the . Haven't done that yet.

Specs: https://vi.aliexpress.com/item/1005005397523761.html?gatewayAdapt=glo2vnm

w/ a 4*1xM.2 port daughter board as such: https://vi.aliexpress.com/item/1005...sea!CA!2764160099!&curPageLogUid=sVI0cUNMn9hO

This converts a 4x M.2 to 4 1xM.2.
CPU: Intel N100
RAM: 16GB DDR5
OS: Debian Bookworm (PVE 8)
Kernel: 6.2.16-19-pve

I verified cpu and NVMe are not getting to TJMax / Crit temps and error is not OOR (out of RAM) for ZFS.
  1. Tried rebuilding pool - same issue.
  2. Read through all of https://forums.servethehome.com/ind...xxx-quad-nic-router.39685/page-22#post-383794 which identifies similar issues. No real fixes.
  3. Went through BIOS, flashed to latest version provided by Topton - looks like a lot of low level changes that can be done. I assume there is a M.2 bifurcation issue that needs to be resolved by BIOs.
  4. I haven't tried updating the microcode - but the only thing showing up in journalctl | grep micro is this:
microcode: Microcode Update Driver: v2.2. (edited)

Anyone experienced this issue before?
 
  • Like
Reactions: indiekiduk

karoiz

New Member
Nov 1, 2023
8
3
3
Yesterday I ordered CW-AL-4L from topton. I'm curious, with a bit of luck maybe I'll also get version v2? There was a promotion for only $160.

How about RAM compatibility? Intel documentation indicates that the maximum is 16GB of RAM. On some websites I see that they sell the N100 in a 32GB RAM configuration. How's that going?
 
Last edited: