Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Craig Curtin

Member
Jun 18, 2017
70
14
8
57
Just wanted to say a hearty thank you for all the work that has gone into the documentation from the OP - just followed through step by step on 3 new switches that i received and everything worked perfectly !

Craig
 

kpfleming

Active Member
Dec 28, 2021
227
105
43
Pelham NY USA
In the guide it says "By default, all ports are in VLAN 1" for the ICX 6450 does that include the 4SPF+ ports? I have an "Cable Matters 1000BASE-T Gigabit SFP to RJ45 Copper Ethernet Modular Transceiver" but doesn't work(ve interface 1 IP doesn't ping). Using any of the ethernet ports direct works (Cat 7 Ethernet Cable High-Speed Flat Gigabit RJ45 LAN)

If not how can I add them?
Have you confirmed that the SFP module is functional in another system? If not, you're dealing with at least two variables, instead of one :)
 

LodeRunner

Active Member
Apr 27, 2019
455
199
43
In the guide it says "By default, all ports are in VLAN 1" for the ICX 6450 does that include the 4SPF+ ports? I have an "Cable Matters 1000BASE-T Gigabit SFP to RJ45 Copper Ethernet Modular Transceiver" but doesn't work(ve interface 1 IP doesn't ping). Using any of the ethernet ports direct works (Cat 7 Ethernet Cable High-Speed Flat Gigabit RJ45 LAN)

If not how can I add them?
I don't have a 6450, so I don't know, but do you have to manually set the speed for a SFP+ port if you're not using a 10G module, or will it properly auto-detect?
 

Craig Curtin

Member
Jun 18, 2017
70
14
8
57
In the guide it says "By default, all ports are in VLAN 1" for the ICX 6450 does that include the 4SPF+ ports? I have an "Cable Matters 1000BASE-T Gigabit SFP to RJ45 Copper Ethernet Modular Transceiver" but doesn't work(ve interface 1 IP doesn't ping). Using any of the ethernet ports direct works (Cat 7 Ethernet Cable High-Speed Flat Gigabit RJ45 LAN)

If not how can I add them?
Did you follow through the initial config that created a VLAN and gave it an IP Address etc ?

Did you take away the stacking config for the SFP+ ports and then follow the licenscing to ensure they were then enabled as SFP+ standard use ports ?

This is what i have ended up with after following the config and have confirmed that one of the SFP+ ports work when attached to an Intel DAC



SSH@CURTO-6610#show run
Current configuration:
!
ver 08.0.30uT7f3
!
stack unit 1
module 1 icx6610-48-port-management-module
module 2 icx6610-qsfp-10-port-160g-module
module 3 icx6610-8-port-10g-dual-mode-module
stack disable
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
enable aaa console
hostname CURTO-6610
ip dhcp-client disable
ip dns server-address 172.16.100.1
ip route 0.0.0.0/0 172.16.100.1
!
no telnet server
username root password .....
!
!
clock summer-time
clock timezone gmt GMT+10
!
!
ntp
disable serve
server 216.239.35.0
server 216.239.35.4
server 172.16.100.1
!
!
no web-management http
!

interface ethernet 1/3/1
speed-duplex 10G-full
!
interface ethernet 1/3/2
speed-duplex 10G-full
!
interface ethernet 1/3/3
speed-duplex 10G-full
!
interface ethernet 1/3/4
speed-duplex 10G-full
!
interface ethernet 1/3/5
speed-duplex 10G-full
!
interface ethernet 1/3/6
speed-duplex 10G-full
!
interface ethernet 1/3/7
speed-duplex 10G-full
!
interface ethernet 1/3/8
speed-duplex 10G-full
!
interface ve 1
ip address 172.16.100.252 255.255.255.0
!
!
end

SSH@CURTO-6610#

 

Craig Curtin

Member
Jun 18, 2017
70
14
8
57
Hey Guys,

New to Ruckus/Brocade - obviously pretty close to Cisco CLI that i have been working with nearly forever - has anyone got a good site that they could refer me to with

1) Basic differences
2) A good cheat sheet for all the basic commands to get L3 VLAN trunks and ESXI servers running ?


Craig
 

Damo

Member
Sep 7, 2022
42
4
8
Did you follow through the initial config that created a VLAN and gave it an IP Address etc ?

Did you take away the stacking config for the SFP+ ports and then follow the licenscing to ensure they were then enabled as SFP+ standard use ports ?

This is what i have ended up with after following the config and have confirmed that one of the SFP+ ports work when attached to an Intel DAC



SSH@CURTO-6610#show run
Current configuration:
!
ver 08.0.30uT7f3
!
stack unit 1
module 1 icx6610-48-port-management-module
module 2 icx6610-qsfp-10-port-160g-module
module 3 icx6610-8-port-10g-dual-mode-module
stack disable
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
enable aaa console
hostname CURTO-6610
ip dhcp-client disable
ip dns server-address 172.16.100.1
ip route 0.0.0.0/0 172.16.100.1
!
no telnet server
username root password .....
!
!
clock summer-time
clock timezone gmt GMT+10
!
!
ntp
disable serve
server 216.239.35.0
server 216.239.35.4
server 172.16.100.1
!
!
no web-management http
!

interface ethernet 1/3/1
speed-duplex 10G-full
!
interface ethernet 1/3/2
speed-duplex 10G-full
!
interface ethernet 1/3/3
speed-duplex 10G-full
!
interface ethernet 1/3/4
speed-duplex 10G-full
!
interface ethernet 1/3/5
speed-duplex 10G-full
!
interface ethernet 1/3/6
speed-duplex 10G-full
!
interface ethernet 1/3/7
speed-duplex 10G-full
!
interface ethernet 1/3/8
speed-duplex 10G-full
!
interface ve 1
ip address 172.16.100.252 255.255.255.0
!
!
end

SSH@CURTO-6610#

Not sure what part of the guide you're talking about can't see it in the 6450


Current configuration:
!
ver 08.0.30uT313
!
stack unit 1
module 1 icx6450-48p-poe-port-management-module
module 2 icx6450-sfp-plus-4port-40g-module
!
!
!
lag lag dynamic id 1
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
ip dhcp-client disable
ip dns server-address 192.168.0.1
ip route 0.0.0.0/0 192.168.0.1
!
username root password .....
!
!
!
!
!
interface ve 1
ip address 192.168.0.50 255.255.255.0
!
!
!
!
!
!
!
!
!
end


The SFP module does work @kpfleming
 

kpfleming

Active Member
Dec 28, 2021
227
105
43
Pelham NY USA
As noted above, you almost certainly need to set the speed of the SFP+ port to 1G instead of the 10G default. Have you given that a try?

Also, while you're bringing up the box you should consider upgrading to 08.0.95<current>, since you're on 08.0.30 now.
 
  • Like
Reactions: prdtabim

LodeRunner

Active Member
Apr 27, 2019
455
199
43
As noted above, you almost certainly need to set the speed of the SFP+ port to 1G instead of the 10G default. Have you given that a try?

Also, while you're bringing up the box you should consider upgrading to 08.0.95<current>, since you're on 08.0.30 now.
It’s a 6450; IIRC the 6000 family can only go to 8.0.30
 

NablaSquaredG

Well-Known Member
Aug 17, 2020
696
311
63
Does anyone know whether there will be a 4X25GF module? There is a 4x10GF (4x 10G SFP+) and 1x100GQ (1x 100G QSFP28), but no 4x25G SFP module... The 4x25G module would make the ICX 7650-24ZP perfect for my application

(I know, chances are low - but maybe anybody has heard anything? If not, I will contact Ruckus)
 

Craig Curtin

Member
Jun 18, 2017
70
14
8
57
Not sure what part of the guide you're talking about can't see it in the 6450


Current configuration:
!
ver 08.0.30uT313
!
stack unit 1
module 1 icx6450-48p-poe-port-management-module
module 2 icx6450-sfp-plus-4port-40g-module
!
!
!
lag lag dynamic id 1
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
ip dhcp-client disable
ip dns server-address 192.168.0.1
ip route 0.0.0.0/0 192.168.0.1
!
username root password .....
!
!
!
!
!
interface ve 1
ip address 192.168.0.50 255.255.255.0
!
!
!
!
!
!
!
!
!
end


The SFP module does work @kpfleming

I am not seeing a stack disable command in your dump ? This would mean the ports still think they are in stacking rather than port mode

(I am only new to all of this Brocade as of last week - so am just surmising)

Craig

Craig
 
  • Like
Reactions: kpfleming

jcstill

New Member
Aug 10, 2021
4
0
1
Southern California
Hi,

I recently got a 7750-48F. It is boot looping printing this:
Code:
Bootloader Version: 10.1.13T205 (Jul 24 2018 - 03:22:28)

SVR: 0x82100120, PVR: 0x80230032
ICX7750:48F,Production-1
SYS CPLD VER: 0xe, Released Ver: 0
Enter 'b' to stop at boot monitor:  0
bootdelay: ===
Booting image from Primary
## Booting kernel from Legacy Image at 86000000 ...
   Created:      2018-07-24  10:22:58 UTC
   Data Size:    473584 Bytes = 462.5 KiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Verifying Application Image ...
    Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK
HV# 
 No vsmgr node in config tree
HV# cpu0/0: failover_register() - registering notifiers...
^[[0ndefault eusb_infra enabled 
ICX7750 eUSB-Infra Called 
 Number of eUSB partitions 7 ...
PLATFORM SW
Config partition mounted.
eUSB flash drive is ready  No External USB Drive(s) Mounted . Resources folder check done!
Mfg. Backup Infra is Factory Disabled
dma_mem_base: 0xf8000000, dma_mem_len: 0x8000000, warm_mem_base: 0xf0200000, warm_mem_len: 0xd00000
Enabling time stamp.
Starting the FastIron.

FIPS Disabled:PORT NOT DISABLED
platform type 61
OS>
Loaded Image SWR08070c from Pri Built on (UTC): Thu Aug 30 11:34:18 2018
Enabling Console Logging
                        flash_file=0.
Hotplugger Daemon Initialized ..
set_board_level: gi_board_type = 94[   17.927284] linux-kernel-bde: map phys range 0xf0000000-0xf0040000 to 0x4d982000-0x4d9c2000
[   17.929673] linux-kernel-bde: map phys range 0xf8000000-0x0 to 0x4d9c2000-0x559c2000
DMA pool size: 134217728
                        SOC unit 0 attached to PCI device BCM56852_A2
0:soc_trident2_chip_reset: LCPLL 0 not locked on unit 0 status = 0x00000000
0:soc_schan_timeout_check: soc_schan_op: operation attempt timed out
0:_soc_cmicm_schan_op: SchanTimeOut:soc_schan_op operation timed out cmc=0
  HDR[NACK=0 BANK=0 DMA=0 ECODE=0 ERR=0 DLEN=8 ACC=0 DPORT=7 OPC=11=READ_REG_CMD]
  DW[ 0]=0x2c700400 DW[ 1]=0x0e001100
fdry_system_init: Misc init failed: Operation timed out
ERROR: SOC unit 0 system_init failed

**********  BCM SDK init FAILED  *************


***********************************************

FATAL ERROR:  Failed in HW init hence rebooting

***********************************************
T=0.9: Halt and reboot
Unmounting the External USB
We are in system resetCopy RAMFS console log file to flash before we shutdownSyncing file system
Rebooting...
Not sure what is going on here, any help would be apreciated.

Thanks
 

LodeRunner

Active Member
Apr 27, 2019
455
199
43
Follow the guide linked in the first post to reflash the primary partition and the boot sector from inside the uBoot environment.

If that fails, you most likely have a hardware issue of some sort. I had a 7150 with wonky flash and I had to use the NAND clean and scrub commands to get it to properly load an image.
 
  • Like
Reactions: fohdeesha

Mushishi

New Member
Apr 26, 2016
14
6
3
43
Turku, Finland
this channel has 300,000 subscribers and he could not google to find this thread or guide before deciding to publish this. kill me

Well you know it is better for him to make a video with that title as that will get more clicks, and he can make a part 2 later on that he fixed it. Not defending him but just thinking about the youtube/adsense mindset. And he can thank his fans to send him to this thread.
 

itronin

Well-Known Member
Nov 24, 2018
977
622
93
Denver, Colorado
this channel has 300,000 subscribers and he could not google to find this thread or guide before deciding to publish this. kill me
surely you realized this would be a train wreck before he even racked the switch?

The words, enterprise and "plug and play" in the same sentence?

Big negative points for using a D'k tahg as a box opener too - that's just - just plan wrong.

listening to his jibber jabber flim flam hurt my brain.

so much bad content in that video.