ASRock romed8-2t: Control fans via IPMI

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

FaSti

New Member
Apr 30, 2022
4
0
1
Hi,
I’m having a hard time to control fans on an ASRock romed8-2t. Via IPMI I can make and save settings but what ever settings I make, the fans will always spin at max… Even if I do someting very simple like selecting manual mode and sat duty to 20, the fan will still spin at max speed, even after reboot.
 

tinfoil3d

QSFP28
May 11, 2020
860
394
63
Japan
Just in case you're here from google, the answer could be found on asrockrack website FAQ in the very bottom.
When I was setting it up initially this worked on my ROMED8-2T/BCM, bios 3.40. There were no fan settings in bios setup whatsoever. Had to do it with ipmitool after boot, I needed to set full speed on all fans and this worked.

1. Switch to manual control
ipmitool raw 0x3a 0xd8 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1 0x1

2. Set 100% speed on all fans (0x64 - 100 in hex, use other values under 100 to fine-tune)
ipmitool raw 0x3a 0xd6 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64

3. Set back to auto?
ipmitool raw 0x3a 0xd8 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0