vSan does not see disks in Gui

Discussion in 'VMware, VirtualBox, Citrix' started by Rand__, Oct 14, 2018.

  1. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,606
    Likes Received:
    347
    So trying to build a test cluster and cobbled together a few servers.

    2 are fine, the third is acting up - disks are not visible in vSan disk selection.
    upload_2018-10-14_19-23-2.png

    They are visible on cli though
    upload_2018-10-14_19-23-47.png
    and o/c on the HBA
    upload_2018-10-14_19-24-45.png

    I thought it might be due the expander backplane i had in use so i swapped that to a -A, but no deal.

    I swapped drives with another box, it worked fine there and the swapped in one does not show up either ...
    I am kind a lost :eek:
     
    #1
  2. billc.cn

    billc.cn Member

    Joined:
    Oct 6, 2017
    Messages:
    38
    Likes Received:
    5
    Try wiping all partitions from the disks using the physical disks page.
     
    #2
  3. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,606
    Likes Received:
    347
    There are no partitions on them any more, they had partition issues so i recreated with
    partedUtil mklabel ... gpt

    Also, same disk is seen fine in another box.

    Will try to switch out the HBA next
     
    #3
  4. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,606
    Likes Received:
    347
    No change with new HBA. Also tried creating datastores and wiping again, also no luck :(
     
    #4
  5. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,606
    Likes Received:
    347
    I found it - the host in question had a vastly different time set up (one year difference).
    One i activated ntp the disks showed up. Seems i don't have ntp high enough (or at all) on my 'post-install activities):)

    One for the pre-check if vmware would listen to non business customers.
    Or maybe it's in the manual, have not checked;)
     
    #5
  6. billc.cn

    billc.cn Member

    Joined:
    Oct 6, 2017
    Messages:
    38
    Likes Received:
    5
    Hmmm, host profiles (if you have the license) is your friend. I teardown/setup ESXi on weekly bases for tests and cannot imagine setting everything up manually.
     
    #6
Similar Threads: vSan does
Forum Title Date
VMware, VirtualBox, Citrix 6.7U1 Vsan doesn't seem to work with Connectx-3 Nov 7, 2018
VMware, VirtualBox, Citrix vSAN ESXi, StarWind, or Dell EMC software solutions Sep 21, 2018
VMware, VirtualBox, Citrix VMWare vSAN, quad M.2 NVME + 1 cache vs SATA SSDs? Jul 5, 2018
VMware, VirtualBox, Citrix VMware vSAN Performance :-( Apr 4, 2018
VMware, VirtualBox, Citrix 2 node vsan for production? Mar 15, 2018

Share This Page