(US) 90 dollar Wyse 5070 Thin client/mini-server?

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

mattalat

Member
Dec 28, 2022
24
29
13
Anyone slap a 140mm fan on top to help with cooling? Mine gets quite hot (particularly the SSD) when downloading large files. Should I power it with a USB to fan header adapter, or is there some way to use the serial port for power?
 
  • Like
Reactions: Samir

chinesestunna

Active Member
Jan 23, 2015
622
202
43
57
Anyone slap a 140mm fan on top to help with cooling? Mine gets quite hot (particularly the SSD) when downloading large files. Should I power it with a USB to fan header adapter, or is there some way to use the serial port for power?
Agree with keeping this passive. If active cooling is needed, I'm considering taping the internal USB3 header port for 5v and getting some 5v fans, although it would be ironic as the chip is about 10W and most fans are around 1W (10% power budget increase!)
 
  • Like
Reactions: Samir

labxplore

Member
Sep 12, 2022
18
26
13
Anyone slap a 140mm fan on top to help with cooling? Mine gets quite hot (particularly the SSD) when downloading large files. Should I power it with a USB to fan header adapter, or is there some way to use the serial port for power?
I have a 120mm fan tied to mine extended one but it’s because I have a HBA card on it. Will change to another 140mm fan I have and try to run at lower speeds…
 
  • Like
Reactions: Samir

tasort

New Member
Dec 6, 2022
9
7
3
Nope, it was on one of my bypassNRO attempts in Win10 setup. It appears to have gotten passed it and displayed a screen I've never seen before in the set-up flow. This screen showed an NBC logo and further text outlining 4 steps are left along the lines of downloading profile, installing apps, joining corp domain etc. I shut down at step 1. I forgot to take a photo.
What's more intriguing is this is after I've wiped the SSD and fresh Win10 install, almost Mac like where if the S/N is registered with corp account the machine is "locked" to it and will auto provision regardless of drive wipe from what I've been told.
Any chance the Service Tag contains "NBC" in it? I saw a couple listings on ebay and cannot find info on the dell support site using their service tags
 
  • Like
Reactions: Samir

chinesestunna

Active Member
Jan 23, 2015
622
202
43
57
Any chance the Service Tag contains "NBC" in it? I saw a couple listings on ebay and cannot find info on the dell support site using their service tags
No indications at all, I searched the serviceTag on Dell and it shows expired 10/18/2023 so guessing these are newly decommissioned systems. I bought it from a local source on FB
 
  • Like
Reactions: Samir

chinesestunna

Active Member
Jan 23, 2015
622
202
43
57
Grabbed 2 sticks of 16GB Crucial DDR4 2400 So-DiMMs, working with 32GB of RAM now :)

Spoke too soon, while BIOS shows all 32GB, the system seems to slow to a crawl. Something funky going on, more work is needed
 
Last edited:
  • Like
Reactions: Samir

Fritz

Well-Known Member
Apr 6, 2015
3,444
1,447
113
70
Grabbed 2 sticks of 16GB Crucial DDR4 2400 So-DiMMs, working with 32GB of RAM now :)

Spoke too soon, while BIOS shows all 32GB, the system seems to slow to a crawl. Something funky going on, more work is needed
What OS are you using?
 
  • Like
Reactions: Samir

Fritz

Well-Known Member
Apr 6, 2015
3,444
1,447
113
70
Sounds like a SM board I have. With 256GB installed it slows to a crawl. Never did figure out why, just dropped back to 128Gb and all was well.
 
  • Like
Reactions: Samir

Fritz

Well-Known Member
Apr 6, 2015
3,444
1,447
113
70
Was using my 5070 Extended as a router running OPNSense. CPU temp was in the high 50's consistently. Started getting strange minute long Internet drop outs. Suspected a thermal problem. Replaced it with a SM E50-40 SYS-E50-9AP-N5. Drop outs stopped. Just opened the 5070 and removed the heatsink/fan from the CPU. The thermal grease was a bit on the dry side. I replaced it and the temp dropped to the mid 30's. This 5070 was brand new when I bought so I'd never have thought to replace the thermal grease but will be checking it from now on whether the box is ne or not. I tywrapped a 92mm fan to the SM box for good measure, it's a fanless sealed box so I figured a fan would be a good idea. CPU temp is running mid 30's which is fine.
 

labxplore

Member
Sep 12, 2022
18
26
13
Wyse 5070 Extended-as-a-NAS update (long)

Disclaimer: “Just because you can doesn't mean you should” :)

I was able to work a little bit more on my 5070 Extended with some nice "upgrades" and it's been working well for a few weeks now.
Parts:
- Wyse 5070 Extended, 32GB RAM, 2TB WD Blue SATA
- HBA Sun/Oracle 7085208 LSI SAS 9300-8e + 2x Mini SAS HD SFF8644 to SATA cables
- 4x WD Red 10TB HDD (can expand to 8 later...) on a salvaged Chenbro 4-Bay HDD Cage
- Corsair SF750 PC Power Supply (way more power than needed but it's what I have and it will be used on another build later..)
- "Contraption" to connect Wyse directly to the PSU: ATX Power Adapter Board + DC Boost/Step up Converter + Power Meter + DS2501 chip (and other components...)
- Corsair Commander PRO (to control the Fans and get multiple temperature readings)
- 2 Fans (140mm tied to the Wyse and 92mm inside the HDD Cage)
- SENA UD100 Bluetooth adapter
- Nooelec RTL-SDR dongle
- Internal USB3 to USB2 header cable

I was trying to see if it was possible to achieve this setup and I'm happy with the results so far...
The power supply is powering both the HDDs and the Wyse, so I'm not using the Dell power brick but I'm also not saving space :D The PSU is connected to an ATX Adapter Board (not really needed, but to make it easier) which then feeds a DC-DC Boost Converter to bring the 12V to 19.5V required for the Wyse.

In order to avoid the adapter warning and lower CPU frequency, I've set up a cable from the Booster to the Wyse based on Dell's 3-wire standard and got a DS2501 (programmed for 130W) to send the signal that the PSU can support 130W. No warnings on the Wyse and full CPU frequency is allowed.

I've also added a Power Meter between the DC-DC Boost Converter mostly to monitor voltage and get some data on power consumption just for the Wyse. Interestingly, with the machine off and no dongles the draw is 0.44W (Fan controller connected). The Bluetooth adapter adds 0.84W and the RTL-SDR adds another 1.72W for a total of 3W draw with the machine OFF!

To keep things cool there is a 140mm Fan attached to the top of the Wyse, right where the HBA card is, and a 92mm inside the HDD cage.
Both fans are controlled by the Commander Pro based on a temperature profile I've defined trying to keep the HBA card and the HDDs within a 85F-110F /~30C-43C range. I'm using both the internal sensors reported by the drives and the LSI card, as well as temperature probes from the Commander PRO at the rear end of the HDD cage and inside the Wyse (above the HBA card)

The Commander PRO by the way requires a USB2 internal connection so I had to route a USB3 to USB2 cable through the DELL logo hole to connect to the Fan controller.

The Wyse is running Proxmox with HomeAssistant, NodeRed, MQTT, Influx, (a bunch of other LXCs) and Ubuntu VMs, and Xpenology for the NAS. CPU usage averages 20% (looks like HomeAssistant is the most constant load - must be the camera feed...). NAS is able to saturate the full Gb Network connection - maybe I should look for a 2.5Gbps network adapter to add to the A+E WiFi slot. :D

I haven't done any optimization for HDD sleep for the NAS yet - average on the wall consumption for everything has been around 64W and with the NAS actively in use, consumption jumps about 10W max. From that total, the wyse seems to be pulling between 8W and 10W, with the biggest draw being the RTL-SDR (~2W). Given the PSU is 750W, I believe a chunk of this 64W may be actually due to the PSU efficiency curve at low load.

Quick math: Wyse (8-10W), Fans (3-4.5W), Commander PRO (? - some places say 12.6W which I think it's too high for just the controller...), HDDs 22.8W (5.7W * 4 - they are not going idle yet) = 46-50W + PSU efficiency curve at such low draw (~70%-78%) seems to match...

If I didn't have some parts available, or got them second-hand/cheap, this build probably would be way more expensive than a DIY NAS motherboard and dedicated case... but now I know it can be done with a Wyse 5070 as well :)
 

Attachments

WANg

Well-Known Member
Jun 10, 2018
1,330
984
113
46
New York, NY
Wyse 5070 Extended-as-a-NAS update (long)

Disclaimer: “Just because you can doesn't mean you should” :)

I was able to work a little bit more on my 5070 Extended with some nice "upgrades" and it's been working well for a few weeks now.
Parts:
- Wyse 5070 Extended, 32GB RAM, 2TB WD Blue SATA
- HBA Sun/Oracle 7085208 LSI SAS 9300-8e + 2x Mini SAS HD SFF8644 to SATA cables
- 4x WD Red 10TB HDD (can expand to 8 later...) on a salvaged Chenbro 4-Bay HDD Cage
- Corsair SF750 PC Power Supply (way more power than needed but it's what I have and it will be used on another build later..)
- "Contraption" to connect Wyse directly to the PSU: ATX Power Adapter Board + DC Boost/Step up Converter + Power Meter + DS2501 chip (and other components...)
- Corsair Commander PRO (to control the Fans and get multiple temperature readings)
- 2 Fans (140mm tied to the Wyse and 92mm inside the HDD Cage)
- SENA UD100 Bluetooth adapter
- Nooelec RTL-SDR dongle
- Internal USB3 to USB2 header cable

I was trying to see if it was possible to achieve this setup and I'm happy with the results so far...
The power supply is powering both the HDDs and the Wyse, so I'm not using the Dell power brick but I'm also not saving space :D The PSU is connected to an ATX Adapter Board (not really needed, but to make it easier) which then feeds a DC-DC Boost Converter to bring the 12V to 19.5V required for the Wyse.

In order to avoid the adapter warning and lower CPU frequency, I've set up a cable from the Booster to the Wyse based on Dell's 3-wire standard and got a DS2501 (programmed for 130W) to send the signal that the PSU can support 130W. No warnings on the Wyse and full CPU frequency is allowed.

I've also added a Power Meter between the DC-DC Boost Converter mostly to monitor voltage and get some data on power consumption just for the Wyse. Interestingly, with the machine off and no dongles the draw is 0.44W (Fan controller connected). The Bluetooth adapter adds 0.84W and the RTL-SDR adds another 1.72W for a total of 3W draw with the machine OFF!

To keep things cool there is a 140mm Fan attached to the top of the Wyse, right where the HBA card is, and a 92mm inside the HDD cage.
Both fans are controlled by the Commander Pro based on a temperature profile I've defined trying to keep the HBA card and the HDDs within a 85F-110F /~30C-43C range. I'm using both the internal sensors reported by the drives and the LSI card, as well as temperature probes from the Commander PRO at the rear end of the HDD cage and inside the Wyse (above the HBA card)

The Commander PRO by the way requires a USB2 internal connection so I had to route a USB3 to USB2 cable through the DELL logo hole to connect to the Fan controller.

The Wyse is running Proxmox with HomeAssistant, NodeRed, MQTT, Influx, (a bunch of other LXCs) and Ubuntu VMs, and Xpenology for the NAS. CPU usage averages 20% (looks like HomeAssistant is the most constant load - must be the camera feed...). NAS is able to saturate the full Gb Network connection - maybe I should look for a 2.5Gbps network adapter to add to the A+E WiFi slot. :D

I haven't done any optimization for HDD sleep for the NAS yet - average on the wall consumption for everything has been around 64W and with the NAS actively in use, consumption jumps about 10W max. From that total, the wyse seems to be pulling between 8W and 10W, with the biggest draw being the RTL-SDR (~2W). Given the PSU is 750W, I believe a chunk of this 64W may be actually due to the PSU efficiency curve at low load.

Quick math: Wyse (8-10W), Fans (3-4.5W), Commander PRO (? - some places say 12.6W which I think it's too high for just the controller...), HDDs 22.8W (5.7W * 4 - they are not going idle yet) = 46-50W + PSU efficiency curve at such low draw (~70%-78%) seems to match...

If I didn't have some parts available, or got them second-hand/cheap, this build probably would be way more expensive than a DIY NAS motherboard and dedicated case... but now I know it can be done with a Wyse 5070 as well :)
Definitely a bit of a Frankenstein there - but hey, as long as it works. Since I have a pair of cats who treats my entire home as their jungle gym, I prefer to keep everything in a single chassis. That A+E slot can also take also take a dual 1GBit M2-i350 if you want to give SRIOV a try.

What's the RTL-SDR dongle for? Passthrough radio for a HomeAssistant VM?
 

labxplore

Member
Sep 12, 2022
18
26
13
That A+E slot can also take also take a dual 1GBit M2-i350 if you want to give SRIOV a try.
That's good to know :)

What's the RTL-SDR dongle for? Passthrough radio for a HomeAssistant VM?
I use it to receive data from different 433MHz sensors: door/window sensors, temperature, water leak and others.
I have rtl_433 capturing everything and sending to MQTT topics - some data I use as part of automation in HomeAssistant, others I have triggers on NodeRed, some are also logged on Influx.
 

WANg

Well-Known Member
Jun 10, 2018
1,330
984
113
46
New York, NY
That's good to know :)


I use it to receive data from different 433MHz sensors: door/window sensors, temperature, water leak and others.
I have rtl_433 capturing everything and sending to MQTT topics - some data I use as part of automation in HomeAssistant, others I have triggers on NodeRed, some are also logged on Influx.
Yeah, I thought about using 433 MHz sensors with my HA VM - but I went with Z-Wave instead - mostly because I plan to control window AC units, and I couldn't find a 433 Mhz outlet controller that I can trust with high draw appliances through. The missus also didn't like the idea of having way too many things that my cats would potentially chew on, so nothing "mad-scientist-y" as she would've said.
My RTL-SDR dongle was also a 10- year old DVB-T decoder (RTL2832U+R820T) that ran a bit hot and draws waaaaay more power than I would like, so Z-Wave hub it was, then. I got a feeling that if I kept it running I'll probably be more interested in capturing ADS-B traffic than checking on temp/humidity and window sensor states.
 
  • Like
Reactions: labxplore

piranha32

Active Member
Mar 4, 2023
266
186
43
I use rtl_433 to collect data from weather sensors. The antenna is mounted in the attic, and the dongle is hooked up to an RPi mounted in a closet on the top floor. Messages from rtl_433 are published via mqtt, from where they are picked up by data logger and HA,, which are running in VMs on a server in the basement.
 
  • Like
Reactions: abq and labxplore