(Update 04-25) DFI DT122 (AMD RX-427BB) Industrial ITX T730-a-like; $99 shipped w/ 8GB

Firebug24k

New Member
Apr 12, 2017
16
11
3
37
What fan did you use? I might try this if someone can recommend a good, quiet 80mm fan to use with it.
I'm using "ARCTIC F8 PWM PST - Value Pack (5pc)" found on Amazon - it's pretty cheap and seems to work fine. Nothing special though.
 
  • Like
Reactions: rj1

Geran

Active Member
Oct 25, 2016
255
38
28
36
Has anyone tried to replace the heatsink and not just the fan?
 

Fritz

Well-Known Member
Apr 6, 2015
2,075
456
83
66
So what does it take to get this thing to play a 4k video? Mine thinks it's a slide show.
 

canta

Well-Known Member
Nov 26, 2014
1,028
198
63
39
One of the eBay sellers had instructions in his listing to reset all the BIOS settings:

"*Steps to resetting the BIOS back to defaults... (if you lost video but unit powers on & still beeps)
(restore all jumpers on motherboard to normal / default... & remove any add in hardware, except for the Ram & Keyboard )
First turn on the computer & press the delete key a few times quickly,... as if you are entering the BIOS / cmos as normal
then press the right arrow 5 times
then press the down arrow 4 times
then press the enter key twice (2)
then press up arrow 4 times
then press the enter key twice (2)
the system should restart and you should have video and bios back to defaults."
Hey, it works!!!!!
Thanks for the sequences :-D
 

canta

Well-Known Member
Nov 26, 2014
1,028
198
63
39
DT122-BE | 2nd Gen AMD Embedded R-Series | Bald Eagle | Pre-Configured System & Chassis | DFI The user manual has screenshots.

Boot pressing delete a few times to get to BIOS. Wait a few seconds.
Press the 'right' arrow 3 times to get to "Boot" section
Press the 'down' arrow 3 times to get to "CSM Properties", hit enter
You'll land on the top choice of "Launch CSM", to turn on, hit "+" ('Shift' + '=')
'F4' to save
'y' to confirm (maybe 'enter' too?)
You'll hear it beep and reboot. If you need to turn on the OPROMs, I didn't, look through the manual on DFI's website.

Leave CSM, and OPROMs on unless you have a specific reason to turn them off.

It's insane that you can accidentally turn off video, and clearing CMOS doesn't fix it, other than that, I like the board.
Thanks again
I flash back to original BIOS without iommu support. I need working nvme on pci-e slot, still waiting "cheap" 2TB or more nvme ha.... Do not know it happens...
Now, the system is back online with running containers. I try Zoneminder container with 2K and 4K ipcamera, and the processor is struggling with 96%. Oh well back to my other e3 proxmox to run ZM vm again :-\


Aeg' post actually works in one trial ;-D
 
Last edited:

Glock24

New Member
May 13, 2019
12
3
3
Thanks again
I flash back to original BIOS without iommu support. I need working nvme on pci-e slot, still waiting "cheap" 2TB or more nvme ha.... Do not know it happens...
Now, the system is back online with running containers. I try Zoneminder container with 2K and 4K ipcamera, and the processor is struggling with 96%. Oh well back to my other e3 proxmox to run ZM vm again :-\


Aeg' post actually works in one trial ;-D
You should try Shinobi, it uses far less CPU than Zoneminder.
 

Hilarius

New Member
Jun 3, 2019
2
0
1
Is anybody using one of these for pfSense or OPNSense?

After following this thread for a while, I finally picked one of these up to use as a router. Using Hyper-V on Server 2012R2, while trying to boot, I keep getting "Fatal trap 1: privileged instruction fault while in kernel mode". I got the same kernel panic on pfSense 2.4.4, pfSense 2.5.0, and OPNSense 19.1. Suspecting the issue was with FreeBSD, I also tried FreeBSD 11.2 and 12.0, and those gave the same kernel panic. Selecting CPU compatibility prevents the kernel panic, but also disables AES-NI. I did get OPNSense 18.7 to boot with zero issues, though. I also got all of those to boot with zero issues on a different Server 2012R2 host. I've been troubleshooting this for 3 days now, and I'm at a loss.
 

canta

Well-Known Member
Nov 26, 2014
1,028
198
63
39
You should try Shinobi, it uses far less CPU than Zoneminder.
Thanks for pointing out.
I tried a standalone before and not in to it :p.

I still bet o ZM due on flexibility ^^.
shinobi is selling native websocket, and current languange solutions, but ZM has been aging where need some refresh. I will see if shinobi maturing enough and has the same flexibilty and better detection.

I look further that shinobi is not good running in container too. and ZM has the same issue too.
going to refresh my current ZM in VM by upgrading to 1.34 version.
 

canta

Well-Known Member
Nov 26, 2014
1,028
198
63
39
After having more than three months:
This motherboard tweaked with specialized BIOS, not for general usage motherboard.:-\

I had a strange issue Yesterday on UEFI booting ( stuck while loading OS loading) :-\, the only to solve it, was reloading centos recovery through USB, and poweroff. it loaded succesdsfully when re-powering on.
 

mimino

Active Member
Nov 2, 2018
103
35
28
Is anybody using one of these for pfSense or OPNSense?

After following this thread for a while, I finally picked one of these up to use as a router. Using Hyper-V on Server 2012R2, while trying to boot, I keep getting "Fatal trap 1: privileged instruction fault while in kernel mode". I got the same kernel panic on pfSense 2.4.4, pfSense 2.5.0, and OPNSense 19.1. Suspecting the issue was with FreeBSD, I also tried FreeBSD 11.2 and 12.0, and those gave the same kernel panic. Selecting CPU compatibility prevents the kernel panic, but also disables AES-NI. I did get OPNSense 18.7 to boot with zero issues, though. I also got all of those to boot with zero issues on a different Server 2012R2 host. I've been troubleshooting this for 3 days now, and I'm at a loss.
Running pfsense on proxmox for the last 6 months with zero issues. Got to be windoze screwing you up.
 
  • Like
Reactions: arglebargle

Hilarius

New Member
Jun 3, 2019
2
0
1
Running pfsense on proxmox for the last 6 months with zero issues. Got to be windoze screwing you up.
I've done a little more testing. FreeBSD 11.2 boots fine on bare metal. So the problem is an interaction between Hyper-V, FreeBSD 11.2 and newer, and this specific hardware. Using an identical version of Hyper-V on different hardware doesn't yield the kernel panic I'm getting.
 

rj1

New Member
Apr 27, 2019
19
4
3
I'm using "ARCTIC F8 PWM PST - Value Pack (5pc)" found on Amazon - it's pretty cheap and seems to work fine. Nothing special though.
I guess I should have looked inside the case again before I ordered it.

Got the adapter printed and the fan coming tomorrow. I took the top off to look at how much clearance it would have and then realized my network card goes over the CPU and I won't be able to do this.

I guess I'll look for a 50mm fan.
 

rj1

New Member
Apr 27, 2019
19
4
3
Is anybody using one of these for pfSense or OPNSense?

After following this thread for a while, I finally picked one of these up to use as a router. Using Hyper-V on Server 2012R2, while trying to boot, I keep getting "Fatal trap 1: privileged instruction fault while in kernel mode". I got the same kernel panic on pfSense 2.4.4, pfSense 2.5.0, and OPNSense 19.1. Suspecting the issue was with FreeBSD, I also tried FreeBSD 11.2 and 12.0, and those gave the same kernel panic. Selecting CPU compatibility prevents the kernel panic, but also disables AES-NI. I did get OPNSense 18.7 to boot with zero issues, though. I also got all of those to boot with zero issues on a different Server 2012R2 host. I've been troubleshooting this for 3 days now, and I'm at a loss.
I've been running pfSense 2.4.4 in HyperV on Windows Server 2019 for a month without issue.
 

Firebug24k

New Member
Apr 12, 2017
16
11
3
37
I guess I should have looked inside the case again before I ordered it.

Got the adapter printed and the fan coming tomorrow. I took the top off to look at how much clearance it would have and then realized my network card goes over the CPU and I won't be able to do this.

I guess I'll look for a 50mm fan.
Ah that sucks. I've transplanted the board into a different case on the one I replaced the card with so I'm not using the riser.

For those wanting to add more drives and also make this a 10GB server, I think adding one of these: US $39.9 |IOCREST 4 Port SATA III 6G Mini PCI Express Marvel 88SE9215 controller Card SATA3.0 mini pci express ssd adapter card-in Add On Cards from Computer & Office on Aliexpress.com | Alibaba Group combined w/a 10GB card ought to work for a total of 8 drives. I have the parts just need some time this week or next to test.
 

canta

Well-Known Member
Nov 26, 2014
1,028
198
63
39
Ah that sucks. I've transplanted the board into a different case on the one I replaced the card with so I'm not using the riser.

For those wanting to add more drives and also make this a 10GB server, I think adding one of these: US $39.9 |IOCREST 4 Port SATA III 6G Mini PCI Express Marvel 88SE9215 controller Card SATA3.0 mini pci express ssd adapter card-in Add On Cards from Computer & Office on Aliexpress.com | Alibaba Group combined w/a 10GB card ought to work for a total of 8 drives. I have the parts just need some time this week or next to test.
Assuming you already prepare on 4sata marvel minipci
That thin heatsink is not enough to dissipate the heat. Must be replaced with bigger one.
Running ssd on those minipci card is not recommended due on pcie 2 single lane
 

canta

Well-Known Member
Nov 26, 2014
1,028
198
63
39
I guess I should have looked inside the case again before I ordered it.

Got the adapter printed and the fan coming tomorrow. I took the top off to look at how much clearance it would have and then realized my network card goes over the CPU and I won't be able to do this.

I guess I'll look for a 50mm fan.
This is just my suggestion...
Tru to get 50mm to 80mm : notebook blower for for cpu cooling. It is slim and blower fan has better pressure on my understanding. This puppy amd embedded cpu generates heat more than intel embedded on average cpu utilization.

I even trigger motherboard to shutdown automatically due on cpu heat limit when 96% utilization for 15ims running zm container with 2k and4k ip camera . My case is very compact. And monitoring through lcdproce display . The fan already full blast: cpu is 4600rpm 80mm fan. And
Exhaust is 1700rpm 120mm fan
 

Zedicus

New Member
Jul 12, 2018
8
5
3
do the display ports on these carry audio? i would like to use one as a remote media player on a crappy old LCD TV in the work out room. the tv is 720P so i think there is more than enough horse power in this device.
 

Fritz

Well-Known Member
Apr 6, 2015
2,075
456
83
66
For those of you who are using this as an HTPC, how are you dealing with the noise?