Supermicro IPMI Fan Speed Control - GPU System

RCS

New Member
Jul 27, 2018
10
0
1
Hi guys,

I'm having issues setting fan speeds on a 4027GR-TR Supermicro system.

System has 8 fans for both CPU/GPU/chassis cooling, and are controlled via the IPMI.

I've followed this guide from PigLover but it doesn't seem to work with this system.

https://forums.servethehome.com/index.php?resources/supermicro-x9-x10-x11-fan-speed-control.20/

I only have two default options for fan speeds: Optimal and Full.

I'm able to check what mode it's set to with the following command;

Code:
ipmitool raw 0x30 0x45 0x00
This outputs 01 or 02 (Full or Optimal).

But... When I try to set the fans to a specific duty cycle (40%, 50%, etc.) using the following command;

Code:
ipmitool raw 0x30 0x70 0x66 0x01 0x00 0x32
I get the following error;

Code:
Unable to send RAW command (channel=0x0 netfn=0x30 lun=0x0 cmd=0x70 rsp=0xcc): Invalid data field in request
I've tried different variations of the same command, and all of them spit out the same error message.

I don't think this system has different fan zones (Zone 1 for CPU, Zone 2 for peripherals, etc.) as all the 8 fans in the system are designed to cool everything. I'm thinking this may have something to do with why it's not working.

Any ideas?

Thanks!
 

RCS

New Member
Jul 27, 2018
10
0
1
Update. Did some more reading and found some commands that work on this board. Maybe its an X9 generation thing?

System seems to have 4 zones. One for each fan pair.

The following code works after setting the fan mode to "Full".
Code:
#set fans in "Zone 1" to 30%
#ipmitool raw 0x30 0x91 0x5A 0x3 0x10 0x4D
#set fans in "Zone 2" to 30%
#ipmitool raw 0x30 0x91 0x5A 0x3 0x11 0x4D
#set fans in "Zone 3" to 30%
#ipmitool raw 0x30 0x91 0x5A 0x3 0x12 0x4D
#set fans in "Zone 4" to 30%
#ipmitool raw 0x30 0x91 0x5A 0x3 0x13 0x4D
The "0x4D" at the end is the fan speed setting for each individual zone. Range is 0-255 (in decimal format)

Hope this helps someone else in the future!

Thanks.