Supermicro Epyc motherboards - list of graphics cards that work - I need help to make a list

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

EBRAddict

Member
Jun 16, 2023
30
8
8
H12SSL Radeon RX 7600 - does not work (mostly)

POST freezes if the PCIe mode for the GPU slot is set to = EFI
If it is set = Disable then it will post and boot into O/S, but... I couldn't get Ubuntu or Debian desktops to work with the card, even though it appeared to be on the PCI bus. In both cases it just used the built-in VGA, but that stopped working in both installs after the few reboots, leading to a blank GUI and journalctl errors thrown by "Mutter".

I *did* get a very rudimentary Nixos install to use the card with Wayland and sway manual install, but it was very low on features.
How to Enable Wayland on NixOS, or: Confusion, Conquest, Triumph
 

alex_stief

Well-Known Member
May 31, 2016
884
312
63
39
I need to resurrect this: recently read that disabling iKVM could help with that. You lose remote access via IPMI, but if that helps with getting pretty much all graphics cards to run, it would be a small price to pay for workstation applications. What are your thoughts on this?
 

rtech

Active Member
Jun 2, 2021
330
119
43
I need to resurrect this: recently read that disabling iKVM could help with that. You lose remote access via IPMI, but if that helps with getting pretty much all graphics cards to run, it would be a small price to pay for workstation applications. What are your thoughts on this?
Only windows has problems with two GPUs: (bmc GPU and pcie GPU)
 

i386

Well-Known Member
Mar 18, 2016
4,315
1,592
113
35
Germany
What are your thoughts on this?
ikvm helped me more than once with an "unresponsive" os & getting into bios/uefi, I don't want to miss this feature for my workstations & servers.
Only windows has problems with two GPUs: (bmc GPU and pcie GPU)
1693233995367.png
This is windows 11 on a m12swa, previously I had a h12ssl with a 1080ti add in card (evga) and it worked without any problems...
ikvm works and show the desktop + open windows :D

Edit:forget the last part. it seems that windows + bmc gpu can be problematic:
1693234716424.png
 
Last edited:

lopgok

Active Member
Aug 14, 2017
217
152
43
The issue I found was the boot process would seemingly hand, and never get to the operating system.
This is operating system agnostic.
There may be other OS specific issues, but if the mb won't get past POST, other problems really don't matter.
 

alex_stief

Well-Known Member
May 31, 2016
884
312
63
39
I see my question was worded poorly. I was more interested if anyone knows if disabling iKVM could help with the GPU compatibility issue at all.
 

Glbjr29

New Member
Aug 20, 2022
6
0
1
So I am using the Supermicro H11SSL-i , Version 2.00 Version 2.1. I used a quadro p2000 in my other setup. Will them not work with this motherboard. What would you recommend and I also purchased a startech kvm that I would like to use as well. Also I am using unraid as my OS.
 
Last edited:

chulojay

New Member
Jan 30, 2024
1
0
1
So I am using the Supermicro H11SSL-i , Version 2.00 Version 2.1. I used a quadro p2000 in my other setup. Will them not work with this motherboard. What would you recommend and I also purchased a startech kvm that I would like to use as well. Also I am using unraid as my OS.
I wanted to add an Nvidia P2000 to H11ssl but no matter what i try it doesn't seem to show up on the bio. I can connect a screen to it and see the post but it wont come up anywhere else on the system.
So maybe we should add this P2000 to the list of non working cards .
I bought the Supermicro board hoping to do gpu passthrough.
Now i have to try to get rid of it.
 

gsrcrxsi

Active Member
Dec 12, 2018
323
108
43
I wanted to add an Nvidia P2000 to H11ssl but no matter what i try it doesn't seem to show up on the bio. I can connect a screen to it and see the post but it wont come up anywhere else on the system.
So maybe we should add this P2000 to the list of non working cards .
I bought the Supermicro board hoping to do gpu passthrough.
Now i have to try to get rid of it.
You will not see the P2000 listed in the bios specifically. I’m not aware that you’d see any GPU in the BIOS.

but if you want to get full display through it you’ll have to change the default VGA output from Internal to External. (Or Offboard vs Onboard, I forget the exact verbiage the SM boards is)

Or if you’re talking about passthrough to a VM, you might need to adjust some IOMMU settings.
 

EBRAddict

Member
Jun 16, 2023
30
8
8
I wanted to add an Nvidia P2000 to H11ssl but no matter what i try it doesn't seem to show up on the bio. I can connect a screen to it and see the post but it wont come up anywhere else on the system.
So maybe we should add this P2000 to the list of non working cards .
I bought the Supermicro board hoping to do gpu passthrough.
Now i have to try to get rid of it.
Mine works fine on Ubuntu Linux 23.04. Post, UEFI/bios and desktop.
 

IamSpartacus

Well-Known Member
Mar 14, 2016
2,520
652
113
I have an H12SSL and have the following GPUs all working perfectly fine.
Code:
Nvidia GTX 1660
Nvidia a4000
Intel Arc Pro a40 (x2)
 

kemic

New Member
Aug 15, 2015
26
4
3
H12SSL-I - WX9100 (MI25 with WX9100 bios) and MI25 work (system boots fine) however the BMC isn't detecting any temps from the WX9100. As a result the fans kick up full tilt on the system. FYI have not tested video output on the WX9100 flash as the fan noise is unsustainable in my environment. I flashed the WX9100 bios back to MI25 (220W version found here: AMD Radeon Instinct MI2 VBIOS) and my BMC is happy. :D

The MI25 has a mini DP port on it but by default there's no video output with the non-WX9100 bios so I won't be able to test that. Not sure if my post is all that relevant to this thread now that I type this. Guess it depends on your definition of "working". lol

Reference (for compatible bios mostly): Mi25, Stable Diffusion's $100 hidden beast
 

clee

New Member
May 5, 2024
3
0
1
H12SSL-NT here, installed an Intel Arc A380 to play with hardware-accelerated video transcoding and of course the server hangs during PCIe enumeration. Was able to fix the boot lockup by disabling the option ROM setting for the PCIe slot with the A380 (it was set to "EFI" previously). A380 shows up in Debian Linux and appears to be functional, but this server is headless so who knows if the video outputs work at all.
 

softwareweaver

New Member
Jun 3, 2024
4
0
1
H12SSL-i with Epyc 7713 works fine with Suprim RTX 4090 under Ubuntu 22.04

Was wondering if anyone has experience with adding RTX A6000 or RTX 6000 Ada cards to it. Is there anything to watch out for adding 4 GPUs to it. Thanks.
 

IamSpartacus

Well-Known Member
Mar 14, 2016
2,520
652
113
H12SSL-i with Epyc 7713 works fine with Suprim RTX 4090 under Ubuntu 22.04

Was wondering if anyone has experience with adding RTX A6000 or RTX 6000 Ada cards to it. Is there anything to watch out for adding 4 GPUs to it. Thanks.
I'm using an RTX A4000 with my H12SSL-i. It's worked flawlesslly along side a GTX 1660 and two Intel Arc A40 Pro's.
 
  • Like
Reactions: softwareweaver

clee

New Member
May 5, 2024
3
0
1
Don't suppose you've still got any of that 20-pack left that you're looking to sell…