Quanta LB4M 48-Port Gigabit Switch Discussion

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Toppy

New Member
May 1, 2017
3
0
1
56
Sadly not, nothing via console at all... /cry ... I will try changing baud rates from the default 9600 later, however I don't hold much hope in that working :S I have been trying to get some info on where the boot code is stored without any joy. Shame as the going price on these switch's is good.

Regards
//\//\ ..... ;)
 

Visseroth

Member
Jan 23, 2016
75
1
8
44
Weird, I haven't yet heard of someone killing the boot rom. I wonder if it was because you used the xmodem option to upload the firmware. Most of us use tftp.
I just enable the service on my server, point the service to my public folder and walla, tftp, NOW UPDATE YOU SWITCH, UPDATE!!! MUHAHAHAHA.
Sorry, went on a rampage there for a second.

Anyhow, if you're getting nothing then I wouldn't know where to go from here. You'd likely need a rom replacement to get it back up and working or order another and you'll have spare parts.
 

TheBloke

Active Member
Feb 23, 2017
200
40
28
44
Brighton, UK
Sadly not, nothing via console at all... /cry ... I will try changing baud rates from the default 9600 later, however I don't hold much hope in that working :S I have been trying to get some info on where the boot code is stored without any joy. Shame as the going price on these switch's is good.

Regards
//\//\ ..... ;)
So you're connecting a serial cable to the Console port of the LB4M, and when you power up the switch with that cable in place, you see no output on the PC terminal software? When connected with 9600,N,1, no flow control?

Sorry for the obvious point, but you have triple checked that it's not a problem with the serial cable or some other element in the connection? Tested that cable + PC + terminal software with another switch and know that works fine?

As Visseroth said, when the switch first powers on you should see an option of 1 or 2, and that's the boot loader which actually loads the boot rom. The ROM you overwrote with xmodem shouldn't be able to affect that initial boot loader. Although again as Visseroth said, we all do it with tftp so I doubt many here have experience of xmodem (I didn't even realise that was possible until you mentioned it.)

So if you're definitely seeing no output at all through a known-good cable, that's really weird and is something I thought should not be possible through any method of updating the ROM.
 

tdale

New Member
May 5, 2017
2
0
1
36
I've upgraded my firmware to:
Images currently available on Flash

--------------------------------------------------------------------
unit image1 image2 current-active next-active
--------------------------------------------------------------------

1 5.13.12.14 1.1.0.8 image1 image1

And it doesnt matter if i run switching or routing no BGP?

Ive seen a few people say these puppies can do BGP. What do i need to do to get BGP going on them?

Thanks,

Tom
 

doctor

Member
Mar 19, 2015
63
24
8
I have two LB4M's running 1.1.1.8 software. The are connected via SFP+/fiber on port 50. They can see eachother advertising LLDP.

(switch01) #show lldp remote-device all | include 0/50

0/50 1 60:EB:69:A9:21:BA 0/50 << MAC OF SWITCH 2


(switch02) #show lldp remote-device all | include 0/50

0/50 1 00:23:8B:03:85:52 0/50 << MAC OF SWITCH 1


These addresses match the opposing switches info in `show hardware`.

I have this configuration on each switch:

vlan database
vlan 100-101,600-602
vlan name 100 "MGMT"
vlan name 101 "PROD1"
vlan name 600 "EXT_1"
vlan name 601 "EXT_2"
vlan name 602 "EXT_3"
exit

...


interface 0/50
vlan participation include 100-101,600-602
vlan tagging 100-101,600-602
exit


I have ports configured on VLAN100 on each switch (0/40-0/48), and they seem to be communicating ON the switch, but not trunking between the switches.


interface 0/40-0/48
vlan pvid 100
vlan participation include 100
exit



What am I missing?


(switch01) #show port 0/50

Admin Physical Physical Link Link LACP Actor Soft-Shut
Intf Type Mode Mode Status Status Trap Mode Timeout Mode
--------- ------ --------- ---------- ---------- ------ ------- ------ -------- ---------
0/50 Enable 10G Full 10G Full Up Enable Enable long Disable
 

ttabbal

Active Member
Mar 10, 2016
752
207
43
47
Has anyone gotten inter-VLAN routing working on these things? I'm just wondering if it's worth the bother to install the routing firmware.
 

ttabbal

Active Member
Mar 10, 2016
752
207
43
47
So, has anyone figured out a way to REMOVE a port from VLAN tagging? I had to reset the config to fix it after inadvertently tagging a port for VLAN 1. The GUI would let me ask it to set it to "untagged", but it didn't work. The CLI "vlan tagging" command seems to only add tags, not remove them. I don't recall if I tried to delete the VLAN config entirely. I know it won't let me tag a VLAN that doesn't exist in the database, which makes sense.
 

MMarco

New Member
Jun 13, 2017
2
0
1
30
Hi, all.
Let me start with this: I'm completely new to this world, and I'm really confused. At work, we bought a Quanta LB4M with two 10Gbps ports and 48 1Gbps ports.
I was able to connect the switch to our network and connect via telnet (and later, after enabling it, via SSH). However, I'm unable to connect or enable the web interface, but I think that our firmware version doesn't have it. That's not so important. All I want to do is connect some computers to the switch and get all the advertised speed.

Right now, I'm able to connect a computer to the switch using a 1Gbps port and that computer gets internet access. However, the speed is only 100Mbps. How can I get a gigabit connection to the switch?

I tried to use the command "speed all" command, but I only get "10" or "100" as options.

Thanks a lot in advance for your help.
 

MMarco

New Member
Jun 13, 2017
2
0
1
30
Update:
Ok, I'm very unlucky: both the cables I tried were faulty. When using a brand new ethernet cable the speed was 1000 as expected.
 

Impire

New Member
Nov 13, 2016
16
0
1
57
Hello,

Can I use this switch as a router? I would like to route internal vlan to external vlan. Will that be possible to do with the LB6M?

Thank you in advance for your help.
 

Impire

New Member
Nov 13, 2016
16
0
1
57
Hello,

On one of my switches, I can see the console display during the boot up. But whatever key pressed does not get any response. I've tried different cables, same issue. Also tried different baud rate setting on Putty, no response.

Also, I have another switch which I would like to set the baud rate to 115200. What is the command to set the baud rate?

Any suggestion is greatly appreciated.
 

Impire

New Member
Nov 13, 2016
16
0
1
57
I have browse through the forum but could not find clear information on how to get the WEB GUI interface to work on the LB4M.

I have firmware 1.1.0.8.

ip http server command does not work.

Any help would be much appreciated.
 

Foray

Member
May 22, 2016
59
30
18
I have browse through the forum but could not find clear information on how to get the WEB GUI interface to work on the LB4M.

I have firmware 1.1.0.8.

ip http server command does not work.

Any help would be much appreciated.

Web gui only works on 1.0.x.x firmware.
 

Regis

New Member
Jul 29, 2017
3
0
1
43
Just to clarify, yes intervlan works rather easilly once you get a copy of the routing firmware for this switch.

Follow this tutorial [routing firmware included in this guys tutorial].

Here is a copy of my running config:


(Routing) #write me
This operation may take a few minutes.
Management interfaces will not be available during this time.
Are you sure you want to save? (y/n) y
Configuration Saved!
(Routing) #
(Routing) #show run
!Current Configuration:
!
!System Description "FASTPATH Routing"
!System Software Version "5.13.12.14"
!System Up Time "7 days 19 hrs 32 mins 37 secs"
!Additional Packages FASTPATH QOS,FASTPATH Multicast
!Current SNTP Synchronized Time: AUG 06 12:49:28 201 UTC
!
serviceport protocol none
serviceport ip 192.168.255.1 255.255.255.252 192.168.255.2
network parms 192.168.255.5 255.255.255.252 192.168.255.6
vlan database
vlan 200,254-255,300
vlan name 200 "wired user"
vlan name 300 "wlan user"
vlan name 254 "servers"
vlan name 255 "egress wan"
vlan routing 255
vlan routing 300
vlan routing 200
vlan routing 254
exit
no ip http java
ip http secure-server
ip ssh server enable
ip ssh protocol 2
no ip telnet server enable
configure
snmp-server sysname "asteria"
snmp-server location "laundry-room-tr"
!
sntp client mode unicast
! sntp server status is active
sntp server 172.16.255.1
no ip domain lookup
ip domain name xxxxxxxxx.net
ip routing
ip route 0.0.0.0 0.0.0.0 172.16.255.1
bootpdhcprelay enable
bootpdhcprelay serverip 172.16.2.253
users passwd "admin" encrypted 974b0f3f6f87a812129529.........
lineconfig
no transport input telnet
exit
spanning-tree configuration name "60-EB-69-A9-14-A9"
spanning-tree forceversion 802.1w
port-channel apollo-nas
no port-channel linktrap 3/1
interface 0/3
addport 3/1
exit
interface 0/4
addport 3/1
exit
interface 0/1
no shutdown
spanning-tree edgeport
vlan pvid 255
vlan participation exclude 1
vlan participation include 255
vlan tagging 255
ip irdp
exit
interface 0/2
no shutdown
spanning-tree edgeport
vlan pvid 200
vlan participation exclude 1
vlan participation include 200,254
vlan tagging 200
exit
interface 0/3
no shutdown
lacp actor admin key 54
exit
interface 0/4
no shutdown
lacp actor admin key 54
exit
interface 0/5
no shutdown
spanning-tree edgeport
vlan pvid 300
vlan participation exclude 1
vlan participation include 300
exit
interface 0/6
no shutdown
spanning-tree edgeport
vlan pvid 200
vlan participation exclude 1
vlan participation include 200,300
exit
interface 0/7
no shutdown
spanning-tree edgeport
vlan pvid 254
vlan participation exclude 1
vlan participation include 254
vlan tagging 254
exit
interface 0/10
no shutdown
spanning-tree edgeport
vlan pvid 200
vlan participation exclude 1
vlan participation include 200
exit
interface 3/1
no shutdown
port-channel static
no snmp trap link-status
spanning-tree edgeport
no spanning-tree port mode
vlan pvid 200
vlan participation exclude 1
vlan participation include 200
lacp collector max-delay 0
exit
interface 4/1
no shutdown
routing
ip address 172.16.255.2 255.255.255.252
exit
interface 4/2
no shutdown
bandwidth 10000
routing
ip address 172.16.3.1 255.255.255.0
ip irdp
ip mtu 1500
exit
interface 4/3
no shutdown
bandwidth 10000
routing
ip address 172.16.2.1 255.255.255.0
ip irdp
ip mtu 1500
exit
interface 4/4
no shutdown
bandwidth 10000
routing
ip address 172.16.254.1 255.255.255.0
ip irdp
ip mtu 1500
exit
router rip
no enable
exit
router ospf
no enable
exit
exit
!!!!!!!!


Many of the folks here complain about the GUI, but its not too bad. Most places actually have the webgui on switches and routers disabled to minimize attack surface. The gui on this firmware "gets you to where you need to go" so to speak.

This configuration uses 4 vlans (2 user vlans, 1 server/admin vlan, 1 /30 Point-to-point vlan), 1 port channel (0/3 and 0/4), NTP, inter vlan routing, basic RSTP, DHCP relay, and i'm working on SNMP now. My only complaint is that there is no NAT on this switch. I use Windows Server 2016 standard for DNS and DHCP. Don't try to use the dhcp server on this switch. I could not get it to work.

On port 2, I have a trunk link connected to a 1Gb port on my ESXi server. The vswitch configured there handles the tagging, so hosts [ethernet adapters] that I assign to that vswitch join vlan 200 seamlessly.

As for BGP, this switch appears not to have that functionality as far as i can tell.
 
Last edited:

NYCone

Member
Jun 23, 2017
36
8
8
61
I recently bought a Quanta LB4M and an LB8. Everything is going well, except I can't seem to get a proper port-channel up between them. I have 1.0.3.2 firmware on the LB4M and 1.2.0.14 on the LB8.

I've tried dynamic in either direction, static, and I've tried using the web interface on the LB4M. I can get a stable static link, but when I do, I get poor internet performance. In the end, I just reset both configs and I don't have a aggregated link. I'm very new to switch software, so any advice is welcome, assume I know almost nothing.
 

Foray

Member
May 22, 2016
59
30
18
I recently bought a Quanta LB4M and an LB8. Everything is going well, except I can't seem to get a proper port-channel up between them. I have 1.0.3.2 firmware on the LB4M and 1.2.0.14 on the LB8.

I've tried dynamic in either direction, static, and I've tried using the web interface on the LB4M. I can get a stable static link, but when I do, I get poor internet performance. In the end, I just reset both configs and I don't have a aggregated link. I'm very new to switch software, so any advice is welcome, assume I know almost nothing.
1.0.3.2 is nothing but problems, revert to 1.0.2.17 or upgrade to 1.1.1.8(no gui). Also, the LB8 is limited in how many dynamic port-channels can be created.
 

NYCone

Member
Jun 23, 2017
36
8
8
61
1.0.3.2 is nothing but problems, revert to 1.0.2.17 or upgrade to 1.1.1.8(no gui). Also, the LB8 is limited in how many dynamic port-channels can be created.

That's easy enough to do. I finally got a static Port-Channel up between the two. The issue was as simple as restarting both once the channel was made. Now all works as it should.

Separately, a shout out to the equipment. Both the LB8 and the LB4m are steals for what you get. I paid $60 for the LB4M delivered with 2 PSs and $320 for the LB8. I'd buy them again if I needed another switch.
 

Foray

Member
May 22, 2016
59
30
18
Separately, a shout out to the equipment. Both the LB8 and the LB4m are steals for what you get. I paid $60 for the LB4M delivered with 2 PSs and $320 for the LB8. I'd buy them again if I needed another switch.
Until you try to do more than 6 dynamic LAGs on the LB8. Then it yells at you and says no.
 

moroz

New Member
Oct 11, 2017
1
0
1
38
Hello!
My network consists of LB6M with servers connected to it with 10Gbps link speeds; two LB4Ms and one Mikrotik 326-24G-2S+RM trunks connected to LB6M via star-like topology.
I have a problem with LB4M switches. Clients, which are connected to LB4M (but not Mikrotik) with 1 Gbps links have poor download speeds from 10 Gbps servers on LB6M (300-400 Mbps with 802.3x enabled, 10-20 Mbps with 802.3x disabled). 1 Gbps to 10 Gbps upload speeds are full ~990Mbps. All tests were done within one VLAN with identical MTU with iperf. NFS performance is even worse then 300 Mbps, speeds are very erratic.
This problem occurs only with clients on LB4M, both LB6M and Mikrotik gigabit ports work great.

My partial LB4M config:
!Current Configuration:
!
!System Description "FASTPATH Switching"
!System Software Version "1.0.2.17"
!System Up Time "64 days 14 hrs 22 mins 32 secs"
!Additional Packages FASTPATH QOS
!Current SNTP Synchronized Time: Not Synchronized
!
network protocol none
serviceport ip 192.168.40.30 255.255.255.0 192.168.40.1
vlan database
vlan 37-46
exit
ip ssh server enable
sshcon maxsessions 2
sshcon timeout 60
no ip telnet server enable
configure
!
sntp server 192.168.40.5
sntp server 192.168.43.5
users passwd "admin" encrypted xxx
lineconfig
exit

--More-- or (q)uit

storm-control flowcontrol
spanning-tree configuration name "60-EB-69-3E-B1-6C"
snmp-server community "off1swpublic"
interface 0/1
mtu 9216
vlan pvid 42
vlan participation exclude 1
vlan participation include 42
exit

.....

interface 0/44
mtu 9216
vlan pvid 42
vlan participation exclude 1
vlan participation include 42
exit

--More-- or (q)uit

interface 0/45
vlan pvid 43
vlan participation exclude 1
vlan participation include 43
exit
interface 0/46
vlan pvid 43
vlan participation exclude 1
vlan participation include 43
exit
interface 0/47
vlan pvid 46
vlan participation exclude 1
vlan participation include 46
exit
interface 0/48
vlan pvid 40
vlan participation exclude 1
vlan participation include 40
exit
interface 0/49
mtu 9216
vlan participation include 37-46
vlan tagging 37-46

--More-- or (q)uit[

exit
interface 0/50
mtu 9216
vlan participation include 37-46
vlan tagging 37-46
exit
exit

Any ideas?

Thanks