Monero XMR Mining on 64 core AMD EPYC

LuckyX2

New Member
Aug 15, 2019
2
0
1
Patrick, I think I found why it still says small pages for you in your test. The flag is
"--largePages", capital P. Easy to miss that. Hope that helps improve your result if you find the time to re-run.
 

jims2321

Active Member
Jul 7, 2013
185
44
28
On the current Monero algo my Ryzen 3700x mines at ~952 H/s on all 16 threads with Xmrig 3.0.0. in Windows 10.

Xmrig 3.0 crashes mining RandomX on both Windows 10 and Ubuntu 18.04.2 still, hard crash that resets the pc.

So i'm running the old algo just to test to see if its a issue with xmrig 3.0 or xmrig 3.0 and randomx.

HWMonitor shows ~60 w and 44c cpu temp.

Definitely the Ryzen runs MUCH cooler than the dual Xeon box, putting my hand on the rear fan exhaust fan it is barely warm.

I think for cpu mining the the Ryzen cpu's are the best option as far as price/performance/power usage.
I have been running xmrig 3.0.0 on my Dell R815 for a 3 days mining cn/r algorithm with no issues. I have also started it up running rx/loki this morning to see if I run into the issue with randomx. So far it seems to be solid and functioning.

* ABOUT XMRig/3.0.0 gcc/7.4.0
* LIBS libuv/1.18.0 OpenSSL/1.1.1 hwloc/1.11.9
* CPU AMD Opteron(tm) Processor 6378 (4) x64 AES
L2:64.0 MB L3:48.0 MB 64C/64T NUMA:8
* DONATE 1%
* ASSEMBLY auto:bulldozer
* POOL #1 donate.v2.xmrig.com:3333 algo rx/loki
* COMMANDS hashrate, pause, resume

[2019-08-16 14:25:55.160] speed 10s/60s/15m 7476.9 n/a n/a H/s max 7480.0 H/s
[2019-08-16 14:26:15.773] accepted (1/0) diff 1000225 (126 ms)
[2019-08-16 14:26:33.438] new job from donate.v2.xmrig.com:3333 diff 1000225 algo rx/loki height 337874
[2019-08-16 14:26:55.211] speed 10s/60s/15m 7476.4 7474.9 n/a H/s max 7483.3 H/s
 

Klee

Well-Known Member
Jun 2, 2016
1,285
393
83
I have been running xmrig 3.0.0 on my Dell R815 for a 3 days mining cn/r algorithm with no issues. I have also started it up running rx/loki this morning to see if I run into the issue with randomx. So far it seems to be solid and functioning.

* ABOUT XMRig/3.0.0 gcc/7.4.0
* LIBS libuv/1.18.0 OpenSSL/1.1.1 hwloc/1.11.9
* CPU AMD Opteron(tm) Processor 6378 (4) x64 AES
L2:64.0 MB L3:48.0 MB 64C/64T NUMA:8
* DONATE 1%
* ASSEMBLY auto:bulldozer
* POOL #1 donate.v2.xmrig.com:3333 algo rx/loki
* COMMANDS hashrate, pause, resume

[2019-08-16 14:25:55.160] speed 10s/60s/15m 7476.9 n/a n/a H/s max 7480.0 H/s
[2019-08-16 14:26:15.773] accepted (1/0) diff 1000225 (126 ms)
[2019-08-16 14:26:33.438] new job from donate.v2.xmrig.com:3333 diff 1000225 algo rx/loki height 337874
[2019-08-16 14:26:55.211] speed 10s/60s/15m 7476.4 7474.9 n/a H/s max 7483.3 H/s

It runs fine on my Xeon boxes but even mining on the old algo with 3.0 crashes after about 4 or five hours on my 3700x.
 

jims2321

Active Member
Jul 7, 2013
185
44
28
It runs fine on my Xeon boxes but even mining on the old algo with 3.0 crashes after about 4 or five hours on my 3700x.
let me install it on my 3900X and see if I have the same issue.

Installed it and built the binaries, and hard lock like you experienced. Interesting.

[2019-08-16 10:14:26.323] ./xmrig1: unsupported non-option argument '80'
* ABOUT XMRig/3.0.0 gcc/7.4.0
* LIBS libuv/1.18.0 OpenSSL/1.1.1 hwloc/1.11.9
* CPU AMD Ryzen 9 3900X 12-Core Processor (1) x64 AES
L2:6.0 MB L3:64.0 MB 12C/24T NUMA:1
* DONATE 1%
* ASSEMBLY auto:ryzen
* POOL #1 donate.v2.xmrig.com:3333 algo rx/loki
* COMMANDS hashrate, pause, resume
[2019-08-16 10:14:26.561] use pool donate.v2.xmrig.com:3333 185.92.222.223
[2019-08-16 10:14:26.561] new job from donate.v2.xmrig.com:3333 diff 1000225 algo rx/loki height 337896
[2019-08-16 10:14:26.562] rx init dataset algo rx/loki (24 threads) seed b57d3b678cce6553...
[2019-08-16 10:14:26.562] cpu use profile rx (24 threads) scratchpad 2048 KB
[2019-08-16 10:14:26.562] rx #0 allocate 2336 MB (2080+256) for RandomX dataset & cache
[2019-08-16 10:14:26.711] rx #0 allocate done huge pages 1168/1168 100% +JIT (150 ms)
[2019-08-16 10:14:26.716] cpu READY threads 24(24) huge pages 24/24 100% memory 49152 KB (155 ms)
[2019-08-16 10:14:28.469] rx #0 init done (1907 ms)
 
Last edited:

jims2321

Active Member
Jul 7, 2013
185
44
28
okay heard back from the developer after opening a ticket on github. remove one parameter from my execution line (--max-cpu-usage) and lockup issue resolved.


miner@ryzensvr:~$ ./xmrig1 --algo=rx/loki --donate-level 1 -o donate.v2.xmrig.com:3333 -u 4ADFnuC1kDQGtkncbETsHnTt7qmQFvwjUMn7Awvh3GAZMRuSaGqTo2j9K2wW4qjpMEQCDPzJmhr2cXEKJqUe9uJvBrdeD3o -p dellr815:talino23211@gmail.com -k
* ABOUT XMRig/3.0.0 gcc/7.4.0
* LIBS libuv/1.18.0 OpenSSL/1.1.1 hwloc/1.11.9
* CPU AMD Ryzen 9 3900X 12-Core Processor (1) x64 AES
L2:6.0 MB L3:64.0 MB 12C/24T NUMA:1
* DONATE 1%
* ASSEMBLY auto:ryzen
* POOL #1 donate.v2.xmrig.com:3333 algo rx/loki
* COMMANDS hashrate, pause, resume
[2019-08-16 11:10:42.736] use pool donate.v2.xmrig.com:3333 159.89.38.204
[2019-08-16 11:10:42.736] new job from donate.v2.xmrig.com:3333 diff 1000225 algo rx/loki height 337928
[2019-08-16 11:10:42.736] rx init dataset algo rx/loki (24 threads) seed b57d3b678cce6553...
[2019-08-16 11:10:42.736] rx #0 allocate 2336 MB (2080+256) for RandomX dataset & cache
[2019-08-16 11:10:42.736] cpu use profile rx (24 threads) scratchpad 2048 KB
[2019-08-16 11:10:42.887] rx #0 allocate done huge pages 1168/1168 100% +JIT (151 ms)
[2019-08-16 11:10:42.902] cpu READY threads 24(24) huge pages 24/24 100% memory 49152 KB (166 ms)
[2019-08-16 11:10:44.623] rx #0 init done (1887 ms)
[2019-08-16 11:11:18.182] accepted (1/0) diff 1000225 (79 ms)
[2019-08-16 11:11:42.773] speed 10s/60s/15m 13275.7 n/a n/a H/s max 13276.8 H/s
[2019-08-16 11:12:42.826] speed 10s/60s/15m 13274.4 13274.5 n/a H/s max 13276.8 H/s
 

Klee

Well-Known Member
Jun 2, 2016
1,285
393
83
okay heard back from the developer after opening a ticket on github. remove one parameter from my execution line (--max-cpu-usage) and lockup issue resolved.


miner@ryzensvr:~$ ./xmrig1 --algo=rx/loki --donate-level 1 -o donate.v2.xmrig.com:3333 -u 4ADFnuC1kDQGtkncbETsHnTt7qmQFvwjUMn7Awvh3GAZMRuSaGqTo2j9K2wW4qjpMEQCDPzJmhr2cXEKJqUe9uJvBrdeD3o -p dellr815:talino23211@gmail.com -k
* ABOUT XMRig/3.0.0 gcc/7.4.0
* LIBS libuv/1.18.0 OpenSSL/1.1.1 hwloc/1.11.9
* CPU AMD Ryzen 9 3900X 12-Core Processor (1) x64 AES
L2:6.0 MB L3:64.0 MB 12C/24T NUMA:1
* DONATE 1%
* ASSEMBLY auto:ryzen
* POOL #1 donate.v2.xmrig.com:3333 algo rx/loki
* COMMANDS hashrate, pause, resume
[2019-08-16 11:10:42.736] use pool donate.v2.xmrig.com:3333 159.89.38.204
[2019-08-16 11:10:42.736] new job from donate.v2.xmrig.com:3333 diff 1000225 algo rx/loki height 337928
[2019-08-16 11:10:42.736] rx init dataset algo rx/loki (24 threads) seed b57d3b678cce6553...
[2019-08-16 11:10:42.736] rx #0 allocate 2336 MB (2080+256) for RandomX dataset & cache
[2019-08-16 11:10:42.736] cpu use profile rx (24 threads) scratchpad 2048 KB
[2019-08-16 11:10:42.887] rx #0 allocate done huge pages 1168/1168 100% +JIT (151 ms)
[2019-08-16 11:10:42.902] cpu READY threads 24(24) huge pages 24/24 100% memory 49152 KB (166 ms)
[2019-08-16 11:10:44.623] rx #0 init done (1887 ms)
[2019-08-16 11:11:18.182] accepted (1/0) diff 1000225 (79 ms)
[2019-08-16 11:11:42.773] speed 10s/60s/15m 13275.7 n/a n/a H/s max 13276.8 H/s
[2019-08-16 11:12:42.826] speed 10s/60s/15m 13274.4 13274.5 n/a H/s max 13276.8 H/s
the first time or two I compiled it and had the crash problem, tried the binarys and the same so I have been using the binarys only since then.

I'm not using the command line to start xmrig, i'm using the config.json .

I start zmrig without configuring the config.json file and let it configure itself as far as cpu and whatnot, then stop it and exit then configure it with the algo, user, pool and other needed info.

Code:
{
    "api": {
        "id": null,
        "worker-id": null
    },
    "http": {
        "enabled": false,
        "host": "127.0.0.1",
        "port": 0,
        "access-token": null,
        "restricted": true
    },
    "autosave": true,
    "background": false,
    "colors": true,
    "randomx": {
        "init": -1,
        "numa": true
    },
    "cpu": {
        "enabled": true,
        "huge-pages": true,
        "hw-aes": null,
        "priority": null,
        "asm": true,
        "cn": [
            0,
            8,
            1,
            9,
            2,
            10,
            3,
            11,
            4,
            12,
            5,
            13,
            6,
            14,
            7,
            15
        ],
        "cn-heavy": [
            0,
            1,
            2,
            3,
            4,
            5,
            6,
            7
        ],
        "cn-lite": [
            0,
            8,
            1,
            9,
            2,
            10,
            3,
            11,
            4,
            12,
            5,
            13,
            6,
            14,
            7,
            15
        ],
        "cn-pico": [
            0,
            8,
            1,
            9,
            2,
            10,
            3,
            11,
            4,
            12,
            5,
            13,
            6,
            14,
            7,
            15
        ],
        "cn/gpu": [
            0,
            8,
            1,
            9,
            2,
            10,
            3,
            11,
            4,
            12,
            5,
            13,
            6,
            14,
            7,
            15
        ],
        "rx": [
            0,
            8,
            1,
            9,
            2,
            10,
            3,
            11,
            4,
            12,
            5,
            13,
            6,
            14,
            7,
            15
        ],
        "rx/wow": [
            0,
            8,
            1,
            9,
            2,
            10,
            3,
            11,
            4,
            12,
            5,
            13,
            6,
            14,
            7,
            15
        ],
        "cn/0": false,
        "cn-lite/0": false
    },
    "donate-level": 1,
    "donate-over-proxy": 1,
    "log-file": null,
    "pools": [
        {
            "algo": "rx",
            "url": "pools.txchange.online:4444",
            "user": "wallet addy",
            "pass": "x",
            "rig-id": null,
            "nicehash": false,
            "keepalive": false,
            "enabled": true,
            "tls": false,
            "tls-fingerprint": null,
            "daemon": false
        }
    ],
    "print-time": 20,
    "retries": 5,
    "retry-pause": 5,
    "syslog": false,
    "user-agent": null,
    "watch": true
}
 

jims2321

Active Member
Jul 7, 2013
185
44
28
How did you get it to generate the config.json file initial. I get the following error when I run xmrig

miner@ryzensvr:~/xmrig/build$ ./xmrig
[2019-08-16 15:19:57.748] unable to open "/home/miner/xmrig/build/config.json".
[2019-08-16 15:19:57.748] No valid configuration found. Exiting.
 

Klee

Well-Known Member
Jun 2, 2016
1,285
393
83
How did you get it to generate the config.json file initial. I get the following error when I run xmrig

miner@ryzensvr:~/xmrig/build$ ./xmrig
[2019-08-16 15:19:57.748] unable to open "/home/miner/xmrig/build/config.json".
[2019-08-16 15:19:57.748] No valid configuration found. Exiting.

A basic one is in the /xmrig-3.0/src folder.

I just copied it to the/build folder then ran xmrig and let it run and error out, it will error out because you need to manually configure the coin to be mined, pool and user info. It configures the threads automatically.

Here is the config.jason file from the src folder.

Code:
{
    "api": {
        "id": null,
        "worker-id": null
    },
    "http": {
        "enabled": false,
        "host": "127.0.0.1",
        "port": 0,
        "access-token": null,
        "restricted": true
    },
    "autosave": true,
    "background": false,
    "colors": true,
    "randomx": {
        "init": -1,
        "numa": true
    },
    "cpu": {
        "enabled": true,
        "huge-pages": true,
        "hw-aes": null,
        "priority": null,
        "asm": true,
        "cn/0": false,
        "cn-lite/0": false
    },
    "donate-level": 5,
    "donate-over-proxy": 1,
    "log-file": null,
    "pools": [
        {
            "algo": null,
            "url": "donate.v2.xmrig.com:3333",
            "user": "YOUR_WALLET_ADDRESS",
            "pass": "x",
            "rig-id": null,
            "nicehash": false,
            "keepalive": false,
            "enabled": true,
            "tls": false,
            "tls-fingerprint": null,
            "daemon": false
        }
    ],
    "print-time": 60,
    "retries": 5,
    "retry-pause": 5,
    "syslog": false,
    "user-agent": null,
    "watch": true
}
 
Last edited:

Klee

Well-Known Member
Jun 2, 2016
1,285
393
83
Well I just turned "Game Boost" off in the bios of my MSI x570 board.

Game Boost sets all core speed to baseclock plus 450 mhz and turns cool and quiet off according to the manual.

Base clock is 3.6 Ghz so with Game Boost it runs all core speed at a set 4.05 Ghz, actually its varies from 4.03 to 4.05 ghz.

I turned it on thinking I would get best performance, I was wrong.

After I turned Game Boost off and let the cpu do its thing the boosts on some cores is 4.1 ghz and others up to 4.375 ghz and mining Monero now I get ~1000 H/s. And a average of 4.1 on all cores at about 85 watts according to HWmonitor.

EDIT: After running Xmrig on the old algo all night without issue maybe the issue is with the Game B oost being turned on.....more testing tho. Also changed to mining Loki now to test. Just compiled xmrig 3.0 on ubuntu 18.04.2 and see if that is more stable.
 
Last edited: