How to use OCZ rev350 as ZIL & Cache

EluRex

Active Member
Apr 28, 2015
216
76
28
Los Angeles, CA
I am facing a problem about kernel module loading order.

I am using Proxmox VE 4.1 (Debian 8.1) and root on ZFS mode. I have a OCZ Rev350 NVMe PCIe SSD need to configure as ZIL and cache. However OCZ NVMe has its module called oczpcie and it loads after ZFS module is loaded, so therefore, everytime system reboot, it will failed to load can complained that the system cannot find ZIL.

Code:
    9.945469] zavl: module license 'CDDL' taints kernel.
[    9.945473] Disabling lock debugging due to kernel taint
[    9.948241] SPL: Loaded module v0.6.5.3-349_ga431cee
[   10.003202] ZFS: Loaded module v0.6.5.3-1, ZFS pool version 5000, ZFS filesystem version 5
[   10.618005] SPL: using hostid 0xa8c02302
[   12.828691] systemd-sysv-generator[1624]: Ignoring creation of an alias umountiscsi.service for itself
[   13.250078] systemd[1]: Cannot add dependency job for unit display-manager.service, ignoring: Unit display-manager.service failed to load: No such f
ile or directory.
.....
[   13.827476] ipmi_si: Trying ACPI-specified kcs state machine at i/o address 0xca2, slave address 0x0, irq 0
[   13.840425] oczpcie 0000:0a:00.0: oczpcie: driver version v4.2.823
[   13.856317] oczpcie 0000:0a:00.0: oczpcie: PCI-E x8, Bandwidth Usage: 2.5 Gbps
[   13.895934] input: PC Speaker as /devices/platform/pcspkr/input/input6
.....
[   16.724029] floppy0: no floppy controllers found
[   19.104016] oczpcie 0000:0a:00.0: Model OCZ-REVODRIVE350, firmware revision 2.50
[   19.462569]  oczpcie_10_0_ssd: oczpcie_10_0_ssd1 oczpcie_10_0_ssd2
I checked dmesg and found out that oczpcie loads after ZFS module. How do I force it to load before ZFS?

use Ubuntu Manpage: modules.dep — List of module dependencies modules.dep?
 
Last edited: