how do you turn off pci nic oprom during boot on asrock rack

jpmomo

Active Member
Aug 12, 2018
451
144
43
Most MBs have a way of shutting off the boot from nic option in the bios. I haven't been able to find that option with some new asrock rack MBs. I went through most of the bios and still could not find a way to turn it off. It cycle through all of the pci nics with the flex boot configuration prompt. When it is finished with all of the nics, it will then finally boot off of the m.2 drive. I would like it to skip past all of the nics and just boot off of the m.2 drive.
thanks for any suggestions,
jp
 

sboesch

Active Member
Aug 3, 2012
467
93
28
Columbus, OH
If booting uefi, remove the boot option from the eufi boot settings menu, then change your boot order to the uefi operating system volume.
 

jpmomo

Active Member
Aug 12, 2018
451
144
43
thanks but I did that but it still keeps cycling through the flex boot options for all of the NICs. I removed all of the boot options except the m.2 drive for vmware. With most motherboards, there is a oprom option that you can disable to not try to boot from the pci slots. the recent asrockrack MBs don't seem to have that.
 

jpmomo

Active Member
Aug 12, 2018
451
144
43
I figured it out and wanted to update anyone that might have the same question. they put it under the "CSM" settings in the bios. this seems to be a mistake that probably should be fixed in any new version of the bios.