Chenbro RM23712 PSU Issues

Fablos

New Member
Jan 16, 2021
1
0
1
Hey there - So I'm working on this issue for a week now... (I hope this is the matching Subforum)

I bought a Chenbro RM23712 with a Redundand PSU Cage but no Modules in it half a year ago.
A week later, I got a pair of Intel DPS-750XB's and tried it with a MSI Z87 Mpower-SP and a Core i5 4460 which worked with no apparent issues.

Now, months later, I bought a Supermicro X9SCL+-F for this Chassis to use as a Storage Server.
But the Board seemed to be DOA: No POST, No Beep Codes, nothing. Even with no RAM installed, so I returned that Board.

After that, I got an ASUS P8B-M - And to my surprise it behaved in the Exact same way, so it got apparent to me, it cant be the Board here and tried the Board with a normal Desktop PSU and - It worked with no issue.

First thought -> Dead PSU in the Chenbro... But then - I tried the P8Z77-V LX2 with the Chenbro Chasis and... It worked for some reason. After that I tried the MSI one again, but this time it showed the same issue like the other Boards (No POST, not even POST LED Working).

Now I bought a Multimeter to check on the PSUs... And to my Surprise - The Corsair CX750 and the Chenbro PSU (a FSP800-50ERS Cage) were in margin of Error of the ATX Standard... At this point I start to freak out.


Have you seen similar issues?
Do I need to get the original PSU Modules (Which are waaaaaaaay out of my Price range no matter what)?
Any other Cheap PSU Modules I could buy?
Can I replace the Cage with a normal single 2U PSU somehow?
Anything else I could try here? I really want to keep the Chassis...