Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

rgunner

New Member
Apr 29, 2019
5
3
3
Wanted to say thanks fohdeesha for all of the time and info. Pulled the trigger on the 7250-24P which got here Friday, now just waiting for my console cable to arrive so I can update the firmware to v8080 and swap out the Quanta LB6M and the Cisco WS-C3750E-48TD. :D
 
  • Like
Reactions: fohdeesha

Hakujou

New Member
Apr 28, 2019
19
6
3
Hello,

Long time lurker here, I finally got an ICX6610 thanks to @fohdeesha !

I got it from g-electronics on ebay, like some people here, and I've issues with the 40Gbps breakout ports. It does seem to be the exact same issue as @N1h1l1ty on page 50 of this topic, as I have those messages on console at boot:
Code:
Parsing Config Data ...
------------------------------------------------------------------
M:9 L:0 - chow_qsfp_read, qsfp 3, error in seting up mux
------------------------------------------------------------------
M:9 L:0 - link_40G_4x10G_get_media: qsfp 3, port 1/2/7 error in reading qsfp
chow_40G_4x10G_get_media: error in reading qsfp 1/2/7
It was working for one of my servers (ESXi) but I could not make a second port work, even from the other QSFP port. Tested with two cables (some Cisco generic on eBay and a Brocade one from FiberStore), same result. All firmwares (bootloader, firmware and PoE firmware) are up-to-date.

Now with the exact same NIC (HP NC530SFP+) on an other server (FreeNAS), it doesn't work at all. It appears up on the interfaces brief, but goes down as soon as I tag it with a VLAN for some reason. It also goes up and down randomly without any vlan tagged (but traffic does not flows anyway, even when switch says it's up).

So I guess my QSFP module is broken ?
Honestly I don't think I'll ever need more than 8 SFP+ ports (all licensed, again thanks to @fohdeesha), but it's kind of a bummer to see it broken. I don't really want to send the switch back as everything is now cabled and I live in France, so shipping to USA would be really tedious.

Is the module replaceable easily ? Is there a way to purchase it alone for cheap ?
Or am I missing something obvious ?

Thanks a lot
 

Thorzeen

New Member
Jun 15, 2018
18
7
3
Hi Hakujou and welcome. People in this thread me included have had a less then stellar experience with g-electronics as posted a couple of pages back. I am sorry to hear your having problems. I would at the very lease contact them (g-electronics) and try to receive a partial refund. Seems that people have reached out and received that. I simply sent mine back ( i am in US) and will no longer give them any of my business
 

Dreece

int 21h
Quick question, the 6450-24P, if I pull the power, and then pop the plug back in, it doesn't fire up. I wait a few minutes and I hear a 'click' sound from the PSU region of the switch, and then I pop the power plug back in and it starts up. Is this some kind of feature or is this a sign of a failing PSU?
 
Last edited:

Hakujou

New Member
Apr 28, 2019
19
6
3
I discussed with g-electronic as recommended by @Thorzeen, they issued a full refund and I don't even have to send it back.
Their units might not be reliable, but they have an awesome customer service!
 
  • Like
Reactions: fohdeesha

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
Quick question, the 6450-24P, if I pull the power, and then pop the plug back in, it doesn't fire up. I wait a few minutes and I hear a 'click' sound from the PSU region of the switch, and then I pop the power plug back in and it starts up. Is this some kind of feature or is this a sign of a failing PSU?
do you just spend all day coming up with absurd ways to try and cause issues with equipment? leave it alone, its fine
 

Kryax

Member
Oct 14, 2017
44
1
8
Hello,

Long time lurker here, I finally got an ICX6610 thanks to @fohdeesha !

I got it from g-electronics on ebay, like some people here, and I've issues with the 40Gbps breakout ports. It does seem to be the exact same issue as @N1h1l1ty on page 50 of this topic, as I have those messages on console at boot:
Code:
Parsing Config Data ...
------------------------------------------------------------------
M:9 L:0 - chow_qsfp_read, qsfp 3, error in seting up mux
------------------------------------------------------------------
M:9 L:0 - link_40G_4x10G_get_media: qsfp 3, port 1/2/7 error in reading qsfp
chow_40G_4x10G_get_media: error in reading qsfp 1/2/7
It was working for one of my servers (ESXi) but I could not make a second port work, even from the other QSFP port. Tested with two cables (some Cisco generic on eBay and a Brocade one from FiberStore), same result. All firmwares (bootloader, firmware and PoE firmware) are up-to-date.

Now with the exact same NIC (HP NC530SFP+) on an other server (FreeNAS), it doesn't work at all. It appears up on the interfaces brief, but goes down as soon as I tag it with a VLAN for some reason. It also goes up and down randomly without any vlan tagged (but traffic does not flows anyway, even when switch says it's up).

So I guess my QSFP module is broken ?
Honestly I don't think I'll ever need more than 8 SFP+ ports (all licensed, again thanks to @fohdeesha), but it's kind of a bummer to see it broken. I don't really want to send the switch back as everything is now cabled and I live in France, so shipping to USA would be really tedious.

Is the module replaceable easily ? Is there a way to purchase it alone for cheap ?
Or am I missing something obvious ?

Thanks a lot
I think there is confusion surrounding tagging vs untagging a port. This all depends on the device you want to connect to (whether it be a switch, host, or something else like an ESXI vswitch). Typically you untag host ports and tag VLAN's on ports that will be used as trunks. Here are some sample Brocade switch and a Cisco switch configs I came up with to compare similiar outputs. Lets assume you want to configure a few VLAN's and do trunking (not LAG/LACP) to devices that require it. We will also change from the default NATIVE VLAN 1 to VLAN 10:

VLAN 10 = Native VLAN (untagged frames for all ports)(default is normally VLAN 1)(Management IP)
VLAN 20 = DATA
VLAN 30 = WIRELESS
VLAN 40 = UNTRUSTED

Brocade Configuration Output:

Code:
vlan 10 name DEFAULT-VLAN by port
 router-interface ve 10
!
vlan 20 by port
 tagged ethe 1/1/1 ethe 1/3/1
 untagged ethe 1/1/2 ethe 1/1/3
!
vlan 30 by port
 tagged ethe 1/1/1 ethe 1/3/1
 untagged ethe 1/1/4
!
vlan 40 by port
 tagged ethe 1/1/1 ethe 1/3/1
 untagged ethe 1/1/5 to ethe 1/1/24
!
interface ethernet 1/1/1
 port-name TRUNK PORT
!
interface ethernet 1/1/2
 port-name DATA 1
!
interface ethernet 1/1/3
 port-name DATA 2
!
interface ethernet 1/1/4
 port-name WIRELESS 1
!
interface ethernet 1/1/5
 port-name UNTRUSTED
!
...
!
interface ethernet 1/1/24
 port-name UNTRUSTED
!
interface ethernet 1/3/1
 port-name 10GB TRUNK
 speed-duplex 10G-full
!
interface ve 10
 ip address 10.10.10.10 255.255.255.0
Cisco equivalent config with having VLAN 10 changed to Native VLAN
Code:
vlan 10
 name NATIVE VLAN
vlan 20
 name DATA
vlan 30
 name WIRELESS
vlan 40
 name UNTRUSTED
!
interface Gigabit1/1/1
 desc TRUNK PORT
 switchport mode trunk
 switchport trunk native vlan 10
 switchport trunk allowed 10, 20, 30, 40
!
interface Gigabit1/1/2
 description DATA 1
 switchport mode access
 switchport access vlan 20
!
interface Gigabit1/1/3
 description DATA 2
 switchport mode access
 switchport access vlan 20
!
interface Gigabit1/1/4
 description WIRELESS
 switchport mode access
 switchport access vlan 30
!
interface Gigabit1/1/5
 description UNTRUSTED
 switchport mode access
 switchport access vlan 40
!
...
!
interface Gigabit1/1/24
 description UNTRUSTED
 switchport mode access
 switchport access vlan 40
!
interface Gigabit1/3/1
 desc 10GB TRUNK PORT
 switchport mode trunk
 switchport trunk native vlan 10
 switchport trunk allowed 10, 20, 30, 40
!
interface vlan 10
 ip address 10.10.10.10 255.255.255.0
Hopefully this helps people who understand Cisco CLI!
 
Last edited:

Dreece

int 21h
do you just spend all day coming up with absurd ways to try and cause issues with equipment? leave it alone, its fine
I do not understand the context of your reply fohdeesha. It is the first time I've come across a switch that has this behaviour, whence raising the question if it is by design (feature) or a potential issue I should be concerned about.

To be fair, yes I do spend a great amount of time getting to know my equipment, though power-cycling is not by choice, I was in the process of taking the switch from my desk to its permanent location in the rack and that is when I noticed this rather peculiar behaviour.
 

Discountsocks

New Member
Aug 16, 2018
8
7
3
I do not understand the context of your reply fohdeesha. It is the first time I've come across a switch that has this behaviour, whence raising the question if it is by design (feature) or a potential issue I should be concerned about.

To be fair, yes I do spend a great amount of time getting to know my equipment, though power-cycling is not by choice, I was in the process of taking the switch from my desk to its permanent location in the rack and that is when I noticed this rather peculiar behaviour.

Firstly, let me preface this by saying that I am in no way intending to be "that guy", though I often have been told that I come across that way. That being said...

The proper place to ask this questions would be the hardware manufacturer who designed the product. BUT since we all here are frequenting a forum of used gear that we offer each other help supporting and there have been 90 pages of very helpful information mainly provided by fohdeesha, I see his response as valid.

You are quoting an issue that would be highly unlikely to solved by people here, initially without the context you later supplied. It can definitely be read (as I did) that you were looking for issues with the hardware and possibly complaining about it. I will state that with the provided context, I do not read it that way, but can see how someone who has done much research and hacking into the platform, then providing it freely to the community might read it that way (again, as I did)

If you suspect a power supply issue or failure, as stated on the first page of the post, you can supply your own 12 volt DC and do some testing.

Again, I am not intending to come across harshly, this is just a validation of someones response and a suggestion as to a path of troubleshooting your issue with hardware not under vendor support.
 

rgunner

New Member
Apr 29, 2019
5
3
3
@fodeesha thanks again for the guide on the 7250. I got my 24 port up and running today and swapped it in place of my other two switches (hella less noise) :D Unfortunately, it looks like 1/3 of my 24 copper ports are not going to function with PoE....sigh. got it from g-electronic. Sent message asking what the options are. I can make things work for now with some PoE injectors (Cameras and AP's). Other than that I'll probably pick up another one as a backup.

PoE Severe Error: Hardware Fault with ports 1/1/9 to 1/1/16. Remove PDs and then configure "no inline power" on these ports.

ICX7250-24P Router#show inline power
Power Capacity: Total is 370000 mWatts. Current Free is 370000 mWatts.
Power Allocations: Requests Honored 23 times
Port Admin Oper ---Power(mWatts)--- PD Type PD Class Pri Fault/
State State Consumed Allocated Error
--------------------------------------------------------------------------
1/1/1 On Non-PD 0 0 n/a n/a 3 n/a
1/1/2 On Off 0 0 n/a n/a 3 n/a
1/1/3 On Off 0 0 n/a n/a 3 n/a
1/1/4 On Off 0 0 n/a n/a 3 n/a
1/1/5 On Off 0 0 n/a n/a 3 n/a
1/1/6 On Off 0 0 n/a n/a 3 n/a
1/1/7 On Off 0 0 n/a n/a 3 n/a
1/1/8 On Off 0 0 n/a n/a 3 n/a
1/1/9 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/10 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/11 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/12 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/13 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/14 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/15 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/16 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/17 On Off 0 0 n/a n/a 3 n/a
1/1/18 On Off 0 0 n/a n/a 3 n/a
1/1/19 On Off 0 0 n/a n/a 3 n/a
1/1/20 On Off 0 0 n/a n/a 3 n/a
1/1/21 On Off 0 0 n/a n/a 3 n/a
1/1/22 On Off 0 0 n/a n/a 3 n/a
1/1/23 On Off 0 0 n/a n/a 3 n/a
1/1/24 On Off 0 0 n/a n/a 3 n/a
--------------------------------------------------------------------------
Total 0 0
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
so that's 3 faulty g-electronic switches just in the last 3 pages, and 1 more in a PM from someone where one of his 40gbE ports does not work. I'm calling it now, avoid g-electronic unless you really enjoy doing the ebay return dance. that's what, like 9 total bad switches from them now just in the last month?
 

Hakujou

New Member
Apr 28, 2019
19
6
3
Yes it looks like they have some really bad batches, some good offers have popped from other vendors too, I was able to score an ICX6610-48P for 120USD +80 shipping (and 50 for taxes, but that's because I'm in EU).
 

sean

Member
Sep 26, 2013
64
30
18
CT
I got a 6450-48P from them back in August that worked fine. It however came from Brocade's lab and it now appears I got pretty lucky.
 

rgunner

New Member
Apr 29, 2019
5
3
3
Quick question....is the noise level on the 6610 that much louder than the 7250? I really like the lower power/heat on the 7250 but since I'm going to have to get another switch (see 4 posts up) would I be better off getting the 6610-24P over the 7250-24P? I basically need 24 ports POE and currently 5 SFP+. I would like to get a 2nd switch and stack them, more for redundancy than port count. I dont really have a need for QSFP since this is my home setup. I'm torn between the two (6610/7250) now that I have been looking at cost and availability to see where i can get a replacement for the one I'm returning to g-electronic as DOA. I'd like to keep the noise/heat down as much as possible, but whatever I get is replacing an LB6M along with 48 Port Cisco 3750-G POE switch.
 

Kryax

Member
Oct 14, 2017
44
1
8
Big thanks to fohdeesha for sending me blank faceplates for the power supply and fan slots. My thermals are already much more tolerable than before. Still awaiting for the replacement power supply though.

BEFORE

Code:
BROCADE#sh chassis
The stack unit 1 chassis info:

Power supply 1 not present
Power supply 2 (AC - PoE) present, status ok
       Model Number:   23-0000142-02
       Serial Number:  LFV
       Firmware Ver:    B
Power supply 2 Fan Air Flow Direction:  Front to Back

Fan 1 ok, speed (auto): [[1]]<->2
Fan 2 not present

Fan controlled temperature: 71.0 deg-C

Fan speed switching temperature thresholds:
               Speed 1: NM<----->78       deg-C
               Speed 2:       73<-----> 87 deg-C (shutdown)

Fan 1 Air Flow Direction:  Front to Back
MAC 1 Temperature Readings:
       Current temperature : 68.0 deg-C
CPU Temperature Readings:
       Current temperature : 69.5 deg-C
sensor A Temperature Readings:
       Current temperature : 42.0 deg-C
sensor B Temperature Readings:
       Current temperature : 70.5 deg-C
sensor C Temperature Readings:
       Current temperature : 41.5 deg-C
sensor D Temperature Readings:
       Current temperature : 35.5 deg-C
stacking card Temperature Readings:
       Current temperature : 71.0 deg-C
       Warning level.......: 83.0 deg-C
       Shutdown level......: 87.0 deg-C
[/SIZE]
AFTER

Code:
Switch#sh chassis
The stack unit 1 chassis info:

Power supply 1 not present
Power supply 2 (AC - PoE) present, status ok
        Model Number:   23-0000142-02
        Serial Number:  LFV
        Firmware Ver:    B
Power supply 2 Fan Air Flow Direction:  Front to Back

Fan 1 ok, speed (auto): [[1]]<->2
Fan 2 not present

Fan controlled temperature: 57.5 deg-C

Fan speed switching temperature thresholds:
                Speed 1: NM<----->78       deg-C
                Speed 2:       73<-----> 87 deg-C (shutdown)

Fan 1 Air Flow Direction:  Front to Back
MAC 1 Temperature Readings:
        Current temperature : 57.5 deg-C
CPU Temperature Readings:
        Current temperature : 46.5 deg-C
sensor A Temperature Readings:
        Current temperature : 31.0 deg-C
sensor B Temperature Readings:
        Current temperature : 52.0 deg-C
sensor C Temperature Readings:
        Current temperature : 29.0 deg-C
sensor D Temperature Readings:
        Current temperature : 23.0 deg-C
stacking card Temperature Readings:
        Current temperature : 51.5 deg-C
        Warning level.......: 83.0 deg-C
        Shutdown level......: 87.0 deg-C

switch#sh optic 1/3/1
 Port  Temperature   Tx Power     Rx Power       Tx Bias Current
+----+-----------+--------------+--------------+---------------+
1/3/1   48.3593 C  -002.3950 dBm -002.4980 dBm    7.316 mA
        Normal      Normal        Normal         Normal
 
  • Like
Reactions: fohdeesha

Kryax

Member
Oct 14, 2017
44
1
8
are you SURE the PSU fan isn't spinning? it can be hard to see. I ask because that's running cooler than my units with working fans :p
I took some measures to try and cool the system down until stuff arrived such as turning my AC up a couple notches, redirecting the AC room vent a little more towards the rack, and pulling out optics for unused ports. Also since the system was resting directly on top of my other switch, I pulled it out so the front half is sitting over air instead of conducting heat with another chassis (still waiting for my shelf to get here). Also I am not pushing that much traffic at this moment so the switch is somewhat idle.
 

tommybackeast

Active Member
Jun 10, 2018
258
85
28
Quick question....is the noise level on the 6610 that much louder than the 7250? I really like the lower power/heat on the 7250 but since I'm going to have to get another switch (see 4 posts up) would I be better off getting the 6610-24P over the 7250-24P? I basically need 24 ports POE and currently 5 SFP+. I would like to get a 2nd switch and stack them, more for redundancy than port count. I dont really have a need for QSFP since this is my home setup. I'm torn between the two (6610/7250) now that I have been looking at cost and availability to see where i can get a replacement for the one I'm returning to g-electronic as DOA. I'd like to keep the noise/heat down as much as possible, but whatever I get is replacing an LB6M along with 48 Port Cisco 3750-G POE switch.
I have a 6450-24P and am very happy with the low noise and low power draw.
I need more ports and was looking at the 7250-48 or 7250-48P.

How is the power draw and noise on your 7250?
 

rgunner

New Member
Apr 29, 2019
5
3
3
I have a 6450-24P and am very happy with the low noise and low power draw.
I need more ports and was looking at the 7250-48 or 7250-48P.

How is the power draw and noise on your 7250?
I’ve only had it running for a week and I’m having to send it back due to a hardware issue (hazard of buying used), but for noise and power, I’m very happy. Enough so that I ordered another one from a different vendor that will be here by Friday. I needed close to 24 ports of POE with the IP cameras and Access points and I’m converting all of the PC’s/servers in the house to 10G with Connectx-2 cards. If all goes well with that one hardware wise, I plan on ordering another so that I have two for redundancy and a few spare 10G ports. So even with the hardware failure, I like it enough to get two. :). In the weeks time the com closet is soooo much cooler and quieter (pulled out the LB6M and the 48Port POE 3750). If you do get one, the console cable is a must, as mentioned earlier in the thread. Again, Big Thanks! To @fodeesha for putting all the info out there on these.
 
  • Like
Reactions: tommybackeast