[Workaround] Foreman VMware Provisioning: mac value is blank!

Patrick

Administrator
Staff member
Dec 21, 2010
12,051
5,043
113
Had this fun one today where I was provisioning a Ubuntu VM on ESXi as a Rancher node. While provisioning I got an error "mac value is blank!"

I still have not fixed this but a workaround seems to be finding the MAC address in a VM and using that. Foreman will recognize the MAC. VMware will PXE boot the image, Foreman will take over and provision everything.
 

Nacer

New Member
Nov 1, 2017
1
0
1
36
Hi,

I'm facing the same issue "Mac Value is blank"

Do you have a solution about this ?

I'm on Foreman 1.15.6 with ESXi 6.5

Thank you in advance :)
 

whitey

Moderator
Jun 30, 2014
2,770
866
113
38
Not seeing this same (my mac's are blank but provision adn autoassign VMware 00:50:56 mac on Vm creation/no errors) issue and provisioning is still working for me but I did just take my foreman from 1.13 to 1.14 to 1.15 in a sad attempt to get my console working again to no avail. Think the dream of novnc is killed in vSphere 6.5, read some hints that the foreman team was working to enable some webkit/html5 goodness (webmks framework) for console access to vSphere 6.5 VM's through foreman UI/integraton and I was hoping that latest 1.15.6-1 w/ foreman-vmware was gonna get me there but alas I am stuck in a hole. :-(

Very sad day and now I have just pissed away 2-3 hrs fighting this to no avail. Posted on IRC #theforeman in hopes for a lifeline from a dev.

FML

@Nacer , you got console access working through foreman UI back to vSphere 6.5 VM's?

yea or nay?

EDIT: Ohh and I had to chase a bunch of STUPID stale/old kernel cleanup nonsense on Ubuntu 16.04 w/ boot 100% full...SMFH, why I use ubuntu less and less every day.
 
Last edited: