US $192 ($190 BO) Great deal on a Quanta D51B-2U 2u Chassis

josh

Active Member
Oct 21, 2013
530
137
43
Received my unit today.. No drive trays for me... Trying to decide if I should order another unit to try my luck.

If everyone has extra drive trays, please PM me.

FYI... I did get the Quanta DAS2BTH7CB0 12Gps raid card and the rack rails. All the goodies except the drive caddies.
They're OOS though
 

funkywizard

mmm.... bandwidth.
Jan 15, 2017
836
384
63
USA
ioflood.com
Tbh everyone seems to have gotten more than the listing stated.
My order for 200 of the 1u version of these, took them several months to ship the servers at all and 6 months to get the full number of working systems with the promised accessories. Interacting with them is like working with Mr. Bean.

But what can you do? Nobody else has their supply of parts and systems.
 

josh

Active Member
Oct 21, 2013
530
137
43
My order for 200 of the 1u version of these, took them several months to ship the servers at all and 6 months to get the full number of working systems with the promised accessories. Interacting with them is like working with Mr. Bean.

But what can you do? Nobody else has their supply of parts and systems.
You ordered 200 CTO? That's a lot of manhours to put together.
 
  • Like
Reactions: funkywizard

SPCRich

Active Member
Mar 16, 2017
235
84
28
40
@Fritz did you get a chassis with the latest firmware? if so, any chance you could maybe dump it and the BMC firmware? The versions I have are:

BIOS: S2B_3A17
IPMI: 3.31.00
 

SPCRich

Active Member
Mar 16, 2017
235
84
28
40
Just a heads up, as the fun continues with these things. I just tried to update the expander firmware (after updating the firmware on the LSI card) to the 1.3 FW QCT has listed for the expander. The flash was successful, said it would take a few minutes to update. I let it sit for 10, didn't see any change, so rebooted the chassis. Now the backplane doesn't seem to work. "lsscsi -g" doesn't show the backplane, nor does storcli, and when I plug drives in, they don't show any activity, like the controller is detecting them.

Getting a little pissed off with Quanta's website, nothing but garbage downloads that just brick things.

Code:
Enclosure LIST :
==============

--------------------------------------------------------------------
EID State Slots PD PS Fans TSs Alms SIM Port# ProdID VendorSpecific
--------------------------------------------------------------------
252 OK        8  0  0    0   0    0   1 -     SGPIO
--------------------------------------------------------------------
the original FW on the expander was 0.7.0.0, this says 1.3
 
Last edited:

SPCRich

Active Member
Mar 16, 2017
235
84
28
40
@Fritz here's how to dump the bios

Code:
./Linux_x86_64/Yafuflash -nw -u admin -p admin -ip 192.168.1.100 -bios -dump v4bios.bin
Change username/password/IP to the BMC ip/credentials, host must be powered off

you can't dump the ipmi, but that should be fine because that worked before. Also, if you're able to liveboot a linux cd, could you also run lsscsi -g, and show the output? (Or storcli /c0/e0 show) and show the expander part?

Curious to see what your expander firmware version is as well. Either way, I've got 2 jacked up chassis now, since I tried to perform the udpate once more on the other expander... FML
 
Last edited:

SPCRich

Active Member
Mar 16, 2017
235
84
28
40
New Update: While screwing around with the now 2nd broken chassis, I attempted to update the BIOS/IPMI, but this time in reverse. The update.sh script does BMC first, then BIOS. I commented out the BMC section, and ran just the bios. To my surprise, it worked successfully:
1604014574039.png

Then ran BMC update... this also seemed to work:

Firmware Revision:3.45.01
Firmware Build Time:May 31 2016 14:01:19 CST
BIOS Version:S2B_3B04



crossing my fingers that the expander just needed updated firmware, booting it now to see if the expander shows back up. If it doesn't, I think I might attempt ONE more chassis..if that doesn't work im calling it quits lol.

EDIT... OH SNAP IT WORKS
1604014988455.png

ok.. so I think the order of operations is:

1.) Update 9361-8i firmware
2.) Update SAS exander firmware to 1.3
3.) Update BIOS
4.) Update BMC
5.) cross your fingers.

It looks like im good though:

Code:
PD LIST :
=======

------------------------------------------------------------------------------
EID:Slt DID State DG       Size Intf Med SED PI SeSz Model            Sp Type
------------------------------------------------------------------------------
28:0     26 UGood -  372.093 GB SAS  SSD Y   N  512B HUSMM1640ASS20E  U  -
28:1     27 UGood -  372.093 GB SAS  SSD Y   N  512B HUSMM1640ASS20E  U  -
28:2     25 UGood -  372.093 GB SAS  SSD Y   N  512B HUSMM1640ASS20E  U  -
------------------------------------------------------------------------------

EID=Enclosure Device ID|Slt=Slot No.|DID=Device ID|DG=DriveGroup
DHS=Dedicated Hot Spare|UGood=Unconfigured Good|GHS=Global Hotspare
UBad=Unconfigured Bad|Onln=Online|Offln=Offline|Intf=Interface
Med=Media Type|SED=Self Encryptive Drive|PI=Protection Info
SeSz=Sector Size|Sp=Spun|U=Up|D=Down|T=Transition|F=Foreign
UGUnsp=UGood Unsupported|UGShld=UnConfigured shielded|HSPShld=Hotspare shielded
CFShld=Configured shielded|Cpybck=CopyBack|CBShld=Copyback Shielded
UBUnsp=UBad Unsupported|Rbld=Rebuild

Enclosures = 2

Enclosure LIST :
==============

----------------------------------------------------------------------------------------------
EID State Slots PD PS Fans TSs Alms SIM Port#                      ProdID      VendorSpecific
----------------------------------------------------------------------------------------------
28 OK       24  3  0    0   0    0   1 Port 0 - 3 & Port 4 - 7 x8 D51B-2U 2.5 x48-1.3.0.0
252 OK        8  0  0    0   0    0   1 -                          SGPIO
----------------------------------------------------------------------------------------------
V4 QS processors now boot.. JOY!
 
Last edited:

Fritz

Well-Known Member
Apr 6, 2015
2,390
624
113
67
@Fritz here's how to dump the bios

Code:
./Linux_x86_64/Yafuflash -nw -u admin -p admin -ip 192.168.1.100 -bios -dump v4bios.bin
Change username/password/IP to the BMC ip/credentials, host must be powered off

you can't dump the ipmi, but that should be fine because that worked before. Also, if you're able to liveboot a linux cd, could you also run lsscsi -g, and show the output? (Or storcli /c0/e0 show) and show the expander part?

Curious to see what your expander firmware version is as well. Either way, I've got 2 jacked up chassis now, since I tried to perform the udpate once more on the other expander... FML
It'll be tomorrow before I can get back to it. Stand by.
 

funkywizard

mmm.... bandwidth.
Jan 15, 2017
836
384
63
USA
ioflood.com
3b22 is the latest BIOS. the "v4 update package" has horrifically old version, basically the first version that ever supported the v4. No wonder using that update package bricks the ipmi or worse.

the latest bmc requires at least 3b05, and the "v4 upgrade package" has 3b04.
 

SPCRich

Active Member
Mar 16, 2017
235
84
28
40
3b22 is the latest BIOS. the "v4 update package" has horrifically old version, basically the first version that ever supported the v4. No wonder using that update package bricks the ipmi or worse.

the latest bmc requires at least 3b05, and the "v4 upgrade package" has 3b04.
Please provide a link to the latest then. Quanta for whatever reason took down bios and bmc links on their download page, for every chassis sometime in the last 2 months, including the stuff currently being sold. Google yields no results for alternative links, and I've tried using all of their international sites in hopes they forgot one. I also reached out to quanta support over a week ago asking for downloads and gave gotten zero response.
 

funkywizard

mmm.... bandwidth.
Jan 15, 2017
836
384
63
USA
ioflood.com
My staff are also having similar problems as mentioned. Working to come up with a "proper" update procedure and will share once we have it.

As to the bios files, we got them from quanta website when it was still online. Not sure of an alternate.