Topton Jasper Lake Quad i225V Mini PC Report

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

kliguin

Member
Nov 22, 2022
59
45
18
My board says CW-N5105-4L and i have ordered it here.
Best way to distinguish are the different ports:
V1/V2 have mPCIE port for the WiFi, 1 HDMI in front, 2-4 USB in front, 4 LAN in back.
V3/4/5 have 4 USB, USB-C and SD-card reader in front, 4 LAN and HDMI and DP in back. Both internal slots are m.2.

But these are only the changwang boards, there are others (eg bluetec with a console port). Could you post a picture of your board?
I can not have look at my BIOS, its running as my main router...
Thanks, I do not have a picture from above but the Ali screenshot shows exactly the one I have.

Do you also think its at least a V3-V5?




Greenshot 2023-08-27 17.51.18.png
 

Attachments

Last edited:
  • Like
Reactions: Stovar

kliguin

Member
Nov 22, 2022
59
45
18
Then it is probably a v5. Got my v4 in august, v5 was afaik first sold in fall. And I remember these photos from the Topton offer.
Thanks, how did you validate you got a V4 is that somewhere displayed at the PCB? When I put all the N5105 BIOS options into Google Translate I got this translation.

1693254684637.png
 

Mike9474593

Active Member
Aug 5, 2022
103
76
28
Thanks, how did you validate you got a V4 is that somewhere displayed at the PCB?
V3: has Intel i225-V Rev3
V4: has Intel i226-V
V5: has also Intel 226, and some small optimisations (eg for SSD, each m.2 has its own clock signal), dont know how to find the difference between V4 and 5 without any stickers.

My board says CW-N5105-4L V4, so mine is a v4 (sticker next to the RAM slots).
Their naming scheme is as follows (not on all boards)
CW is the manufacturer (changwang)
N5105 is the CPU/generation
4L means 4 Lan ports
V4 is version 4 I guess
The new AlderLake N have more or less identical board naming, eg CW-ADLN-5L for the 5 port version.


Found an Photo of my board, on the CPU side is a sticker that says FMI07 N5105 JK 4L-V01, yours says says the same with V02, so your V5 is a V4 version 2. AFAIK V3 is FMI01 or something.

Yeah, I know, quite complicated, but I really like these devices.
 
  • Like
Reactions: Stovar

kliguin

Member
Nov 22, 2022
59
45
18
@Mike9474593 Would be able to share your board picture? My board doen't have a sticker which makes it hard to identify. Based on the photos which are sometime included at the BIOS downloads, there are some optimizations around the PC speaker/battery. I'm wondering if you can see any diffs.

Would you be able to share your photo? Here is mine.

Hmmm seems the site is having troubles, I'll PM it to you.
 

Snk B

Member
Jul 19, 2022
61
54
18
Hi all fellas
My new barebone 5825U device just arrived
I'm assembling it and I would like to ask something to those already owning this kind of device
1) where could I check for any cwwk's bios update availability?
2) to install a sata SSD drive to pair with the M2 one I already installed, where could I place it? just on top of the nvme and ram spot? Because this way the bottom cover's fan would be in direct contact with the data drive, and I think this would for sure block the airflow from this fan.
3) cwwk sent me a replacement for a side cover of the case with 2 little fans to attach on it. On the fans there's not any arrow to show from which side the airflow will move. Do anyone know if the air flows from the side with the sticker to other one or viceversa? And where the hell should I connect the 4 pin this fans come with?

Sorry for bothering you with all this questions, but is my 1th device of this kind and I'm a bit confused on how to go with it
I attach some pics of the device and how I was considering to place the additional data SSD drive

Any advice will be really appreciated
Thanks a lot
Kom
Hello friend, I also have a 5825U unit, could you show me how this side cover with two fans is?
Thanks!
 

Dopamin3

New Member
Aug 30, 2023
8
2
3
I purchased this unit from Topton Mar 30, 2022 (N6005 V1 board, I225-V B3 NICs x4 barebones and slapped in 2x8GB 2666MHz SODIMM and 480GB SX8200 NVME). I ran bare metal OPNsense on it for some time with 0 issues.

Flash forward to present, I updated the BIOS to the CWWK 2022425 version and loaded Proxmox VE 8.0.4 onto the system. I also applied the BIOS power tweaks from this post:
I am just quoting some very important post above regarding Power saving bios/tweaks so others can bookmark or refer back to them it saves people reading 120+ pages (but its a good read regardless!)
So far all I've done is enable IOMMU and passthrough two NICs (1x WAN, 1x LAN) to use for virtualized OPNsense, this is the only VM running right now. My issue is Network Time / NTPd / NTP is throwing errors. In NTP server logs all the default servers (0.opnsense.pool.ntp.org - 3.opnsense.pool.ntp.org) show Unreach/Pending, the log file says "kernel reports TIME_ERROR: 0x41: Clock Unsynchronized" and the console will show things like "calcru: runtime went backwards from xxx usec to xxx usec for pid xxx (pidname)"

I'm worried that Proxmox itself is messed up with time too but I'm much more familiar with FreeBSD. I did some brief research on this and it might be due to the Timecounter? Output from OPNsense VM:
Code:
root@OPNsense:~ # dmesg | grep Timecounter
Timecounter "kvmclock" frequency 1000000000 Hz quality 975
Timecounter "HPET" frequency 100000000 Hz quality 950
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
Timecounter "i8254" frequency 1193182 Hz quality 0
Timecounters tick every 10.000 msec
It's currently using kvmclock so is my potential fix here just setting a tunable for kern.timecounter.hardware = i8254 ? Do I need to check anything on Proxmox host too? I didn't try any changes yet but would appreciate anyone who can provide some input. Before on the bare metal install I never messed with the power tweaks so I'm not sure if this is a power tweak issue or virtualization issue, but I'd really like to keep the power savings.
 
  • Like
Reactions: oeiknearf

cBorisa

New Member
Sep 30, 2022
12
13
3
Thanks everyone sharing their experience with those units here at the forum. I learned a lot before buying the unit and when setting it up.
So I've got myself a 5105 unit with i226 4 ports card, based on GF-1338NP-12-V14 motherboard.
I've ordered a unit with no RAM and drive since I have enough parts myself. It was 140,59€ with delivery from Kingnovy store. Ordered on August 20, item delivered to Germany on August 30.
Pfsense-firewall-soft-router-n5105-n100-4x-intel-i225-i226-2-5g-lan-2-xddr4-nvme.jpg

The item came well packed and worked right away.

TLDR: Final version runs now with 2x8Gb RAM in it, mini SATA drive (with SATA-mSATA adapter) and NVME drive., average temperature on CPU: 46C, NVME: 55C, ACPI: 28C

My purpose for the node is to make it an ultimate router for my homelab. Therefore it needs to run Pfsense together with couple of other containers (Omada controller, Pi-hole and others). So the plan was Proxmox, Pfsense VM on it, and VM for docker with small containers.

First thing I did, I unscrewed the motherboard and replaced the thermal paste. It had enough paste on the plate and CPU, but I replaced it with the one I had - just in case.

I wanted to have boot drive in a pool to be able to use the system if a drive fails. Initially I installed standard SATA drive (SK Hynix 256Gb) and NVME drive (Toshiba THNSN5256GPU7). However, it had 2 issues:
1) the supplied SATA cable has 90-degree angle connector, so I couldn't close the lead with the SATA drive attached to the back plate. (I've ordered the replacement, but it may take a while to arrive).
2) The Toshiba NVME drive was running very hot (68-69C). Installing heat sink on it didn't solve the problem, as there is not enough air movement inside the box.

As I don't need high performance, I replaced SATA with mSATA drive (with SATA to mSATA adapter) to save some space. I looked into getting the fan inside to cool down the NVME, but then I got a hand on Samsung PM951 NVMe SSD. This SSD runs 15-20 degrees cooler without any heatsink.

20230920_124637.jpg

20230920_124645.jpg

So it has been running as my primary router for 10 days already - all good.

Here are the temps:

Code:
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +46.0°C  (high = +105.0°C, crit = +105.0°C)
Core 0:        +41.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:        +41.0°C  (high = +105.0°C, crit = +105.0°C)
Core 2:        +41.0°C  (high = +105.0°C, crit = +105.0°C)
Core 3:        +41.0°C  (high = +105.0°C, crit = +105.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +27.8°C  (crit = +119.0°C)

nvme-pci-0100
Adapter: PCI adapter
Composite:    +55.9°C
 
  • Like
Reactions: Stovar

alexmoore

New Member
Nov 10, 2022
12
0
1
Hey everybody,

I bought one of these last year from "Topton 3C" on AliExpress with the N6005 cpu, and had it working mostly fine over the last year with Proxmox / opnsense. It would lock up occasionally and or throw segmentation faults, but I chalked that up to software. I reinstalled opnsense on the bare metal to try and fix that, transported it back to the rack, and now it won't boot whatsoever. No lights or beeps when you press the power button, but there are lights on the LAN ports if you plug in a cable.

I've tried reseating everything, unplugging the CMOS battery, repasting the CPU, and a different power supply. I'm kinda out of ideas to test.

Is there anything else I could try?

Parts Details
Code:
Model:   FM107A N6005 JK 4L-V02 CBOX
Listing: "4xIntel i226-V 2.5G Mini PC Pentium N6005 N5105 Quad Core DDR4 NVMe Fanless Soft Firewall Router HD DP Type-C OPNsense ESXi"

PSU: LITEON PA-14805M04 12V/4A

Memory: 2x Crucial 16GB DDR4-3200 SODIMM 1.2V CL22 (CT16G4SFRA32A.C8FF)

SSD: WD Blue SN570 500GB
 
Last edited:

BobS

Member
Dec 2, 2022
34
26
18
Hey everybody,

I bought one of these last year from "Topton 3C" on AliExpress with the N6005 cpu, and had it working mostly fine over the last year with Proxmox / opnsense. It would lock up occasionally and or throw segmentation faults, but I chalked that up to software. I reinstalled opnsense on the bare metal to try and fix that, transported it back to the rack, and now it won't boot whatsoever. No lights or beeps when you press the power button, but there are lights on the LAN ports if you plug in a cable.

I've tried reseating everything, unplugging the CMOS battery, repasting the CPU, and a different power supply. I'm kinda out of ideas to test.

Is there anything else I could try?

Parts Details
Code:
Model:   FM107A N6005 JK 4L-V02 CBOX
Listing: "4xIntel i226-V 2.5G Mini PC Pentium N6005 N5105 Quad Core DDR4 NVMe Fanless Soft Firewall Router HD DP Type-C OPNsense ESXi"

PSU: LITEON PA-14805M04 12V/4A

Memory: 2x Crucial 16GB DDR4-3200 SODIMM 1.2V CL22 (CT16G4SFRA32A.C8FF)

SSD: WD Blue SN570 500GB
Have a similar model but have not had that type of problem on mine but try:
1. Reinstall the BIOS <<< It does sound like the BIOS/UEFI got borked
2. Remove one stick of memory and try booting.
3. If that doesn't work, swap the other module into that position
4. Rinse and repeat with the second memory stick and position
5. Verify with a voltmeter or swap the power module

Try installing Win10 or a Linux distro. Should you have a problem installing BIOS or any software from a flash drive, Try to use a known good USB "2" drive and try swapping USB connections. I've had problems with PNY and Verbatim flash drives in the past on some of these mini's.

BobS
 

alexmoore

New Member
Nov 10, 2022
12
0
1
Have a similar model but have not had that type of problem on mine but try:
1. Reinstall the BIOS <<< It does sound like the BIOS/UEFI got borked
2. Remove one stick of memory and try booting.
3. If that doesn't work, swap the other module into that position
4. Rinse and repeat with the second memory stick and position
5. Verify with a voltmeter or swap the power module

Try installing Win10 or a Linux distro. Should you have a problem installing BIOS or any software from a flash drive, Try to use a known good USB "2" drive and try swapping USB connections. I've had problems with PNY and Verbatim flash drives in the past on some of these mini's.

BobS

I did try swapping around the memory, 1 stick, red stick, blue stick. Also checked the power supply with a voltmeter, and the voltage on the motherboard. Not sure how I would reinstall the bios, especially since it doesn't respond to anything.
 

BobS

Member
Dec 2, 2022
34
26
18
I did try swapping around the memory, 1 stick, red stick, blue stick. Also checked the power supply with a voltmeter, and the voltage on the motherboard. Not sure how I would reinstall the bios, especially since it doesn't respond to anything.
Do you know how to enter the BIOS/UEFI? Most likely you keep hitting the DEL key while it boots but it could be an ESC key or an F key to get into the BIOS. Usually, the last page where you Save any BIOS setting changes, there is also a "Load Defaults" selection - do that.

If you can't get into the BIOS there are typically a sequence of steps you can do that force a response, like long press the power and/or the reset button.

You should contact the tech support of the model you purchased and ask them for both the download link and install instructions to reinstall the BIOS. Some of these AliExpress resellers don't want to know you after the sale but most do have a public forum where you can post questions and god forbid, they may even have a tech support email address.

BobS
 

BobS

Member
Dec 2, 2022
34
26
18
Do you know how to enter the BIOS/UEFI? Most likely you keep hitting the DEL key while it boots but it could be an ESC key or an F key to get into the BIOS. Usually, the last page where you Save any BIOS setting changes, there is also a "Load Defaults" selection - do that.

If you can't get into the BIOS there are typically a sequence of steps you can do that force a response, like long press the power and/or the reset button.

You should contact the tech support of the model you purchased and ask them for both the download link and install instructions to reinstall the BIOS. Some of these AliExpress resellers don't want to know you after the sale but most do have a public forum where you can post questions and god forbid, they may even have a tech support email address.

BobS
Forgot to ask. What do you see on the monitor when booting. Does it post or just a blank screen?