Supermicro Epyc motherboards - list of graphics cards that work - I need help to make a list

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

lopgok

Active Member
Aug 14, 2017
217
152
43
I have a supermicro H11SSL motherboard. It is quite fussy dealing with graphics cards. If the graphics card is incomparable with the UEFI BIOS then the BIOS will freeze during boot time. I have a lot of graphics cards that won't work. I want to make a list of graphics cards that *do* work. I will start with what I know work and don't work, and I will need your help to add to the list.

Motherboard BIOS Card Status
H11SSL v2 2.0a nvidoa quadro K420 works
H11SSL v2 2.0a MSI rx 560 doesn't work

H11SSL v2 2.1 nvidoa quadro K420 works
H11SSL v2 2.1 nvidia quadro p400 works
H11SSL v2 2.1 R9 270x doesn't work
H11DSi rev.1 Radeon RX570 8GB works
H11SSL AMD Instinct MI25/Radeon Pro WX9100 works

H11DSi rev.1 AMD Radeon RX570 8GB works
H11DSi-NT rev.2 GTX 1660 Super works

H11DSi-NT rev.2 RTX 2080Ti works
H11DSi-NT rev.2 RTX 3070 works

H12SSL 2.4 nvidia 1080ti works
H12SSL ? Nvidia GTX 1660 works
H12SSL ? nvidia 1660 works
H12SSL ? Suprim RTX 4090 works
H12SSL ? nvidia quadro p400 works
H12SSL ? Nvidia a4000 works
H12SSL ? RTX A4000 works
H12SSL 2.4 A4000 works
H12SSL ? Nvidia RTX A6000 works
H12SSL 2.4 titan Xp works
H11DSi-NT rev.2 Titan V works
H12SSL ? Intel Arc Pro a40 works

H12DSi-N6 + 1080 Ti works
H12DSi-N6+ Titan Xp works

H12DSi-NT6 PNY NVidia GT 610 works
H12DSi-NT6 EVGA NVidia GTX 1080 TI works
H12DSi-NT6 Asus AMD Radeon R9 390X doesn't work
H12SSL-i Radeon RX 7600 doesn't work if BIOS is set to UEFI
 
Last edited:

IamSpartacus

Well-Known Member
Mar 14, 2016
2,520
652
113
I had this problem when I had an H11 board. They don't like desktop graphics cards but do work with workstation cards.
 

eduncan911

The New James Dean
Jul 27, 2015
648
506
93
eduncan911.com
Besides the video switching implementation in the bios (for primary video), I can't think of what would break specific graphic cards from working.

Maybe it doesn't like EFI-only based graphics cards? Most older GPUs needed to have an Option ROM to get initialized during boot (pre-EFI days, and even for a long time with EFI). These days, high-end server GPUs typically don't have Option ROM binary blobs any longer - as they are all EFI.

Maybe play with enabling Option ROMs, Legacy BIOS for PCIe slots (there's usually a way to specify what Option ROMs to load - like video, storage, network), etc. Enable Legacy boot, disable EFI for a bit, etc. Maybe mis Legacy first, and then EFI. Etc.
 
Last edited:

IamSpartacus

Well-Known Member
Mar 14, 2016
2,520
652
113
I'm also using an H12SSL-i now with a 1660 and no issues at all. So this may be patched in H12 boards.
 

alex_stief

Well-Known Member
May 31, 2016
884
312
63
39
What would be examples of graphics cards not working?

I'm using an H11DSi rev.1 with an AMD Radeon RX570 8GB
 

lopgok

Active Member
Aug 14, 2017
217
152
43
What would be examples of graphics cards not working?

I'm using an H11DSi rev.1 with an AMD Radeon RX570 8GB
The MSI 560 and the R9 270x both freeze during post.

It may be possible that the VGA output works after post seems to freeze, but I have not tested that.
 

gsrcrxsi

Active Member
Dec 12, 2018
322
108
43
I've used many normal nvidia cards in my H11DSi-NT rev.2 without any problem.

GTX 1660 Super
Titan V
RTX 2080Ti
RTX 3070

when you say "MSI 560" do you mean the RX560 (AMD) or GTX560 (Nvidia)? if the later, then the GTX 560 and R9 270x are both quite old models, and probably the issue is the Option Rom settings in the BIOS that eduncan mentioned.
 

lopgok

Active Member
Aug 14, 2017
217
152
43
I've used many normal nvidia cards in my H11DSi-NT rev.2 without any problem.

GTX 1660 Super
Titan V
RTX 2080Ti
RTX 3070

when you say "MSI 560" do you mean the RX560 (AMD) or GTX560 (Nvidia)? if the later, then the GTX 560 and R9 270x are both quite old models, and probably the issue is the Option Rom settings in the BIOS that eduncan mentioned.
I mean the msi rx 560. I played around with various settings without any luck. At least the quadro k420 and p400 are working for me.
 

drdepasquale

Member
Dec 1, 2022
79
34
18
I have tested a few graphics cards on my H12DSi-NT6

PNY NVidia GT 610 Works
EVGA NVidia GTX 1080 TI Works
Asus AMD Radeon R9 390X Does not work
 

darkconz

Member
Jun 6, 2013
193
15
18
I recently acquired a H12SSL-i (fw 2.4) and popped my AMD 6800XT in there. Everything went smoothly during install but when I got into Windows (Win10Pro) and when Windows grabs the latest AMD driver for the card, the system would hang and would no longer boot into Windows.

Video is fine if outside windows (BIOS/EFI).

I thought it was my specific card, asked my friend for his AMD 6800 to try and same thing.

Both cards work on regular consumer boards. Don't have any nVidia cards to try. Something to do with the latest AMD driver and this board?
 

lopgok

Active Member
Aug 14, 2017
217
152
43
You might try booting a live linux from usb. If that works, the issue is windows drivers...
 

turbo944s2

New Member
Dec 2, 2022
4
0
1
H12dsi-n6 evga 3090 ftw works on the first boot but then freezes if you restart it, without powering it completely down.