Supermicro 6028U-TRTP X10DRU-i Barebone $349

hansaya

New Member
Dec 10, 2021
8
2
3
Since I got a extra motherboard I played with it alot(using software), non worked. You might be able to pull the bios flash chip off and reprogram it. But this leaves you with the issue of not being able to flash the IPMI. If you can send this out to Supermicro get it reflashed then there has to be a easy way of doing it or supermicro has a private key that they can use to sign the bios with.

What I have tried so far.
* Tried to flash with or without protect jumper.
* Flash using IPMI API
* Flash using USB
* Flash using IPMI web interface
 

haregh19

New Member
Jun 20, 2020
27
8
3

artveb

New Member
Apr 28, 2022
1
0
1
Im actually working to try to resolve this issue. We got in a bunch of these systems with the signed firmware that cannot be upgraded. I will keep everyone posted. If somebody has figured out how to fix this issue I would be happy to compensate for the info.
Same here. X10DRU-i+, bios 3.2a, ipmi 03.88. Cant firmware
I tried download from flash current ipmi firmware (something like "dupdate -d backup_ipmi_file") and then flashing the same downloded file. Not working. So problem is not just upgrade new version but flashing overall.
Maybe this help:
GitHub - devicenull/ipmi_firmware_tools: IPMI analysis tools ?

How can you determine that firmware is signed?
 
Last edited:

dreamkass

New Member
Aug 14, 2012
25
5
3
Anyone tried this yet for the firmware upgrades?


Please may try update IPMI using web GUI and uncheck all the boxes where says “ save BMC configurations and all that “
If didn’t help, please may try to move the JPME2 jumper to pin 2-3 then apply the updates and see if that helps ?

X10DRU-i+ - JMPE2 Jumper.png