Supermicro 6026TT-BTR (X8DTT-F motherboards)

talsit

Member
Aug 8, 2013
112
20
18
I recently acquired a 6026TT with 4 nodes of dual L5630s and 16GB or RAM.

I'm trying to install Ubuntu 16.04 but the install can't find the NICs on any of the nodes.

Ostensibly the NIC is a dual port Intel 82576.

The NICs are connected (both 1 and 2) to my Netgear GB switch. I have access to the IPMI and I have yellow activity lights flashing on all NICS.

During initial boot I made sure both NICs were enabled in BIOS.

The install fails on every node at the detect network hardware step.

Any ideas?

Thanks in advance.
 

vanfawx

Active Member
Jan 4, 2015
366
68
28
43
Vancouver, Canada
There's a jumper on each board that enables or disables the onboard ethernet. It should be marked as JPL1. Pins 1-2 connected enable the network, 2-3 connected disable. If those are enabled, you might want to open a support ticket with Supermicro.

Hope that helps.
 

talsit

Member
Aug 8, 2013
112
20
18
As an update...

1. I have changed the position of JPL1 to ensure that it was on the correct pins.
2. I ran lspci grep | Ethernet and got nothing using the ubuntu livecd and dropping to a command line during install
3. I verified the NICs were enabled in the BIOs, there are two options once they are enabled, PXE and iSCSI (boot options) I've tried both of those, though they shouldn't impact the NIC being visible
4. I've verified connectivity on all my cables
5. I have a flashing orange light (100Mb?) on the NICs when the cables are attached
6. I can access IPMI (I was also able to upgrade IPMI from ver 1.01 to 3.3)

It's a used unit and came with dead BIOs batteries and no riser card installed in the PCIe slot, neither of those things should make the NICs disappear though.

I haven't tried to update the BIOS yet but, again, I don't think that would make the NICs unavailable
 

fractal

Active Member
Jun 7, 2016
312
69
28
32
Just as a FYI. lspci on an x8dtt-f in a 6026TT on an earlier version of ubuntu looks like:

Code:
Welcome to Ubuntu 14.04.4 LTS (GNU/Linux 4.2.0-27-generic x86_64)

...snip

:~$ lspci
00:00.0 Host bridge: Intel Corporation 5500 I/O Hub to ESI Port (rev 22)
00:01.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 1 (rev 22)
..snip
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
01:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
02:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
05:01.0 VGA compatible controller: Matrox Electronics Systems Ltd. MGA G200eW WPCM450 (rev 0a)
You don't need cables for them to be detected. One of mine is not connected and was still listed as expected.

The fastest and cleanest way to verify bios settings is to revert to factory. That will eliminate the chance that you, or anyone else changed them. I reset mine to factory before installing ubuntu. The only thing I changed was eliminating the splash screen so I could see startup and the boot order so I could boot from USB to install. A dead battery would make me want to reset to factory at least twice.
 
  • Like
Reactions: talsit

talsit

Member
Aug 8, 2013
112
20
18
Thanks, that helped. Nowhere does the network adapter show up on any node when using lspci.

Still digging.