SAS2308 and mpt3sas.msix_disable=1

trumee

Member
Jan 31, 2016
194
9
18
50
Hello,

I have an LSI 9207-8i card which is detected by Arch Linux only when i have mpt3sas.msix_disable=1. The kernel version is 5.1.5. Is this a hardware issue with the card?

Card details are as follows:

Code:
#sas2flash -list
LSI Corporation SAS2 Flash Utility
Version 20.00.00.00 (2014.09.18)
Copyright (c) 2008-2014 LSI Corporation. All rights reserved

        Adapter Selected is a LSI SAS: SAS2308_2(D1)

        Controller Number              : 0
        Controller                     : SAS2308_2(D1)
        PCI Address                    : 00:04:00:00
        NVDATA Version (Default)       : 14.01.00.06
        NVDATA Version (Persistent)    : 14.01.00.06
        Firmware Product ID            : 0x2214 (IT)
        Firmware Version               : 20.00.07.00
        NVDATA Vendor                  : LSI
        NVDATA Product ID              : SAS9207-8i
        BIOS Version                   : N/A
        UEFI BSD Version               : N/A
        FCODE Version                  : N/A
        Board Name                     : SAS9207-8i
        Board Assembly                 : H3-25412-00H
        Board Tracer Number            : SV40220473
Thanks