Ruckus Wireless as an Unifi alternative?

Vesalius

Active Member
Nov 25, 2019
151
114
43
I wish to setup up LACP on a R610 AP to my ICX6450 48POE. I
Would someone be willing to guide me along,step by step? Does the 2nd port also need POE?

much thanks
This is how I did it. https://forums.servethehome.com/ind...rocade-icx-6450-ruckus-r720.26547/post-254295

although the latest unleashed software cli guide states you can ssh into each AP and issue the command:

Code:
ruckus> en
ruckus# ap-mode
  You have all rights in this mode.
ruckus(config-ap)# status-lacp enable
ruckus(ap-mode)# get bond
LACP/Bonding is ENABLED.
<bond0>
       544
RUCKUS Unleashed 200.10 Command Line Interface Reference Guide Part Number: 800-72824-001 Rev A
Mode:          8023AD
LACP-rate:     fast
MII-Mon:       100 (ms)
Xmit-Hash:     layer2+3
Slaves:        2
Slave-0:       eth0, ACTIVE, DOWN TOO LONG, link-fail-count: 0
Slave-1:       eth1, ACTIVE, UP, link-fail-count: 0
OK
 

epicurean

Active Member
Sep 29, 2014
705
51
28
This is how I did it. https://forums.servethehome.com/ind...rocade-icx-6450-ruckus-r720.26547/post-254295

although the latest unleashed software cli guide states you can ssh into each AP and issue the command:

Code:
ruckus> en
ruckus# ap-mode
  You have all rights in this mode.
ruckus(config-ap)# status-lacp enable
ruckus(ap-mode)# get bond
LACP/Bonding is ENABLED.
<bond0>
       544
RUCKUS Unleashed 200.10 Command Line Interface Reference Guide Part Number: 800-72824-001 Rev A
Mode:          8023AD
LACP-rate:     fast
MII-Mon:       100 (ms)
Xmit-Hash:     layer2+3
Slaves:        2
Slave-0:       eth0, ACTIVE, DOWN TOO LONG, link-fail-count: 0
Slave-1:       eth1, ACTIVE, UP, link-fail-count: 0
OK
Thank you. What do i need to set on the ICX6450 switch? I assume these commands are all on the AP?
 

TXAG26

Active Member
Aug 2, 2016
316
97
28
yeah we do managed wifi for muti family housing and student housing. I am hopping to be able to SZ at home as I am getting confirmable with using its interface at work. Right now I use unleashed at home and feels like software from fisher price.
I guess over the years I’ve gone the opposite direction and have tried to simplify network items when possible, while keeping enterprise grade hardware where feasible.
 
  • Like
Reactions: hmw and Scarlet

Vesalius

Active Member
Nov 25, 2019
151
114
43
Thank you. What do i need to set on the ICX6450 switch? I assume these commands are all on the AP?
On the 6450 You will need to create a named Dynamic (this is LACP) lag group. Then add ports and deploy the lag group. This can also be done from the 6450 web gui. Only one of the 6450 ports in your LACP group needs to be PoE I used this one for the primary port, if that is how you power the AP. Make sure you are feeding 802.3at PoE+ to the 610 or the second AP ethernet port won't work.

To create a LACP group named Ruckus610 using ports 1/1/1 & 1/1/2 with 1/1/1 being the PoE and primary LACP port:
Code:
device(config)# lag Ruckus610 dynamic
device(config-lag-Ruckus610)# ports ethernet 1/1/1 ethernet 1/1/2
device(config-lag-Ruckus610)# primary-port 1/1/1
device(config-lag-Ruckus610)# deploy
 
Last edited:
  • Like
Reactions: epicurean

sth

Active Member
Oct 29, 2015
340
72
28
I use vSZ at home and if I recall correctly after 90 days you are prevented from making changes to the AP configuration but they still function and you can still log into smart zone to apply licences etc. I didn't apply my licences correctly a few years back and "tested" this feature accidentally :)
You could reinstall and restore a config and run for another 90 days if you dont want to fork out for a licence.
There is some additional functionality exclusive to vSZ although the gap has closed in the last 24 months as they've added more to unleashed so value may not be super high. The monitoring and single control plane for switches and APs is a nice to have though.
 

Vesalius

Active Member
Nov 25, 2019
151
114
43
Firmware 200.10.10.5.246 released, will need to click on the downloads tab to see it.

RUCKUS Unleashed 200.10 (GA Refresh1) Release Notes

Resolved Issues in Build 200.10.10.5.246
• Resolved an issue where channels 132 and 136 were disabled for 80 Mhz and Auto, Japan country code. [ER-10500]
• Resolved an issue where WLAN passphrase locked up the system. [ER-10223]
• Resolved an issue where Apple clients were getting disconnected from the WLAN due to inactivity. [ER-9831]
• Resolved an issue where the UE loses network connectivity when roaming between radios on same AP, in WPA2 WLAN. [ER-10340]
• Resolved an issue where the client with Sonos app were failing to detect Sonos speakers over the WLAN. GTK Key Index missing. [ER-9637]
 

Vesalius

Active Member
Nov 25, 2019
151
114
43
I can only assume not or it would be listed. I have not retried that setting since upgrading.
 

audiobahn

New Member
Sep 29, 2021
23
1
3
Hi everyone,

(First Post!) Just starting my journey in setting up a proper network in my house. I started small with one Ruckus R710 on Unleashed (-WW version) and will then add a managed switch, pfsense and server.

Having said that, I seem to be having problems from step 1 as I cant seem to be able to get a decent downlink on the R710. The max downlink speed I seem to get on my phone (iPhone 11) is 350Mbit which is nothing compared to the 800Mbit I get with my standard router supplied by my ISP. The same story goes all around the house with the Ruckus performing consistently worse than the "cheap" router. Uplink speed on the other hand, is perfect at 550Mbit+.

Any tips on how to address?

Things already considered:
*Read about slow speeds for iOS on certain FWs: I'm running the latest released (200.10.10.5.246)
*Checked and confirmed AP negotiates 802.3at power
*Set gain to max power (made it worse so reverted back to Auto)
*Replicated channel setup of 'cheap' router and switched it off to avoid interference

Special shout out to @ViciousXUSMC on your 'how to setup unleashed' video, would be lost with out it but instead took me 10 mins to get everything set up.
 

Vesalius

Active Member
Nov 25, 2019
151
114
43
Hi everyone,

(First Post!) Just starting my journey in setting up a proper network in my house. I started small with one Ruckus R710 on Unleashed (-WW version) and will then add a managed switch, pfsense and server.

Having said that, I seem to be having problems from step 1 as I cant seem to be able to get a decent downlink on the R710. The max downlink speed I seem to get on my phone (iPhone 11) is 350Mbit which is nothing compared to the 800Mbit I get with my standard router supplied by my ISP. The same story goes all around the house with the Ruckus performing consistently worse than the "cheap" router. Uplink speed on the other hand, is perfect at 550Mbit+.

Any tips on how to address?

Things already considered:
*Read about slow speeds for iOS on certain FWs: I'm running the latest released (200.10.10.5.246)
*Checked and confirmed AP negotiates 802.3at power
*Set gain to max power (made it worse so reverted back to Auto)
*Replicated channel setup of 'cheap' router and switched it off to avoid interference

Special shout out to @ViciousXUSMC on your 'how to setup unleashed' video, would be lost with out it but instead took me 10 mins to get everything set up.
Is your cheap router Wi-Fi 6? How are you measuring speeds through each Wi-Fi router?

 

audiobahn

New Member
Sep 29, 2021
23
1
3
Hi @Vesalius , the cheap router is ac, not ax. Specs below:

Sagecomm FAST 5364:
Antennas: 4×4 5GHz and 3×3 2.4GHz
WiFi: 2.4GHz Wi-Fi (802.11 b/g/n) and MU-MIMO 5GHz Wi-Fi (802.11 a/n/ac)
Whilst decent specs I would imagine the R710 should be at least able to match it.

Used the Wi-FiSweetSpots app for like for like tests between the two and verified the Ruckus speeds with SpeedFlex. Quick WiFi survey using NetSpot reconfirms results...
 

Vesalius

Active Member
Nov 25, 2019
151
114
43
Hi @Vesalius , the cheap router is ac, not ax. Specs below:



Whilst decent specs I would imagine the R710 should be at least able to match it.

Used the Wi-FiSweetSpots app for like for like tests between the two and verified the Ruckus speeds with SpeedFlex. Quick WiFi survey using NetSpot reconfirms results...
I am not sure what is going on with the cheap router 800 speed results if not wifi6ax. My understanding is that realistic maximums are in the 450-550 range for ac even with your iPhone sitting on top the Wi-Fi router/AP.
 

audiobahn

New Member
Sep 29, 2021
23
1
3
I am not sure what is going on with the cheap router 800 speed results if not wifi6ax. My understanding is that realistic maximums are in the 450-550 range for ac even with your iPhone sitting on top the Wi-Fi router/AP.
No idea! I'll do some more testing and see what comes out of it. Was thinking one R710 would be good enough for the size of my house but it seems I might need to consider a couple of H510s I found for decent price. (unrelated to previous issue).
 
Last edited:

audiobahn

New Member
Sep 29, 2021
23
1
3
Okay, so after going to version 200.09 and then updating it back to 200.10, I can happily say it starting behaving like I had hoped. I seem to now get a solid 250-350mbit all around the house and 65mbit to the outside world (compare that to 15mbit to the outside world and 250+ ms pings before the updates). I still haven't how the cheap router achieves 650-800mbit when you're in the same room as it, but I'd much rather have the reliable connection the R710 offers.
 

sth

Active Member
Oct 29, 2015
340
72
28
You should be able to easily match your previous AP. Id start by figuring out why you are getting a suboptimal connection.
Share with us what channel, SNR, frequency etc and we may be able to advise.
there are tools available to help diagnose issues and comparing and contrasting your old and new AP will be insightful.
Wifi explorer is good for one.
 

klui

Active Member
Feb 3, 2019
394
169
43
Maybe it's not getting enough power. What's the AP's connected switchport's negotiated max power?
 

audiobahn

New Member
Sep 29, 2021
23
1
3
You should be able to easily match your previous AP. Id start by figuring out why you are getting a suboptimal connection.
Share with us what channel, SNR, frequency etc and we may be able to advise.
there are tools available to help diagnose issues and comparing and contrasting your old and new AP will be insightful.
Wifi explorer is good for one.
Excluding the complete disaster of connectivity issues I had yesterday which got resolved with the firmware re-installs, the persistent 350mbit vs 650mbit issue seems to be specific to my iPhone. As you can see from the below survey the Ruckus seems to perform better in both signal strength and speed. Signal to Interface Ratio is also 8-12dB better too (Didn't include the heatmaps for that to avoid spamming the forum)

Channel Details (Left old router, Right R710)
5Ghz_Channels.png
Old Router Wireless Transmit Rate
TalkTalk.PNG
R710 Wireless Transmit Rate
Ruckus.PNG
From iPhone: Old Router (Spot 2 & 3 In same room and right next to it), R710 (Spot 1&4: In same room and right next to it). The phone really didn't like being right next to the R710...
IMG-4881.jpg
 

audiobahn

New Member
Sep 29, 2021
23
1
3
Maybe it's not getting enough power. What's the AP's connected switchport's negotiated max power?
It should be fine as I am powering it with the official Ruckus PoE+ injector. In settings I have also forced a 802.3at sync.
 
Last edited: