Quanta LB6M (10GbE) -- Discussion

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

c6100

Member
Oct 22, 2013
163
1
18
USA
Hi.

I just received my LB6M switch and what a cheap way to get 10G here at my home. Got it off Ebay for just around 250 USD :)

Now starting to configure the switch a few questions are coming up:
Is there a CLI command to verify the LACP channel is up and running?

I come from a Cisco background where I would use "show etherchannel" to verify the operating status of the channel.

Another funny thing. I tried to use a GLC-T RJ45 in the LB6M to connect a Cisco 3560E and the LB6M. Both ends come up with a link, and the Cisco switch will send out packets. But the LB6M does not receive any nor does it send out any packets.

I am using the Cisco TWINAX cables and SFP-10G-SR SFP+ modules to connect a couple of Cisco UCS C220 M3 servers with Fujitsu based Intel 520 cards inside the servers. That seem to work just fine.

and I have VMware NSX running between them in Hybrid mode for the VxLAN traffic :)

/Martin
What happens when you set the interface up that is using the GLC-T as speed 100?

(FASTPATH Routing) (Interface 0/1)#speed ?

10 Set speed to '10 Mbps'.
100 Set speed to '100 Mbps'.
 

Martin Kiefer

New Member
Nov 25, 2016
6
0
1
49
Hinnerup / Denmark
www.kiefer.dk
I just tried a simple performance test.

The setup was:
CentOS 6 with iperf3 -> VMware 6.0 with NSX on Cisco UCS C220 M3 -> Quanta LB6M -> VMware 6.0 with NSX on Cisco UCS C220 M3 -> CentOS 6 with iperf3

But I do not get more than around 4Gbit/s throughput from one linux to the other. Any idea was could cause this?

I am not using LACP, just a single link using an NSX virtual switch.
 

c6100

Member
Oct 22, 2013
163
1
18
USA
I just tried a simple performance test.

The setup was:
CentOS 6 with iperf3 -> VMware 6.0 with NSX on Cisco UCS C220 M3 -> Quanta LB6M -> VMware 6.0 with NSX on Cisco UCS C220 M3 -> CentOS 6 with iperf3

But I do not get more than around 4Gbit/s throughput from one linux to the other. Any idea was could cause this?

I am not using LACP, just a single link using an NSX virtual switch.
Curious, any data going through the Edge VM?
 

Martin Kiefer

New Member
Nov 25, 2016
6
0
1
49
Hinnerup / Denmark
www.kiefer.dk
No Edge VM involved, only L2

I just did the same tests without NSX involved:


[root@localhost ~]# iperf3 -c 10.0.10.101 -p 500

Connecting to host 10.0.10.101, port 500

[ 4] local 10.0.10.102 port 56325 connected to 10.0.10.101 port 500

[ ID] Interval Transfer Bandwidth Retr Cwnd

[ 4] 0.00-1.00 sec 681 MBytes 5.71 Gbits/sec 625 904 KBytes

[ 4] 1.00-2.00 sec 701 MBytes 5.88 Gbits/sec 1746 447 KBytes

[ 4] 2.00-3.00 sec 684 MBytes 5.74 Gbits/sec 1116 467 KBytes

[ 4] 3.00-4.00 sec 708 MBytes 5.94 Gbits/sec 749 645 KBytes

[ 4] 4.00-5.00 sec 630 MBytes 5.28 Gbits/sec 1257 171 KBytes

[ 4] 5.00-6.00 sec 531 MBytes 4.46 Gbits/sec 1133 792 KBytes

[ 4] 6.00-7.00 sec 295 MBytes 2.47 Gbits/sec 1760 853 KBytes

[ 4] 7.00-8.00 sec 728 MBytes 6.11 Gbits/sec 1302 669 KBytes

[ 4] 8.00-9.00 sec 458 MBytes 3.84 Gbits/sec 2146 97.6 KBytes

[ 4] 9.00-10.00 sec 537 MBytes 4.50 Gbits/sec 1186 936 KBytes

- - - - - - - - - - - - - - - - - - - - - - - - -

[ ID] Interval Transfer Bandwidth Retr

[ 4] 0.00-10.00 sec 5.81 GBytes 4.99 Gbits/sec 13020 sender

[ 4] 0.00-10.00 sec 5.81 GBytes 4.99 Gbits/sec receiver


And with NSX:
[root@localhost ~]# iperf3 -c 10.0.10.101 -p 500

Connecting to host 10.0.10.101, port 500

[ 4] local 10.0.10.102 port 56327 connected to 10.0.10.101 port 500

[ ID] Interval Transfer Bandwidth Retr Cwnd

[ 4] 0.00-1.00 sec 410 MBytes 3.44 Gbits/sec 386 652 KBytes

[ 4] 1.00-2.00 sec 461 MBytes 3.87 Gbits/sec 208 588 KBytes

[ 4] 2.00-3.00 sec 447 MBytes 3.75 Gbits/sec 237 707 KBytes

[ 4] 3.00-4.00 sec 465 MBytes 3.90 Gbits/sec 162 882 KBytes

[ 4] 4.00-5.00 sec 464 MBytes 3.90 Gbits/sec 324 732 KBytes

[ 4] 5.00-6.00 sec 466 MBytes 3.91 Gbits/sec 143 874 KBytes

[ 4] 6.00-7.00 sec 374 MBytes 3.14 Gbits/sec 426 759 KBytes

[ 4] 7.00-8.00 sec 468 MBytes 3.93 Gbits/sec 192 730 KBytes

[ 4] 8.00-9.00 sec 368 MBytes 3.09 Gbits/sec 676 840 KBytes

[ 4] 9.00-10.00 sec 189 MBytes 1.58 Gbits/sec 2058 150 KBytes

- - - - - - - - - - - - - - - - - - - - - - - - -

[ ID] Interval Transfer Bandwidth Retr

[ 4] 0.00-10.00 sec 4.02 GBytes 3.45 Gbits/sec 4812 sender

[ 4] 0.00-10.00 sec 4.01 GBytes 3.45 Gbits/sec receiver


There is a 1Gbit/s difference in favour of the non NSX.
 

c6100

Member
Oct 22, 2013
163
1
18
USA
I am trying to get inter-vlan working, below is the config show I setup vlan routing:

vlan routing 10 1
vlan routing 40 2

interface 0/1
description '***HOST1***'
set igmp
vlan participation include 10,40
vlan tagging 10,40


interface 2/1
routing
ip address 10.0.0.62 255.255.255.192
exit
interface 2/2
routing
ip address 10.0.0.253 255.255.255.128

------
show ip interface b

Interface State IP Address IP Mask Method
---------- ----- --------------- --------------- -------
2/1 Down 10.0.0.62 255.255.255.192 Manual
2/2 Down 10.0.0.253 255.255.255.128 Manual

------------

What is needed to get the virtual interfaces up so the vlan can be pinged?
 

Terry Kennedy

Well-Known Member
Jun 25, 2015
1,142
594
113
New York City
www.glaver.org
I am trying to get inter-vlan working, below is the config show I setup vlan routing:

[big snip]

What is needed to get the virtual interfaces up so the vlan can be pinged?
I'm not familiar with this specific switch model and don't use routing on the one switch I have running FASTPATH. On a Cisco switch, you'd have something like:

Code:
ip routing
;
interface vlan 1
ip address a.b.c.d x.x.x.x
interface vlan 2
ip address w.x.y.z x.x.x.x
;
interface tengigabitethernet 2/1
switchport mode access
switchport access vlan 1
interface tengigabitethernet 2/1
switchport mode access
switchport access vlan 1
One thing I noticed about your example is the inconsistent netmask (/25 vs. /26) on your 10.0.0.0/24 subnets. It's allowable, since there is no overlap, but may not be what you were trying to achieve.

Edit: You may not even need routing - you have a trunk to your HOST1 on port 1/1. Assuming the host is set up for a trunk, it should be able to reach both the system on 2/1 and the one on 2/2. Is there something not included in the piece of the configuration you posted that needs routing? You could also enable routing on HOST1, assuming it has enough performance, and let it handle the routing for you.
 

c6100

Member
Oct 22, 2013
163
1
18
USA
I'm not familiar with this specific switch model and don't use routing on the one switch I have running FASTPATH. On a Cisco switch, you'd have something like:

Code:
ip routing
;
interface vlan 1
ip address a.b.c.d x.x.x.x
interface vlan 2
ip address w.x.y.z x.x.x.x
;
interface tengigabitethernet 2/1
switchport mode access
switchport access vlan 1
interface tengigabitethernet 2/1
switchport mode access
switchport access vlan 1
One thing I noticed about your example is the inconsistent netmask (/25 vs. /26) on your 10.0.0.0/24 subnets. It's allowable, since there is no overlap, but may not be what you were trying to achieve.

Edit: You may not even need routing - you have a trunk to your HOST1 on port 1/1. Assuming the host is set up for a trunk, it should be able to reach both the system on 2/1 and the one on 2/2. Is there something not included in the piece of the configuration you posted that needs routing? You could also enable routing on HOST1, assuming it has enough performance, and let it handle the routing for you.
Thanks for replying but I am coming off a Cisco switch and unfortunately the config is much different so what you have would not work. This is a vmw host which is why I need a trunk.

From what I understand on this switch, 2/1 and 2/2 are the logical interfaces which map back to the vlan routing statements above.

I just need someone to confirm.

Sent from my Nexus 6P using Tapatalk
 

av00va

Member
Dec 10, 2015
53
5
8
34
My LB6M came in today with 1.2.0.3 FP Routing on it. I want to upload it since it seems newer, but it's not communicating with my laptop. I tried two ports. conf, ip routing, int 0/27, no shut, ip address 192.168.4.1 255.255.255.0. I've also tried setting up vlan 1 and vlan 2 and giving them a subnet. No matter what I do I cant ping my laptop/tftp server. Help?
 
  • Like
Reactions: fvanlint

tbg

New Member
Dec 12, 2016
8
5
3
49
Hi, new here.

I was looking at getting an LB6M, but i wanted to find some information on how loud it really is with stock fans.
As I have gotten older i have become less tolerant of noisy stuff in my home rack to the point of ending up with a few things i didn't end up using.
My current switches are 2 nortel baystack 5510-48t if that helps for a comparison.
I would really like to add some 10gbe ports, but i just don't want to end up with another thing not being used because of the noise.
 

av00va

Member
Dec 10, 2015
53
5
8
34
Hi, new here.

I was looking at getting an LB6M, but i wanted to find some information on how loud it really is with stock fans.
As I have gotten older i have become less tolerant of noisy stuff in my home rack to the point of ending up with a few things i didn't end up using.
My current switches are 2 nortel baystack 5510-48t if that helps for a comparison.
I would really like to add some 10gbe ports, but i just don't want to end up with another thing not being used because of the noise.
I work in a datacenter and expected these switches to be louder than people made them out to be. Our complex uses a lot of LB6Ms (they're being phased out but there still are some), and you'd know when they were ramping up. Turns out when there's just one, the noise is pretty tolerable. As long as you weren't nearing the capacity of the switch, you could probably sleep in the same room as one. Now if the fans kick up... that's a different story

Sent from my SM-N910V using Tapatalk