Quanta LB6M (10GbE) -- Discussion

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
Yeah, I think having the same ip for your switch as another router on the same subnet/network might cause problems. I mean, if you wanna log into your router, will it say "cannot connect" as it is seeing the ip for the switch and not the router? Remember, the switch doesn't have a http/gui server as yet (looking at you, Sorin) so it depends on what may come up when you type in your default gateway address.

If it works, and you see your router gui instead of the switch responding with "cannot connect", then you are good i guess. That would mean the switch only would respond to ssh on that ip address which is cool, but make sure you turn off ssh to the router, or else who knows what type of universe shattering time-paradox you may unleash my friend!
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
As far as Vlans go, you should be able to have the signal pass through to the switch from the pc on the Vlan through ssh. I don't see why it wouldn't work. Test it though. If you get a problem, it would mean a disparity between the Vlan and the main ip of the switch. I am not too perfect with Vlans as I must admit I don't use 'em. It should work though, as the machine would have a static ip you set on the Vlan.

At least I think that is right...

Pretty sure....

Mostly...

Just kidding Josh, I think that setup is fine.
 

josh

Active Member
Oct 21, 2013
597
178
43
Yeah, I think having the same ip for your switch as another router on the same subnet/network might cause problems. I mean, if you wanna log into your router, will it say "cannot connect" as it is seeing the ip for the switch and not the router? Remember, the switch doesn't have a http/gui server as yet (looking at you, Sorin) so it depends on what may come up when you type in your default gateway address.
I don't think you're getting my setup. The gateway router is set to 192.168.1.1 while the LB6M is set to 192.168.1.254. They just share the same subnet. I'm getting "request timed out" when I ping the LB6M but the IP 192.168.1.254 shows up in the ARP.

Posting this again from earlier:

#show network

Interface Status............................... Up
IP Address..................................... 192.168.1.254
Subnet Mask.................................... 255.255.255.0
Default Gateway................................ 192.168.1.1
Burned In MAC Address.......................... X:X:X:X:1B:47
Locally Administered MAC address............... 00:00:00:00:00:00
MAC Address Type............................... Burned In
Configured IPv4 Protocol....................... None
Management VLAN ID............................. 1
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
Hmm... I see.

Where does your dhcp server ip range start from in your router? Example: 192.168.1.1 - 192.168.1.254?

It may give problems if the switch's default ip address is set within the whole lan network dhcp range. May be the reason the switch is timing out on ping. I usually set my router dhcp ip range to start at 100 and set the limit to 200. Example: 192.168.1.100 - 192.168.1.200

But first and foremost, you have the switch ip address set to 192.168.1.254

This is what might be wrong my friend. I really think that this has to be set to anything other than this. Try for a smaller ip address for the switch like: 192.168.1.5

I only say this because sometimes, the end address of 192.168.1.254 is sorta reserved in the ip address space sometimes by pnp devices on a network. It depends though. I personally never use the last ip address number.

You can still use the ip address you set for the switch (192.168.1.254) if you exclude it from your dhcp range I believe.

So, for example, set your Router's dhcp server ip address range to start at something like 192.168.1.100 and set the end ip range to 192.168.1.200, then set the lb6m ip address to 192.168.1.5, (or any number outside of the dhcp range) and the default gateway address should remain 192.168.1.1.

This should fix your problem my friend.
 
Last edited:

josh

Active Member
Oct 21, 2013
597
178
43
I've already tried that. It doesn't work. I can't even ping the gateway from the switch.
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
Why do you need to ping the gateway from the switch my friend? The LB6M should have a static Ip that you ping the switch from your PC through ssh. Not sure why you need the other way around, but the feature is there.

Hmm.. ok, might be better to clear your config and start over. Perhaps something probably got mixed up when you configured the first time? But first, let me tell you my settings.

So, I have the LB6M ip address set to 192.168.0.5
I have the gateway set to 192.168.0.1, this matches the default gateway of my router, so both devices will share the same subnet. this is right as you know:

(FASTPATH Routing) #show network

Interface Status............................... Up
IP Address..................................... 192.168.0.5
Subnet Mask.................................... 255.255.255.0
Default Gateway................................ 192.168.0.1
Burned In MAC Address.......................... xx:xx:xx:xx:xx:xx
Locally Administered MAC address............... 00:00:00:00:00:00
MAC Address Type............................... Burned In
Configured IPv4 Protocol....................... None
Management VLAN ID............................. 1

(FASTPATH Routing) #

I then set my dhcp range in my router to 100-200 (192.168.0.100-192.168.0.200) and I have the LB6M at 192.168.0.5 and my access point set at 192.168.0.2

When I try to ping the switch/log in through ssh, it works as the network sees the address of the switch, which is outside of the dhcp range set on my router. Same for my wireless access point.

So, now, I wonder my friend, I know you said you followed all the instructions on the post, but can you confirm that you:

1. Used the command "network protocol none" (turns off dhcp on the switch, very important)
2. Enabled ssh server? "ip ssh server enable"
3. Disabled telnet? "no ip telnet server enable"
4. After all config settings, you used the "write memory" command to save it to config memory? This is important if you rebooted the switch after changing settings
5. Heck, even try rebooting your router, then check and make sure the PC that you are trying to ssh into the switch, is on the same subnet too. (Network adapter settings if using Windows)

Of note, after setting the ip address and confirming your settings with "show network" you can then use the regular ports 25-28 to connect through ssh. The management ports may not work as well for ssh after you set the static ip.

Let us know if this worked my friend. Don't give up or get frustrated. We are all here to help. If I can't help you, someone else reading this will stop by and offer assistance. I will continue to do my best though. The commands work great, so there might just be something in your setup that isn't configured right. We will keep trying.
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
Also, of note, if you have jumbo frames enabled on your pc and not on the switch, you will not be able to ping anything. I found that out the hard way my friend. The switch has to have the interfaces/ports enabled to pass through jumbo frames as they aren't enabled by default. It wasn't until I discovered this, I was able to ping the switch from my pc after turning jumbo frames off on my network adapter. I then got the commands to enable jumbo frames on the switch from the guys in the thread here. Once enabled, I then turned back on jumbo frames on my PC and then it worked. I included this info in my post as well.

So just in case:

Enable Jumbo Frames across all Interfaces:

1) Login (SSH or Telnet)
2) Type: enable (press enter, when ask for password if one is set, enter it, if not set, leave blank, press enter)
3) Type: config (press enter, if ask for password if one is set, enter it, if not, leave blank, press enter)
4) Type: interface 0/1-0/28
5) Type: mtu 9216 (This is the maximum amount you can put on an interface I believe. This particular number is used, so that even if varying jumbo frame numbers are set across different interfaces in different pc's/servers, (ex. 9000, 9014, 9028, etc...)the interface/port will be able to handle it as 9216 is obviously higher.
6) Type: exit
7)Type: exit (yes, again)
8) Finally Type: write memory"
9) Type: exit
10) Logout/Quit/Exit your ssh/telnet session.

Who knows, this may the source of your problems....
 
Last edited:

josh

Active Member
Oct 21, 2013
597
178
43
Also, of note, if you have jumbo frames enabled on your pc and not on the switch, you will not be able to ping anything. I found that out the hard way my friend. The switch has to have the interfaces/ports enabled to pass through jumbo frames as they aren't enabled by default. It wasn't until I discovered this, I was able to ping the switch from my pc after turning jumbo frames off on my network adapter. I then got the commands to enable jumbo frames on the switch from the guys in the thread here. Once enabled, I then turned back on jumbo frames on my PC and then it worked. I included this info in my post as well.
I have jumbo frames on my switch but not on my PC. That shouldn't be a problem right?
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
Well, the switch should have jumbo frames enabled, so that's fine, and your network adapter can send the regular frames through the jumbo enabled ports on the switch, so that is ok. Shouldn't be a problem, but I would test with it enabled and disabled in my PC just to be safe. The switch can always have jumbo frames enabled on all ports.

Are you still not able to ping the switch or log in through ssh? Did you try to ssh through any of the 4 ports 25-28 instead of the management ports?
 
Last edited:

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
After going back and reading through the thread, I realized that I missed something. You can actually ssh into the switch through the management ports if you set a static ip address. This is done by setting the serviceport ip address. (Big thanks to djflow195)

So, login, then type "enable"

then type: serviceport protocol none
then type: serviceport ip (your static ip you wanna set) (your subnet mask) (your default gateway ip address)

Example: serviceport ip 192.168.1.10 255.255.255.0 192.168.1.1

if that doesnt work, try serviceport parms followed by your ip address and subnet mask and default gateway.

Type: write memory, then press Y.

Then you should be able to ssh into the switch using the management ports.
 
Last edited:
  • Like
Reactions: Chuntzu

josh

Active Member
Oct 21, 2013
597
178
43
After going back and reading through the thread, I realized that I missed something. You can actually ssh into the switch through the management ports if you set a static ip address. This is done by setting the serviceport ip address. (Big thanks to djflow195)

So, login, then type "enable"

then type: serviceport protocol none
then type: serviceport ip (your static ip you wanna set) (your subnet mask) (your default gateway ip address)

Example: serviceport ip 192.168.1.10 255.255.255.0 192.168.1.1

Type: write memory, then press Y.

Then you should be able to ssh into the switch using the management ports.
YES. This is exactly what I'm looking for. Thanks! This works for MGNT1 but what is MGNT2 called?
 

josh

Active Member
Oct 21, 2013
597
178
43
Also, is there a similar command for the Cisco "no switchport" command? Trying to configure 0/28 with an uplink to the internet router. The manual has a whole plethora of "switchport xxx" commands which don't seem to be what I'm looking for. "The no switchport command makes the interface Layer 3 capable. The IP address is in the same subnet as the default router."

Switch(config)#interface FastEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 200.1.1.1 255.255.255.0
Switch(config-if)#no shutdown
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
Glad we got a breakthrough there for ya! I think mgmt 2 port is for failover/insurance in case mgmt port 1 goes down. Test to see if you can login with the ip address you set on mngt port 1. if it doesn't work, then you may need to set the ip for mgmt port 2. Perhaps serviceport 2?
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
I don't think the switch actually does layer 3. The firmware shows dregs of it because it is a firmware that was written to match other quanta products i believe. I am not too positive on this though. Last I heard, I don't think the LB6M can do Layer 3. It would be nice to have though.
 

Toby

New Member
May 6, 2016
17
4
3
48
Also, is there a similar command for the Cisco "no switchport" command? Trying to configure 0/28 with an uplink to the internet router. The manual has a whole plethora of "switchport xxx" commands which don't seem to be what I'm looking for. "The no switchport command makes the interface Layer 3 capable. The IP address is in the same subnet as the default router."

Switch(config)#interface FastEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 200.1.1.1 255.255.255.0
Switch(config-if)#no shutdown
I think what you're looking for is "Port Routing" instead of "VLAN routing".

Here is some info from a manual I downloaded at some point. I tested it and my LB6M does support this "routing" command on the interface.

Code:
Use the following commands to enable routing for ports on the switch. The default link-level encapsulation format is Ethernet. Configure the IP addresses and subnet masks for the ports. Network directed broadcast frames are dropped and the maximum transmission unit (MTU) size is 1500 bytes.
Please note, setting upPort based routing is not possible on all Kontron products, e.g. CP6923 does not provide this feature, but Routing must be configured based on VLANs.
(Ethernet Fabric) #config
(Ethernet Fabric) (Config) #interface 0/2
(Ethernet Fabric) (Config) (Interface 0/2) #routing
(Ethernet Fabric) (Config) (Interface 0/2) #ip address 192.150.2.2 255.255.255.0
(Ethernet Fabric) (Config) (Interface 0/2) #exit
(Ethernet Fabric) (Config) #exit
(Ethernet Fabric) (Config) #config
(Ethernet Fabric) (Config) #interface 0/3
(Ethernet Fabric) (Config) (Interface 0/2) #routing
(Ethernet Fabric) (Config) (Interface 0/2) #ip address 192.130.3.1 255.255.255.0
(Ethernet Fabric) (Config) (Interface 0/2) #exit
(Ethernet Fabric) (Config) #exit
(Ethernet Fabric) (Config) #config
(Ethernet Fabric) (Config) #interface 0/5
(Ethernet Fabric) (Config) (Interface 0/2) #routing
(Ethernet Fabric) (Config) (Interface 0/2) #ip address 192.64.4.1 255.255.255.0
(Ethernet Fabric) (Config) (Interface 0/2) #exit
(Ethernet Fabric) (Config) #exit
I don't think the switch actually does layer 3. The firmware shows dregs of it because it is a firmware that was written to match other quanta products i believe. I am not too positive on this though. Last I heard, I don't think the LB6M can do Layer 3. It would be nice to have though.
Of course it does "Layer 3". It supports VLAN's and routing of those VLAN's. So yes, that is layer 3. It does IPV4 routing, but no IPv6. That's the only piece I really am missing that I need.

Oh and Slyek, I can't help you with any more information on LACP than I already gave everyone in the post I made. I posted exact snips from my config. That's about the best I can explain it.
 

keoki

New Member
Jun 2, 2016
21
19
3
60
I generally prefer VLAN routing, as it gives me the ability to have more flexibility and control over the network ports. It gives you a one size fits all configuration, so a single layer 3 point to point port has the same general configuration as ports you use for a multi-port vlan, and le lets you move the physical port of of a layer 3 ptp connection to another switch in your stack... But then I have operated a number of networks where you have arbitrarily large numbers of switches, and lots of redundancy, but once I became comfortable with vlan routing, I configure all of my networks this way, even at home. This is really handy when you have failover ports from a offsite location that are configured for separate building entry, and you have your core switches spread across the physical space. When a big disaster strikes a facility and takes down a couple of isles, it is handy to have your redundant core gear spread across some distance, so hopefully half of it remains up. But the bottom line is that a port is a port on the outside, so picking one over the other doesn't affect the physical wiring, it is more of a choice on picking flexibility over hard configuring a single port. I suppose there could be some advantage to port based routing as well, for example if you have a failover event, and you need a port to go down to trigger failover because of some feature your failover requires... But the best examples of that I can think of are not ethernet protocols, so it is more of a guess than a real example.

I like to have all of my layer three configurations consistent, and sometimes a new application comes along that requires a second vlan on a port. For example I have some access equipment that I support, and the proprietary SFP's are $2500 each. So rather than spend $5000 to have a trunk AND a management interface, I spend $2500 for a single port, and configure trunking for the access paths, and set the port-native access vlan to the management vlan.

I say all of this from many years experience running Cisco based networks where I use trunks everywhere I might have more than one logical network path, and the physical speed is much greater than the speed of the normal traffic. I just got my LB6M today, and I have not yet had a chance to dive into this aspect of configuration yet, so I could easily change my mind.

I didn't always prefer VLAN routing over port routing. But that was only because I started out with port based routing before the vlan standards were developed, so port layer 3, and port bridging was pretty much all I knew back then. The first time I stepped into a really large environment, the advantages of keeping all of the layer 3 on VLANS seemed elegant to me, and it is simply how it is done in many environments for many reasons. You CAN mix the techniques, but anytime you mix configuration techniques, you increase debug time, and create complexity.

I saw one blog from someone that works for a company that writes network monitoring systems, and he went on and on about how his network has no vlans, and never will have a vlan, and how vlans make things harder to debug, harder to understand, and in his 20 years of experience he never found a use for a vlan. The blog comments were divided with lesser experienced people thanking him for his words of wisdom, and enterprise network experts that could rattle-off endless reasons vlans were important and made things easier to debug. The point here is that once you learn how to use vlans for everything in your switch gear, AND layer 3 devices, you should find that configurations can scale much easier, and many network configuration design changes can be made from your desk without moving a lot of wires constantly, so your patch bays stay cleaner, and your knowledge of how the network goes together is easier to document and support.

And a final treason is it allows you to entertain self-configuring designs. The hospital network I ran had ports that configured themselves after you plugged into the port. So any ethernet port anywhere was set up for anyone to use it. The port joined the vlan appropriate for your machine, and if you had no business in the port, or were a guest, you were handed off to a captive portal vlan. It does not get more elegant than that. And if you have thousands of switches, 10's of thousands of ports, and rigid configuration change management procedures, elegant solutions are a godsend.

Yes, learning the ways vlans can be used is some work, and may seem like overkill for just one switch at home. But it is easy (once you learn it) scalable, flexible, and can make the difference between a network admin earning 44k per year, and being a network expert making $150k.

I'm sorry if I come off a bit opinionated. I /am/ very opinionated. But I have also been building networks for some 30 years, some really large, and some really small. Vlans don't make sense everywhere, but they are used in surprising places. Millions of people have them in their homes, as many ISP's use them to split Internet, voice, multicast video and management networks

Sleyk, this is what comes out when I scream like a gorilla... ;)
 
Last edited:
  • Like
Reactions: King Keroppi

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
heheh...gorilla....

Godzilla's scream is totally louder!

Keoki my friend, was that entire monlogue to convince me to use vlans?

No worries friends! I am in the process of learning how to use 'em and how it can apply in my network.

I am all about learning new things and gaining new knowledge, so I have actually already started reading up on the basics. I hate not knowing about something that can be useful or integral to me, and if it is something that I can learn that can also help others, then I'm all for it.

I will be reading up on Layer 3 as well. Still a fighting noob when it comes to networking, but I know enough to get me up and running. Will do my due diligence.

Heheh....diligence...

Oh, and Toby, thanks, I will try to piece it together from your post and include it in the document. Thanks!
 
Last edited:

josh

Active Member
Oct 21, 2013
597
178
43
Glad we got a breakthrough there for ya! I think mgmt 2 port is for failover/insurance in case mgmt port 1 goes down. Test to see if you can login with the ip address you set on mngt port 1. if it doesn't work, then you may need to set the ip for mgmt port 2. Perhaps serviceport 2?
Tried that. Didn't work. Does not pick up the IP set under serviceport.

I think what you're looking for is "Port Routing" instead of "VLAN routing".

Here is some info from a manual I downloaded at some point. I tested it and my LB6M does support this "routing" command on the interface.

Code:
Use the following commands to enable routing for ports on the switch. The default link-level encapsulation format is Ethernet. Configure the IP addresses and subnet masks for the ports. Network directed broadcast frames are dropped and the maximum transmission unit (MTU) size is 1500 bytes.
Please note, setting upPort based routing is not possible on all Kontron products, e.g. CP6923 does not provide this feature, but Routing must be configured based on VLANs.
(Ethernet Fabric) #config
(Ethernet Fabric) (Config) #interface 0/2
(Ethernet Fabric) (Config) (Interface 0/2) #routing
(Ethernet Fabric) (Config) (Interface 0/2) #ip address 192.150.2.2 255.255.255.0
(Ethernet Fabric) (Config) (Interface 0/2) #exit
(Ethernet Fabric) (Config) #exit
(Ethernet Fabric) (Config) #config
(Ethernet Fabric) (Config) #interface 0/3
(Ethernet Fabric) (Config) (Interface 0/2) #routing
(Ethernet Fabric) (Config) (Interface 0/2) #ip address 192.130.3.1 255.255.255.0
(Ethernet Fabric) (Config) (Interface 0/2) #exit
(Ethernet Fabric) (Config) #exit
(Ethernet Fabric) (Config) #config
(Ethernet Fabric) (Config) #interface 0/5
(Ethernet Fabric) (Config) (Interface 0/2) #routing
(Ethernet Fabric) (Config) (Interface 0/2) #ip address 192.64.4.1 255.255.255.0
(Ethernet Fabric) (Config) (Interface 0/2) #exit
(Ethernet Fabric) (Config) #exit
Does setting an IP + routing for an individual port mean that all traffic over that subnet will be routed through that port itself? I've done this on the port I want to use (0/28) as well as set the frames to untagged and I'm just wondering if there's anything else I need to do to let the switch know that I don't want it to be a trunk port and I just want it to forward all external traffic through this port. I've also set a default gateway as the gateway on my (0/28) subnet but it doesn't show up under #route.

Oh is there a way to set a port as a trunk for all VLANs instead of adding each individual VLAN to the port? There's no switchport mode trunk command.
 

Caleb

Member
Nov 16, 2015
39
8
8
34
I followed every step in that post. I've used the console port to set up more than the management IP. I've set up VLANs and interVLAN routing. The IP on #show network is static. Does it matter that 192.168.1.1 (gateway IP) is the address of another router which serves as a gateway to the internet and also runs a DHCP server?

Also, if I connect machines to a VLAN with an IP address set, does it mean that this IP serves as the IP to the switch and can be used for SSH as well?
From my rudimentary understanding of networking, I believe your gateway IP should indeed be the IP of your edge router.
 

Sleyk

Your Friendly Knowledgable Helper and Techlover!
Mar 25, 2016
1,346
687
113
Stamford, CT
Yeah, I think he has it set for that, he was just unable to ping with the ip of the network ports set at 192.168.1.254

I think though, he was still trying to connect through the management ports and not the network ports, which is why he couldn't ping.

We were able to set the management port ip address, so now he can ssh into the switch through management port 1, but I am not sure of how to set an ip for management port 2. I will look it up in the manual.