PLEASE DELETE: OmniOS: 'zpool set autoexpand=on poolname' not working

AveryFreeman

ESXi + ( ILLUMOS / ZFS ) = HAPPY
Mar 17, 2017
165
19
18
39
Near Seattle
averyfreeman.com
Hey,

I'm running:

Code:
SunOS napp-it01 5.11 omnios-r151030-1b80ce3d31 i86pc i386 i86pc illumos
Have two z-mirror pools, four 2TB drives each pool, want to replace all 2TB drives with 4TB drives I just ordered. Should be here in a few days, so I'm trying to prepare for when they arrive.

I can see that the autoexpand setting is set to off on all the current pools:

Code:
root@napp-it01:~# zpool get autoexpand hitachi
NAME     PROPERTY    VALUE   SOURCE
hitachi  autoexpand  off     default
But I cannot appear to be able to set autoexpand=on on existing pools. Ex:

Code:
root@napp-it01:~# zfs set autoexpand=on hitachi
cannot set property for 'wdgreen': invalid property 'autoexpand'
Is there a step I'm missing?

EDIT: Moderator please delete this thread, it's obvious I was just using the wrong command (zfs vs zpool)

Thanks!
 
Last edited: