Perc H710 Mini to IT mode

blindive

New Member
Feb 11, 2020
6
1
1
will make the requisite dedicated threads on the popular internet holes tonight but for now have at it, feedback welcome Introduction - Fohdeesha Docs
I had a go with the D1 guide, and seems to be a problem:



user@debian:~$ sudo su -
root@debian:~# D1-H710
rmmod: ERROR: Module megaraid_sas is not currently loaded
rmmod: ERROR: Module mptctl is not currently loaded
rmmod: ERROR: Module mptbase is not currently loaded
Errors above are normal!
Trying unlock in MPT mode...
Device in MPT mode
Device in MPT mode
Resetting adapter in HCB mode...
Trying unlock in MPT mode...
Device in MPT mode
IOC is RESET
Device in MPT mode
Resetting adapter in HCB mode...
Trying unlock in MPT mode...
Device in MPT mode
IOC is RESET
Setting up HCB...
HCDW virtual: 0x7faa09400000
HCDW physical: 0x7f9e00000
Loading firmware...
Loaded 809436 bytes
Booting IOC...
IOC is READY OPERATIONAL FAULT
IOC Host Boot successful.
Device in MPT mode
Removing PCI device...
Rescanning PCI bus...
PCI bus rescan complete.
Pausing for 20 seconds to allow the card to boot

LSI Logic MPT Configuration Utility, Version 1.72, Sep 09, 2014

0 MPT Ports found

LSI Logic MPT Configuration Utility, Version 1.72, Sep 09, 2014

0 MPT Ports found
All Done! Continue following the guide to set SAS addr
root@debian:~# reboot


=====

user@debian:~$ sudo su -
root@debian:~# setsas my-id-from-earlier
LSI Corporation SAS2 Flash Utility
Version 20.00.00.00 (2014.09.18)
Copyright (c) 2008-2014 LSI Corporation. All rights reserved

No LSI SAS adapters found! Limited Command Set Available!
ERROR: Command Not allowed without an adapter!
ERROR: Couldn't Create Command -sasadd
Exiting Program.
root@debian:~# info
LSI Corporation SAS2 Flash Utility
Version 20.00.00.00 (2014.09.18)
Copyright (c) 2008-2014 LSI Corporation. All rights reserved

No LSI SAS adapters found! Limited Command Set Available!
ERROR: Command Not allowed without an adapter!
ERROR: Couldn't Create Command -c
Exiting Program.
 
Last edited:

fohdeesha

Kaini Industries
Nov 20, 2016
2,491
2,668
113
31
fohdeesha.com
Booting IOC...
IOC is READY OPERATIONAL FAULT
IOC Host Boot successful.
Hmm, the D1 guide is the one that's been tested the most and nobody else has had errors, so you probably forgot a command somewhere. In fact, that output is the exact output we got when we didn't run the cleaning step in FreeDOS first. Did you follow the introduction page instructions and the FreeDOS instructions first: EG booting into the FreeDOS live ISO and running "D1CROSS"

I would follow the guide from the beginning again, being sure to run "D1CROSS" in freedos first. Send me a screenshot of the end of the freedos output after running this

also be absolutely sure there's no other LSI based controllers in the system
 

blindive

New Member
Feb 11, 2020
6
1
1
Thanks, I did run the freedos commands first. Will try again tomorrow and reply in the new thread.
 

lbong

New Member
Nov 5, 2017
1
0
1
52
I have a bunch of Dell servers that I can test. One of them is

Product Name: PERC H710P Adapter
ChipRevision: D1
SAS Address: XXXX

when I run the "info" command. Will the H710p mini firmware works ?

Thank you
 

dcol

New Member
Jul 13, 2020
3
0
1
Is there a way to just load the stock LSI IR firmware? I have an H710p, full size, that is not able to run 4Kn drives. From what I read, the stock LSI cards can use 4Kn sector drives. I think Dell has a firmware restriction to block these 4Kn drives. I have HGST 8TB 4Kn drives that only have 918GB available with the stock Dell firmware.
 

Spartacus

Well-Known Member
May 27, 2019
786
326
63
Austin, TX
Is there a way to just load the stock LSI IR firmware? I have an H710p, full size, that is not able to run 4Kn drives. From what I read, the stock LSI cards can use 4Kn sector drives. I think Dell has a firmware restriction to block these 4Kn drives. I have HGST 8TB 4Kn drives that only have 918GB available with the stock Dell firmware.
Try updating the firmware from dell’s site pretty sure they support 4k drives on the later updates.
Strike that
Now that i think again i dont think any of the controller prior to PERC9 support 4k.
 

dcol

New Member
Jul 13, 2020
3
0
1
But what if I load the stock LSI IR firmware? I have eight of these 8TB 4Kn drives. Can I pop in a different controller? I know the H730's should work, but the cabling is different.
 

dcol

New Member
Jul 13, 2020
3
0
1
Does anyone know if using 4Kn drives with the H710 is just a firmware restriction with the Dell version? Can the equivalent LSI card use 4Kn drives?
If not, can anyone recommend a drop in replacement? Has anyone tried using an H730 with a cable adapter?
 

krisden

New Member
Nov 30, 2020
1
0
1
Hello, first BIG thanks to who permits all peoples (like me :D) to be able to use one Perch H710-D1 (PE T320) in IT mode.
Need this stuff to install Promox-6 raid-10 zfs ; in addition, I've to flash the controller with x64 blob to be able to boot the system.
PVE related => I added a 15 delay in
Code:
ZFS_INITRD_PRE_MOUNTROOT_SLEEP
otherwise delay was not sufficient...
SMACK ;)