Oof

sboesch

Active Member
Aug 3, 2012
427
43
28
Columbus, OH
I am running TrueNAS-12.0-BETA2.1. When attempting to replace the disk via the GUI it fails with an error stating the disk is too small. I removed all the partitions from the replacement disk, same error. I tried another disk, same error. It's BETA! LOL! I was able to replace the disk via the shell just fine using the zfs replace command. It's BETA! I have to remind myself that it's BETA!
Screenshot from 2020-09-01 21-12-46.png
 
  • Like
Reactions: vangoose

Mithril

Active Member
Sep 13, 2019
140
40
28
So one of the things I personally do with ZFS is to never, ever, not once ever again trust a GUI when creating disks/pools. As a consumer/prosumer it's unlikely I have a stack of exact same model disks ready to go just sitting unused (and there's something to be said to not having a disk monoculture as well).

Why is that? Size differences, "8TB" may not be the exact same number of bytes between brands, or even models!

So what I always do is preformat (also giving disks nice useful gptid names) to a nice roundish number leaving the last few hundred mb empty, then import/replace at the commandline.

Once burned, twice shy :-/
 
  • Like
Reactions: sboesch