OmniOS 151036 stable

gea

Well-Known Member
Dec 31, 2010
2,535
856
113
DE
The next OmniOS 151036 stable is available later this year.
If you want to test new OmniOS features you can use OmniOS bloody 151035 (pre release of 151036)

The new OmniOS version is supported up from napp-it free 18.12w6, 19.12b12 home, 20.6a3 Pro or 20. dev from Aug 12.
 
  • Like
Reactions: gb00s

gea

Well-Known Member
Dec 31, 2010
2,535
856
113
DE
OmniOS stable 151036 is out

Some improvements:

SMB 3.1.1 (ZFS/kernelbased SMB server)
Improvements on Linux/LX zones
Improvements on Bhyve virtualizer
ZFS can use hardware acceleration for Raid-Z
Improved support for Mellanox ConnectX-4/5/6 , i40e and bge nic devices
gcc10 is now default compiler
 
Last edited:
  • Like
Reactions: gb00s

BullCreek

New Member
Jan 5, 2016
16
5
3
52
Does the SMB 3.1.1 stuff mean that it will be possible to use nappit for time machine backups again over SMB instead of AFP?
 

gea

Well-Known Member
Dec 31, 2010
2,535
856
113
DE
I have not tried but I do not asume that Illumos took away Apple extensions that allow TM over SMB out of the box.
 

nle

Member
Oct 24, 2012
201
11
18
I've run TimeMachine over SMB for years I think.

I have this in my Bonjour/mDNS settings:

Code:
dns-sd -R "<name>" _adisk._tcp local sys=waMa=0,adVF=0x100 &
dns-sd -R "<name>" _adisk._tcp local dk0=adVN=<smb-share>,adVF=0x82 &
If you google that, you should get a few hits that explains it.

My whole setting, with icons and etc.
Code:
dns-sd -R "name" _device-info._tcp. local 445 model=Xserve &
dns-sd -R "name" _smb._tcp. local 445 &
dns-sd -R "name" _adisk._tcp local sys=waMa=0,adVF=0x100 &
dns-sd -R "name" _adisk._tcp local dk0=adVN=<smb-share>,adVF=0x82 &
 
Last edited:

Freebsd1976

Active Member
Feb 23, 2018
227
33
28
after update to 151036 ,napp-it 19.12homeuse show error:
Tty.c: loadable library and perl binaries are mismatched (got handshake key ff80080, needed 12400080)
try logout ,reboot , still errors, now reinstall napp-it ,how to slove this ?

btw, install download very very slow , maybe a offline install tarball is a good idea

btw2 delete /var/web-ui and reinstall 18.12 ,everything run smooth ,now upgrade to 19.12 homeuse

btw3 after upgrade to 19.12.homeuse ,napp-it stop , report
Can't open perl script "/var/web-gui/data/napp-it/zfsos/_lib/scripts/stop_napp-it.pl": No such file or directory
, in /var/web-gui/data/ there not napp-it dir
 
Last edited:

Patrick

Administrator
Staff member
Dec 21, 2010
12,003
4,988
113
@gea here is another one that got lost.

after update to 151036 ,napp-it 19.12homeuse show error:
Tty.c: loadable library and perl binaries are mismatched (got handshake key ff80080, needed 12400080)
try logout ,reboot , still errors, now reinstall napp-it ,how to slove this ?
OmniOS 151036 includes a newer Perl.
The Perl module Expect.pm is required for interactive command (ex passwd user, join domain) etc
This is why you need a current napp-it on some menus like user or services with support for the newer Perl release.

btw, install download very very slow , maybe a offline install tarball is a good idea
A setup installs add-ons ex from the OmniOS extra, this require online updates

btw2 delete /var/web-ui and reinstall 18.12 ,everything run smooth ,now upgrade to 19.12 homeuse

btw3 after upgrade to 19.12.homeuse ,napp-it stop , report
Can't open perl script "/var/web-gui/data/napp-it/zfsos/_lib/scripts/stop_napp-it.pl": No such file or directory
, in /var/web-gui/data/ there not napp-it dir
Re-run the online wget installer.
This can happen if an online update is interrupted or does not complete properly. This installs napp-it free. You can then update/activate a different release in a second step. Settings are always preserved.
 

BobTB

Member
Jul 19, 2019
37
4
8
btw, install download very very slow , maybe a offline install tarball is a good idea
It indeed is slow (very) if you are using it on a not directly supported graphics card. After they started using the new installer it became incredibly slow. You can fix it by running:

echo boot_resolution=off > /boot/conf.d/vga
or
echo boot_resolution=800x600x8 > /boot/conf.d/vga

reboot and then run installer, it will fly through. 8-bit colour is the key to make it faster!
 

Freebsd1976

Active Member
Feb 23, 2018
227
33
28
It indeed is slow (very) if you are using it on a not directly supported graphics card. After they started using the new installer it became incredibly slow. You can fix it by running:

echo boot_resolution=off > /boot/conf.d/vga
or
echo boot_resolution=800x600x8 > /boot/conf.d/vga

reboot and then run installer, it will fly through. 8-bit colour is the key to make it faster!
I mean download update zip file from napp-it.org very very slow , so I wget it manually to local http server and mod admin.pl redirect download to local http server
 

BobTB

Member
Jul 19, 2019
37
4
8
Is it better if you try to mount it with cifs:// instead of smb:// - just to test if smb1 works as it was
 

gea

Well-Known Member
Dec 31, 2010
2,535
856
113
DE
I mean download update zip file from napp-it.org very very slow , so I wget it manually to local http server and mod admin.pl redirect download to local http server
A napp-it update is around 6MB. Within Germany an update is done in less than 5s. Even from other countries it should not be a problem. For large files ex the ESXi templates I offer a Gdrive download.
 

Freebsd1976

Active Member
Feb 23, 2018
227
33
28
A napp-it update is around 6MB. Within Germany an update is done in less than 5s. Even from other countries it should not be a problem. For large files ex the ESXi templates I offer a Gdrive download.
Unfortunately due to The F*** GFW , download update zip file from China indeed very very slow. I use wget to download update zip file (it will take hours in China) and save it to local disk and mod admin.pl.