Need help on Dell H310

Discussion in 'RAID Controllers and Host Bus Adapters' started by TeleFragger, Jun 5, 2019.

  1. TeleFragger

    TeleFragger Member

    Joined:
    Oct 26, 2016
    Messages:
    134
    Likes Received:
    16
    ok so I was just handed a dell h310 card and went to flash it in IT mode. I googled and landed on various pages and read and tried what they said.
    I cannot get this card to flash and I think somewhere I messed up and I don't have a sass address now.

    is there a way I can flash this card back to OEM? I have tried various ways but it just errors out.

    I have tried going to dell and installing the h310 oem firmware and it runs in windows.. errors.. package is not compatible with your system configuration. Running it on win7 64bit and tried 64bit file. unless it needs Server?
     
    #1
  2. TeleFragger

    TeleFragger Member

    Joined:
    Oct 26, 2016
    Messages:
    134
    Likes Received:
    16
    forgot to mention..there is no sas address... it fails on that line so wonder if that is what is botching the card as well.
     
    #2
  3. nthu9280

    nthu9280 Well-Known Member

    Joined:
    Feb 3, 2016
    Messages:
    1,418
    Likes Received:
    358
    Flashing some H310s can real PITA. Check out TechMattR blog it should have all the tools and step by step instructions.

    Not having a SAS generally doesn't hinder the flash process.

    The card may have a sticker with SAS address. You can makeup up one if needed. It just needs to be unique in your environment, correct length.
     
    #3
    TeleFragger likes this.
  4. Spartacus

    Spartacus Active Member

    Joined:
    May 27, 2019
    Messages:
    285
    Likes Received:
    82
    I have several of the H310 and I botched it the first time too.
    I've done both the flash recover and itmode procedure, unfortunately if you wiped it the SAS address it may be gone, good news is it doesn't matter. Its just like a network address as long as you don't have the same addresses connected to the same machine it wont be a problem.

    I'll grab one of my addresses when I get home plus the guides I used for flashing/recovering them.
    The good news is, its nearly impossible to brick them so no need to fret.
     
    #4
    TeleFragger likes this.
  5. TeleFragger

    TeleFragger Member

    Joined:
    Oct 26, 2016
    Messages:
    134
    Likes Received:
    16

    thx.. this was the fix..


    disclaimer - i see what was wrong and got it going!!!!
    also it is nice to have the actual files someone used so we know the tool version is whats needed. When I flashed my HP infiniband 10gb cx4 cards, it was a learning curve as i had to use a certain older tool set to flash...
    onto it..



    megacli.exe -AdpAllInfo -aAll -page 20
    Fails

    so tried
    sas2flsh -sasadd 0123456789abcdef
    fails

    sas2flsh.exe -listall
    worked

    sas2flsh.exe -c 0 -list
    worked but no sas address

    megarec.exe -writesbr 0 sbrempty.bin
    worked

    megarec.exe -cleanflash 0
    worked

    sas2flsh.exe -o -f 6GBPSAS.fw
    finally told me didnt match so chose Y to flash
    worked

    as2flsh.exe -o -f 2118it.bin
    worked - even gave me a sas address - 0000000-0-0000-0000
    still cant change it...

    sas2flsh -sasadd 0123456789abcdef
    operation not found 0500000f

    Then i realized.. i read through again and ughhh found a different command line. I got mine from google...
    s2fp19.exe -o -sasadd 500xxxxxxxxxxxx
    so
    s2fp19 -o -sasadd 500123456789abcd
    WORKED!!!!

    thx.. im 100% up and running!!!! well card successfully ran through everything. need to get it into my hp box and get freenas on it.
     
    #5
  6. TeleFragger

    TeleFragger Member

    Joined:
    Oct 26, 2016
    Messages:
    134
    Likes Received:
    16
    #6
  7. Spartacus

    Spartacus Active Member

    Joined:
    May 27, 2019
    Messages:
    285
    Likes Received:
    82
    Yep HDD activity light.
     
    #7
    TeleFragger likes this.
Similar Threads: Need help
Forum Title Date
RAID Controllers and Host Bus Adapters Need help with lsi 9261-8i Nov 15, 2019
RAID Controllers and Host Bus Adapters Need help: looking for SBR for LSI SAS2308 Rev B0 (9205-8e, or H221 with Rev B0) Jun 14, 2019
RAID Controllers and Host Bus Adapters Need help with RAID enclosure.... Jan 6, 2019
RAID Controllers and Host Bus Adapters need some help with HP H240 in HBA mode with Linux Oct 1, 2018
RAID Controllers and Host Bus Adapters [SOLVED]need help finding breackout cables. Aug 21, 2018

Share This Page